acodec=mp3 audio_bit_rate=128000 frequency=44100

Dear friends,

When exporting to custom Xvid, I used the following export options:
video_rc_min_rate=0 video_bit_rate=400000 size=720x576 vcodec=xvid acodec=mp3 audio_bit_rate=128000 frequency=44100 mbd=2 progressive=1

It seems that audio is buggy. I have to remove this option:
acodec=mp3 audio_bit_rate=128000 frequency=44100

To my knowledge, the bug appeared after an MLT commit, a few weeks ago.

Kind regards,
Jean-Michel

Forums:

This bug is painful. I cannot encode mp3 sound in my movie.

Try recompile ffmpeg with lame support. Something like ./configure .... --enable-liblame. Check ./configure --help.
Lame is mp3 encoder.
You must have liblame and liblame-dev installed on your system indeed.
Ffmpeg doesn't have own mp3 support, it rely on extrenal libs like mp3.
Well, I'm just guessing, there migth be a mlt bug as well.

Sorry, it's
--enable-libmp3lame

Just for inspiration, these are option used for SUSE Packman version of ffmpeg working well with kdenlive:

configuration: --shlibdir=/usr/lib --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib --enable-shared --enable-libmp3lame --enable-libogg --enable-libvorbis --enable-libtheora --enable-libfaad --enable-libfaac --enable-xvid --enable-liba52 --enable-libdts --enable-pp --enable-gpl --enable-vhook --enable-x11grab --enable-libgsm --enable-x264 --enable-amr_nb --enable-amr_wb