Announcing Ubuntu packages for kdenlive 0.8.2

Hi,

Packages for the new kdenlive release (0.8.2) are ready. See here for a fresh install.
If you were already using this ppa, just update your system.

Notes:

  • These packages have been built with the official ffmpeg version of each Ubuntu release.
  • If you are using some backported version of ffmpeg you can't use my packages.
  • To have all codecs activated for project rendering : sudo apt-get install libavcodec-extra-*
  • Thanks to all kdenlive and mlt teams for this cool release.

    lots of thanks for the packages :)

    Hi

    I have a problem on two computer, one on 11.10 and the other on 10.04, 0.8.2 svn version from your repository

    i have an error immediately after the begin of creation process of proxy file (l'intermédiare a planté)...but i don't know how to see the error log ...

    if you can help

    thanks

    Might be a problem with the proxy parameters. You can go in the Project Settings (in the Project menu) and click on the info button that is near the proxy encoding profile.

    This will display the proxy params. Copy these params, then in a terminal type:

    ffmpeg -i myclip.mpg ( ... copy the proxy params here ...) test.mpg

    where myclip.mpg is one of the clip you try to use in your project. This is the exact process that Kdenlive is launching when trying to create a proxy clip, so it might give you some hints

    Do you know if Kdenlive 0.8.2 works fine if I install the latest ffmpeg, x264 and libvpx?

    Installing those is explained in an article called "HOWTO: Install and use the latest FFmpeg and x264" at ubuntuforums dot org, but I can't link the article without triggering this forums spam police.

    Hi

    here is the result when i try to generate a proxy in shell with parameter standart of the project ("normalMPEG")

    it's a 10.10 ubuntu

    f@tf-laptop:~/Bureau/sept$ ffmpeg -i 00104.MTS -f mpegts -acodec libmp3lame -ac 2 -ab 128k -ar 48000 -vcodec mpeg2video -g 5 -deinterlace -s 480x270 -vb 400k test.mpg
    FFmpeg version SVN-r23417, Copyright (c) 2000-2010 the FFmpeg developers
    built on Sep 14 2010 13:46:23 with gcc 4.4.5
    configuration: --enable-libfaac --enable-libx264 --enable-gpl --enable-pthreads --enable-nonfree
    WARNING: library configuration mismatch
    libavutil configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --enable-shared --disable-static
    libavcodec configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --enable-shared --disable-static
    libavformat configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --enable-shared --disable-static
    libavdevice configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --enable-shared --disable-static
    libavfilter configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --enable-shared --disable-static
    libswscale configuration: --extra-version=4:0.6-2ubuntu3.2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libdirac --enable-libgsm --enable-libopenjpeg --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-vaapi --enable-pthreads --enable-zlib --enable-libvpx --disable-stripping --enable-runtime-cpudetect --enable-libmp3lame --enable-gpl --enable-postproc --enable-x11grab --enable-libfaad --enable-libxvid --enable-libx264 --enable-librtmp --enable-libdc1394 --enable-shared --disable-static
    libavutil 50.16. 0 / 50.15. 1
    libavcodec 52.72. 1 / 52.72. 2
    libavformat 52.67. 0 / 52.64. 2
    libavdevice 52. 2. 0 / 52. 2. 0
    libavfilter 1.20. 0 / 1.19. 0
    libswscale 0.11. 0 / 0.11. 0

    Seems stream 0 codec frame rate differs from container frame rate: 50.00 (50/1) -> 50.00 (50/1)
    Input #0, mpegts, from '00104.MTS':
    Duration: 00:00:04.71, start: 1.000033, bitrate: 16857 kb/s
    Program 1
    Stream #0.0[0x1011]: Video: h264, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x1100]: Audio: ac3, 48000 Hz, stereo, s16, 256 kb/s
    Stream #0.2[0x1200]: Subtitle: pgssub
    Error opening filters!

    i have the same error with ffmpeg -i 00104.MTS -vcodec mpeg2video test.mpg

    thanks

    For me upgrading from the ppa to version 0.8.2 makes kdenlive not starting any more. From the terminal emulator I have:


    (kdenlive:18398): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (kdenlive:18398): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (kdenlive:18398): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    (kdenlive:18398): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
    kdenlive(18398) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
    kdenlive(18398) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 109052032
    project monitor connected
    clip monitor connected
    detected format: YUV 4:2:2 (YUYV): YUYV
    Size: 640x480: 1/30,
    Size: 352x288: 1/30,
    Size: 320x240: 1/30,
    Size: 176x144: 1/30,
    Size: 160x120: 1/30,
    Size: 800x600: 1/5,
    Size: 1024x768: 1/5,
    Size: 1280x1024: 1/5,
    detected format: MJPEG: MJPG
    Size: 640x480: 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30, 1/30,

    and the kdenlive process stays at 100% CPU time for ever (I tried leaving it alone for more than a hour).
    I have already deleted all my kdenliverc & C. files with no results. Is there anything else I could try?

    @michelinux: This issue has already been reported, this is caused by your webcam giving an unexpected answer, and Kdenlive not correctly handling it. A new release of Kdenlive will be made soon (probably on the 14th of november) to fix this problem and several other.

    pretty sure it will NOT work. I have tried this before to no avail. It matters what version of FFMPEG kdenlive and mlt are compiled against hence why sunab mentions that the packages are compiled against the FFMPEG version within normal Ubuntu. IF you wanted to use a later build of FFMPEG and x264 you'd have to build kdenlive and mlt from scratch as well I am pretty sure.

    very strange problem. Updated everything, I am on 10.04 which has KDE 4.4.5, when I open an old project file, it tells me it saved a backup with 0 on it. I can drag clips into kdenlive from nautilus and then work with them in kdenlive and everything is ok BUT if I choose the Add Clip from the Project pull down menu, instant crash and no useful info in log file. Just a segfault. I'll stick to drag and dropping my clips I guess. LOL

    hi

    This command solve my problem of generating proxy file:

    sudo apt-get install libavcodec-extra-*

    thanks to all ...

    No one else running into issues with 10.04 and the new 0.8.2? Still crashing for me upon hitting "add clip" or even when I want to switch to another project, hitting "open" CRASH. Debug info says no useful info in crash log.

    The Ubuntu 10.04 crash is a known issue. A fix has been commited last night to our new git repository, the sunab experimental repository should have the update in a few hours (packages compiling right now).

    So for all ubuntu users who want to try it, you can get the sunab experimental packages:
    https://launchpad.net/~sunab/+archive/kdenlive-svn

    They contain fixes for almost all Kdenlive problems announced since the 0.8.2 release (just wait for the current compilation to finish to get all fixes - I recommend version git20111110.d42c81ff)

    As soon as we get positive feedback on the reported issue with this experimental package, I will make a new stable 0.8.2.1 release with those fixes.

    regards
    jb

    WOW, thank you so much for the great efforts made to ensure kdenlive is awesome editing software for users, even those using 1+ old versions of Ubuntu (i think 10.04 is that old isn't it?)

    ok, i removed all existing mlt and kdenlive. removed the stable ppa, and added new svn ppa. installed and all is well now, it doesn't crash anymore with add clip or open BUT now when I play what I have in my timeline, the position indicator does NOT move.
    Any thoughts OR hopefully it will get fixed with the new .8.2.1 you're going to publish.

    well, I updated to the latest a minute ago and I am now running 0.8.3+git20111111.08fd8d1c-0ubuntu0~sunab~lucid1
    It has fixed the position indicator not moving when playing your timeline in the project monitor BUT now when I apply a dissolve transition, it doesn't show it in my timeline. it doesn't show up in the effects list either. It does appear to have applied a dissolve between my 2 clips which is really weird. Not sure where I should submit this? I understand I am using experimental svn and there will be issues. That's all fine and what not, just want to aid in reporting bugs properly. Time is off the essence so I need to go finish my video before someone else on YT uploads it first. Lots happening on the COD YT front. LOL

    UPDATE: I've had to go back to sunab stable because now that I can't see the transitions added to clips (screen for example) there is no way to edit what tracks it affects now can I drag it so that it affects more clips to the right. Also, I need to use the affine to locate a video watermark which I can't do because I can't see the affine transition after I add it to my clips.

    @ ubuntuaddicted : a bug report has been filed for the transitions not showing.
    http://www.kdenlive.org/mantis/view.php?id=2404

    yeap, I am using your svn experimental and all is well for now. THANKS!!