Another jerky AVCHD output

Hi there!

I really appreciate you supporting AVCHD because editing movies I took with my camera has been an unsolvable problem for me for about two years now.

Also I am fascinated about the developments you recently did. Good work there.

 

But here's my problem:

At first, my problem was loading the MTS files at all. That problem was solved by simply renaming the files to .avi, I hope that was right.

Then, after some editing, I tried rendering the movie. I tried about 30 combination of different formats and profiles, but all of them are jerky. I can play the raw file in VLC without any problems.

I uploaded 2 sample files:

Raw

Output

 

I am using Kdenlive 0.7.2.1 and Ubuntu 8.10.

Thanks for help!

Forums:

Both of those play back on my Dell Studio 15 laptop (Intel core2 duo P8400 with 4GB RAM) with no difficulty.  No jerkiness nor stuttering in either using ffplay.

Hm, I am also using a powerful machine, but the output doesn't work as well as the original file does here.

I also just found out that rescaling the movie does't work. I thought this might be a problem because of the high resolution, but whenever I acticate the option "Rescale" and enter anything I want, the output movie is 1920 × 1080.

AVCHD editing support is not yet resolved in FFmpeg and MLT. Editing requires heavy seeking. Just because you can play it sequentially with ffplay does not make it editable. Sorry. Work on it was progressing well, a month or so ago, but it has stalled.