binaries for ubuntu 8.10

hi
You can get binaries from ...
sudo nano /etc/apt/sources.list
deb http://ppa.launchpad.net/baudm/ubuntu intrepid main
deb-src http://ppa.launchpad.net/baudm/ubuntu intrepid main
sudo apt-get update && sudo apt-get install kdenlive
 
I tested 10 mn and it seems to work ...
Thank to cyrille borne ...

http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages
Warning: ffmpeg is rather old on Intrepid. I can only encourage you to contact ffmpeg maintainer and ask for ffmpeg upgrades.

What is the difference between the PPA mentioned above and the one mentioned on the Kdenlive website? Any at all? I'm using the one above and it works fine...

No difference. These packages as Kdenlive recommended unofficial binaries.

Please note that this release does not include video effects (provided by FreiOr) and that h264 and AVCHD are broken. For normal use in DV and HDV, this should okay. I wrote the maintainer to ask for FreiOr package release.

The Ubuntu packages page states that there is an updated ffmpeg snapshot included in the repos listed there. This doesn't seem to be the case. This pretty much makes Kdenlive useless for my purposes. It would be great to actually have an updated ffmpeg in these repos. Failing that, someone might want to make a note of this on the actual download page.

According to the packages in the PPA mentioned above (as seen here: https://launchpad.net/~baudm/+archive) there are packages for ffmpeg and frei0r built but I'm not sure if they work... It doesn't seam like it.
EDIT: I notice both PPAs have the frei0r plugin package now but everytime I install it the extra effects don't appear in Kdenlive. How can I get these effects?

It's sure a great package .
It's amazing the progress to this version of kdenlive.. QT4 is very nice. And 0.7 is a great version.
I've a lot of use of kdenlive with 0.4 and 0.5 version.. so .
 
 And the web-site is in great progress too. So It's finally a great work ! Thanks a lot
 
But where are the packages effects ?

Thanks. Now I understand. I updated Ubuntu page:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages
 
Would you agree to be Kdenlive official maintainer for Ubuntu packages?

Currently, the frei0r module for MLT makes Kdenlive crash at startup. I believe this has something to do with buggy plugins, AFAIK. The only way to make Kdenlive usable again was to exclude the frei0r plugin from the mlt package. I want to fix this but I don't know how to make yml files for the frei0r plugin.

Please file an issue for this at http://kdenlive.org/mantis

In general frei0r does not crash Kdenlive, but some modules does. Note, that Kdenlive blacklists several frei0r modules that are known to cause problems - you may be hitting one we do not know about?

Regards

Mads

I installed the packages from this repository, but I'm still getting error:

kdenlive: symbol lookup error: /usr/lib/i686/cmov/libavcodec.so.52: undefined symbol: av_lfg_init
 

which is caused by libavcodec, but I guess I have the latest one too(libavcoded also from the same repo).

It's all on ubuntu 8.10 32bit.  :(

 

 

I've read somewhere that the Kdenlive blacklist doesn't actually work. Also, I've also stumbled upon a patch for MLT that contains some yml files for its frei0r module.

Where did you read about that? I am under the impression it *does* work?

Regards

Mads

Here you go: http://www.mail-archive.com/kdenlive-devel@lists.sourceforge.net/msg0074...

Anyway, using the yml file doesn't work and the patch seems to be outdated. But I'm sure that the frei0r module is the cause of the crash since Kdenlive starts up fine when I delete the frei0r module from my system.

It is great to see 0.7 packages for Ubuntu at last- I know there have been lots of people including myself waiting what seems like eternity for this! :D

 

Couple of probs though as it seems the current package is linked to the regular versions of both libavcodec and libavformat. Surely it should be compiled against the 'unstripped' versions of both libs so that we can encode and decode more formats? All the unstripped libs should be used in preference over the crippled ones.

 

Also, whats going on with KDEnlive getting into Jaunty - are we still going to be stuck with the now totally outdated 0.5 version or might we see 0.7 make it in yet?

i confirm this with wizzard svn built, i removed frei0r package and no more crash..

Excellent news!

I'm sure I checked before I posted yesterday- has it just made it in today?

It looks like the jaunty package will work fine if you have the unstripped libraries installed but the 8.10 repo insists I have the regular versions or it won't install but I need the unstripped libs to use winff properly.

I have same issue:

kdenlive: symbol lookup error: /usr/lib/i686/cmov/libavcodec.so.52: undefined symbol: av_lfg_init

on Ubuntu 8.10

any suggestion?

I am presently installing several distros in Qemu to test packages. Will be back shortly.

IMHO Ubuntu is only a Debian station with graphics.

If you remove all your stuff in /usr/local and add Debian Marillat repositories, you should be able to install Kdenlive and MLT packages.

Anyway, we will need to validate packages.

The unstripped ffmpeg packages are already available in my PPA. This was also based on the Ubuntu Jaunty package but includes faad and x264 (>= ppa2). amr?b-related and other nonfree code cannot be enabled because this would make the resulting package unredistributable (only redistributable packages can be hosted on the PPAs).

I update the Ubuntu package page:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Can you tell me how to force installation of FFmpeg unstripped?
Also, are there additional lines, like deb repos to add?

Thanks, Jean-Michel

i think you should put back the link to intrepid repos on the download page as ubuntu jaunty is in alpha stage and will be available only in april 2009.

Since having separate *-unstripped* packages tends to complicate things, I decided to just make the ffmpeg-debian source package become the ffmpeg source package. Basically, this means that all the ffmpeg packages now are unstripped. amrnb/amrwb/nonfree codes are still disabled though.

Btw, the packages for 0.7.1 are currently being built and will be available soon from my PPA. The frei0r problem still persists though...

Thank you very much.

Still, it should be possible to add sources to /etc/apt/sources.list and perform an installation. What are the sources.list for Jaunty?

I managed to install 7.1 from the ppa, but still no succes with running.

 

here's console output:

kdenlive(15339) MainWindow::parseProfiles: RESULTING MLT PATH:  "/usr/share/mlt/profiles/"
mlt_repository.c, mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so
kdenlive(15339) initEffects::parseEffectFiles: //  INIT EFFECT SEARCH
kdenlive(15339) Render::Render: //////////  USING PROFILE:  dv_pal
kdenlive(15339) Monitor::Monitor: /////// BUILDING MONITOR, ID:  75497738
kdenlive(15339) Render::Render: //////////  USING PROFILE:  dv_pal
kdenlive(15339) Monitor::Monitor: /////// BUILDING MONITOR, ID:  75497834
kdenlive(15339) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID:  75497875
QStatusBar::insertPermanentWidget: Index out of range (5), appending widget
QStatusBar::insertPermanentWidget: Index out of range (7), appending widget
kdenlive(15339) KdenliveDoc::setProfilePath: KDEnnlive document, init timecode from path:  "dv_pal" ,   25
kdenlive(15339) KdenliveDoc::KdenliveDoc: KDEnnlive document, init timecode:  25
kdenlive(15339) Render::setSceneList: // NEW SCENE LIST DURATION SET TO:  0
KCrash: Application 'kdenlive' crashing...
sock_file=/home/vilda/.kde/socket-vilda-laptop/kdeinit4__0
kdeinit4: preparing to launch /usr/lib/kde4/libexec/drkonqi

 

it seems the problem is with kdeinit4, there's a popup telling signal 11(SIGSEGV).

... agh!

I try to install kdenlive since the 0.7 was released, and still no succes. Built it myself, downloaded from all available repos...

I'm not going to try it with jaunty now, since I really don't want to destabilize my system again, I already had trouble with using opencv because of alternative ffmpeg...

If anybody can help, I'll be very greatfull.

 

 

I had the same problems too but i noticed that one of my repositories updated some of my libraries.  One of the libraries was ffmpeg.  Do you have the repository in your source list mentioned above?

Good news everyone! I've been able to trace which frei0r plugin makes Kdenlive crash at startup--the facedetect plugin. As a workaround, so that frei0r effects can now be used in Kdenlive, I've updated the frei0r (to exclude the facedetect plugin), mlt, and kdenlive packages. The binary packages are currently being built and will be available shortly. I've tested this on amd64.

I also managed to install 0.7.1 from the ppa, but still no succes running.

So I went ahead and downloaded the latest sources:

kdenlive-0.7.1.tar.gz,  mlt-0.3.4.tar.gz &  mlt++-0.3.4.tar.gz

took care of some of the needed libs and compiling still had some warnings, which I didn't think they matter.

when I run, I am getting the errors below, which similar to yours  related to MLT.

Today, there were new updates of libmlt1 & libmlt-data & frei0r.1.22 from ppa.

I am going to remove everything and probably try the Kdenlive Wizard v0.7.1

By the way, I am running Kubuntu 8.10 with KDE 4.2 Beta 2.

& file /abe/.kde/socket-abe-kubuntu41/kdeinit4__0 contents are shown below

 /abe/.kde/socket-abe-kubuntu41/kdeinit4__0: No such file or directory

 

I appreciate any feedback to resolve this issue.

Thanks,

-Abe

 

............................. Start of error msg ...........................

sock_file=/home/abe/.kde/socket-abe-kubuntu41/kdeinit4__0
abe@abe-kubuntu41:~/FOSS-downloads/KDEnLive$ /usr/local/bin/kdenlive
kdenlive(6916) MainWindow::parseProfiles: RESULTING MLT PATH:  "/usr/share/mlt/profiles/"
kdenlive(6916) initEffects::parseEffectFiles: //  INIT EFFECT SEARCH
kdenlive(6916) Render::Render: //////////  USING PROFILE:  dv_pal
KCrash: Application 'kdenlive' crashing...
sock_file=/home/abe/.kde/socket-abe-kubuntu41/kdeinit4__0


............................. KDE Crash Handler msg ...........................

Application: Kdenlive (kdenlive), signal SIGSEGV

 

Thread 1 (Thread 0xb5e026c0 (LWP 6916)):

[KCrash Handler]

#6 mlt_properties_fetch (this=0x0, name=0x82c7324 "resize") at mlt_properties.c:346

#7 0xb7f369df in mlt_properties_set_int (this=0x0, name=0x82c7324 "resize", value=1) at mlt_properties.c:736

#8 0xb7f19d74 in Mlt::Properties::set () from /usr/local/lib/libmlt++.so.1

#9 0x080e2d04 in Render::buildConsumer (this=0x8d93398) at /home/abe/FOSS-downloads/KDEnLive/kdenlive-0.7.1/src/renderer.cpp:114

#10 0x080f0fac in Render (this=0x8d93398, rendererName=@0x8d87e10, winid=81789192, extid=-1, parent=0x8d87de0) at /home/abe/FOSS-downloads/KDEnLive/kdenlive-0.7.1/src/renderer.cpp:66

#11 0x080d7d7f in Monitor (this=0x8d87de0, name=

{static null = {<No data fields>}, static shared_null = {ref = {_q_value = 7050}, alloc = 0, size = 0, data = 0x8329f7a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 91}, alloc = 0, size = 0, data = 0xb73de9ce, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0xbfa65cf8, static codecForCStrings = 0x0}, manager=0x8aa3a60, parent=0x8a72f28) at /home/abe/FOSS-downloads/KDEnLive/kdenlive-0.7.1/src/monitor.cpp:108

#12 0x080b5be1 in MainWindow (this=0x8a72f28, MltPath=@0xbfa65ddc, Url=@0xbfa65dbc, parent=0x0) at /home/abe/FOSS-downloads/KDEnLive/kdenlive-0.7.1/src/mainwindow.cpp:167

#13 0x080a18b2 in main (argc=1, argv=0xbfa65f24) at /home/abe/FOSS-downloads/KDEnLive/kdenlive-0.7.1/src/main.cpp:71

............................. End of error msg ...........................

 

Hello,

Thanks for the packages. What the output of the ffmpeg command, please?

Kind regards,

Jean-Michel

Hmm. This makes me somewhat worried. Could you please check out this issue:

http://www.kdenlive.org/mantis/view.php?id=476

In short, the facedetect module should already be blacklisted in 0.7.1?

Regards

Mads

Hi. Do you have a forum for Newbies? The install page is not too easy to follow for newbies.

Anyway, I finally managed to get it installed by using this command:

sudo apt-get update && sudo apt-get install kdenlive dvgrab frei0r swh-plugins

(I didn't know what to do with the first three commands, if they were commands) and to find it in my files and make a launcher for it. But I find that it is Version .6.0-svn. Is there a way to get Version .7 (I'm on Ubuntu Intrepid with i386 architechture)? The Wizard didn't work for me.

Thanks in advance - sorry to be so dumb, and I'll continue to use this version if I can't get the later. I enjoyed using Kdenlive on Gutsy with an earlier version. It worked well, apart from frequent crashes, which were manageable if I remembered to save every couple of minutes.

Cheers,
Kath

 

 

1.Go to your system menu > Software sources > Third-Party Software
2.click add and paste this line in:
deb http://ppa.launchpad.net/baudm/ubuntu intrepid main

3. close software source and click reload

then you can
sudo apt-get update && sudo apt-get install kdenlive dvgrab frei0r swh-plugins

and you will have the latest version of kdenlive

Hello all,

thank you for the PPA ;-)

I have problems when upgrade to latest packages:

Preparando para reemplazar kdenlive 0.7.1-0.0~ppa3 (usando .../kdenlive_0.7.1-1ubuntu1~intrepid1_i386.deb) ...

dpkg: error al procesar /var/cache/apt/archives/kdenlive_0.7.1-1ubuntu1~intrepid1_i386.deb (--unpack):                                                    
 intentando sobreescribir `/usr/share/man/man1/kdenlive.1.gz', que está también en el paquete kdenlive-data

 

Cheers

i had it as well, do the update again and it should be ok.

FYI, kdenlive 0.7.2 binaries now available from my PPA.

There is a new announcement that it is recommended to "update your Kdenlive version to 0.7.2.1"

It would be great if you could post the new binary to your site baudm.

Yes, I would like to see them too.

If you install the Ubuntu deb of 0.7.2. from afresh, it crashes on the first run wizard - i couldnt find any way to cancel the wizard either, so couldnt use it.

As an upgrade to a previous version you dont get this problem

mlt/mlt++ 0.3.6 and kdenlive 0.7.2.1 packages are currently building and will be available shortly.