Buggy clip preview

Clip preview is not working when project is stored and loaded again.
Seems to clip duration shrinks to 0:00:00 for any clip from previewer perspective.

How to reproduce:
Take any video clip, add it to empty just created project
Video clip preview works as expected
Save project
Restart kdenlive
Load project
Try to play video clip

Forums:

Small demonstration of the issue see this screenshot:

http://espinosa.klenot.cz/videotest/kde ... or_bug.png

This is a real show stopper for 0.5 release!

Tested on today SVN ffmpeg, mlt, kdenlive sources, kdenlive_builder.sh - bug still present :(

Note:
just to remind to reproduce you need to save project and then load it back.

I cannot reproduce that problem. Sometimes when loading a project, you need to click on the clip in the project list view to make clip monitor work, but that's not a big issue I think. Can't you make the clip monitor work by simply clicking on the clip in the project's tree view ?

I cannot make it work by any mean of clicking, doubleclicking, dragging. The clip had focus for sure. Sorry :(

Tested on several projects, tested on several settings - show/hide timecode, drop timecode etc.. - which may have influence.
Tested on both trivial and more complex projects. All videoclips were VOBs (mpeg2)
To me it seems that clip monitor consider the clip as a zero length. Check the length indications in my screenshot.
Timeline player is always OK so it is not an issue of like wrong video driver or sound.

Can you print some info into std when a clip is going to be played? Like:
kdenlive: clip monitor is going to play abcdxyz.vob clip, length 00:01:23s
to give me some feedback?

Can you test it with a trivial one-clip-project using my testing 7.2MB shot?

http://espinosa.klenot.cz/videotest/tes ... golany.vob

Thank you very much..

BTW:
How the player is done? Is it called as an external application embedded in kdenlive? ffplayer? inigo?

Cannot reproduce your problem... Both clip monitor and timeline monitor work in the same way (using the MLT libraries and sending the SDL output to the monitor widget). The thing is that you can only have one monitor playing (connected). You can tell which one is connected by looking at the small green rectangle above the timecode. If the rectangle is dark green, the monitor is not connected and will not be able to play video. If it is light green, it is connected. On your screenshot, the clip monitor does not seem to be connected, but I don't understand why it is so.

Could you try to rename your $HOME/.kde/share/config/kdenliverc file to see if it does fix the problem ?

Quote:
Could you try to rename your $HOME/.kde/share/config/kdenliverc file to see if it does fix the problem ?

Unfortunatelly not :(

So SDL is responsible for playback in monitors!

Even Timeline Monitor is little bit buggy. See my another bugreport. When I swith monitors, it is "black" and not connected but I need just to click anywhere on timeline, or click play, and picture and connection is back. This trick is not applicable to Clip Monitor. Connected or not connected I never get a picture when project is loaded.

This might be SDL issue. If I pick a X11 video driver in config HW dialog? SDL is not mentioned there, just auto, X11, SVGALib and some exotic options.

SDL 1.2.11
SDL_image 1.2.5
SDL_mixer 1.2.7

Notice:
When the project is created, clip monitor works, at the bottom of clip monitor there is green timeline full stretched indicating the clip length (16sec in the test_video_golany.vob). When project is stored, kdenlive restarted, clip monitor indicate no duration for the selected (highlighted) clip. There is no green line below at all. It is clearly visible on my screenshot.

This is my project XML:

Luckily I don't use clip monitor much and timeline monitor is mostly OK so the situation is not so bad.

Interesting:
When the clip is in videotrack and I pick a razor tool or marker tool Clip Monitor is back! From that point I can work with CM as usual until I exit Kdenlive.
When I run Kdenlive again, load project, CM is nonfunctional until I run razor tool or marker.
If the clip is not on timeline on any track - no way how to revitalize CM.

Ultimate description:
It is easy to get clip into a Clip Monitor if clip is on Timeline, just click on it and it appears in CM, or use marker or razor tool.
It is easy to get clip into a Clip Monitor if video clip was freshly added to sources, just click on it in list.
But there is no way get a clip to CM if this clip was added in previous Kdenlive session and it is not present (full or part) in Timeline.

Still no luck. Even with latest SVN sources :(

Please JB, can you add "Play video clip" functionality to popup menu (Project Tree panel)? to explicitly run selected clip.
This function should also print something useful to stdout, like clip name and length.

Thank you

This issue is still present for me.
I have upgraded fully my SUSE system, notably KDE (3.5.7), Qt, and -dev packages.

espinosa@esplaptop:~/src> ./kdenlive_build.sh info
FFmpeg SVN version:
Revision: 9470
Last Changed Date: 2007-07-03 18:59:28 +0100 (Tue, 03 Jul 2007)
MLT SVN version:
Revision: 1005
Last Changed Date: 2007-07-01 19:17:44 +0100 (Sun, 01 Jul 2007)
MLT++ SVN version:
Revision: 1005
Last Changed Date: 2007-06-12 07:00:29 +0100 (Tue, 12 Jun 2007)
Kdenlive SVN version:
Revision: 1627
Last Changed Date: 2007-07-04 08:55:11 +0100 (Wed, 04 Jul 2007)

I have created a path and sent it to mail list.

- Add "play clip" action (context menu, project menu) for any clip in
project tree
- print some debug info, what is played and the length (to track other
similar issues)
- update status line with current clip name
- improve documentation (in Doxygen style)