building kdenlive on 64 bit - solved

I'm building kdenlive 0.9 on SUSE 11.4 64 bit. I configured using this:


Make chugs along fine until it gets to this:

[ 97%] Building CXX object src/CMakeFiles/kdenlive.dir/qrc_resources.o
make[2]: *** No rule to make target `/usr/lib/', needed by `src/kdenlive'. Stop.
make[1]: *** [src/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2

Mlt was biuld using

./configure --prefix=/usr --libdir=/usr/lib64 --enable-gpl

and is in /usr/lib64. How do I tell cmake/make to look in /usr/lib64 for mlt?

Well, this is embarrassing. I ended up solving this by deleting the build directory and simply doing it again. I guess what happened is that I rebuilt mlt into the /usr/lib64 directories *after* the kdenlive build failed to find it, but kdenlive continued to look in /usr/lib. Or something. Anyway, it is resolved.

the first post here.
I ran into the same problem. Thanks for you own fixed :)