Can I somehow aquire fresh settings from somewhere?

As I mentioned in another posting, Kdenlive had worked reasonably well up until recently.

However, many things have started to fall apart. The timeline won't play, and I've noticed that the entire list of audio and video effects is now missing.

I'm using the version available from the Ubuntu Gutsy (7.10) repositories.

Is there a way I can perhaps remove or add some configuration files to try and get back to the stability I seemed to have before? I tried reinstalling the Debian packages (with Synaptic), but that didn't change anything.

Any advice would be much appreciated.

the Kdenlive settings is in the file:

You can try do delete it, Kdenlive will use default settings again. However, if your timeline doesn't work and your effects disappear, it might be a different problem. First, make sure you don't have several versions of Kdenlice installed. In a terminal, type:
which kdenlive

This will give you the path to your Kdenlive executable, for example /usr/local/bin/kdenlive
Then, try:

ldd /usr/local/bin/kdenlive

This will give you a list of library linked to Kdenlive. Are some of them missing ?



Thank you for replying.

I tried deleting the configuration file. The good news: This did bring back my effects list.

The bad news, the timeline still won't play in any way.

I ran the commands you suggested:

dave@homebase:~/kdenlive_builder$ which kdenlive
dave@homebase:~/kdenlive_builder$ ldd /usr/local/bin/kdenlive =>  (0xffffe000) => /usr/lib/ (0xb777c000) => /usr/lib/ (0xb7774000) => /usr/lib/ (0xb775c000) => /usr/lib/ (0xb766a000) => /usr/lib/ (0xb765c000) => /lib/tls/i686/cmov/ (0xb7658000) => /lib/tls/i686/cmov/ (0xb7640000) => /usr/lib/ (0xb72ef000) => /usr/lib/ (0xb6ffe000) => /usr/local/lib/ (0xb6fe0000) => /usr/lib/ (0xb6d96000) => /usr/lib/ (0xb6d55000) => /usr/lib/ (0xb6c85000) => /usr/lib/ (0xb6b92000) => /lib/tls/i686/cmov/ (0xb6b6d000) => /lib/ (0xb6b61000) => /lib/tls/i686/cmov/ (0xb6a17000) => /usr/local/lib/ (0xb69f8000) => /usr/lib/ (0xb69cd000) => /usr/lib/ (0xb69a2000) => /usr/lib/ (0xb698c000) => /usr/lib/ (0xb693a000) => /usr/lib/ (0xb691a000) => /usr/lib/ (0xb68f7000) => /usr/lib/ (0xb68e2000) => /usr/lib/ (0xb68da000) => /usr/lib/ (0xb68d2000) => /usr/lib/ (0xb68cb000) => /usr/lib/ (0xb68c2000) => /usr/lib/ (0xb68bf000) => /usr/lib/ (0xb68ad000) => /usr/lib/ (0xb683d000) => /usr/lib/ (0xb6839000) => /usr/lib/ (0xb6834000)
        /lib/ (0xb7fa7000) => /usr/lib/ (0xb681e000) => /usr/lib/ (0xb680d000) => /lib/ (0xb6806000) => /lib/ (0xb6801000) => /usr/local/lib/ (0xb67f5000) => /usr/lib/ (0xb67c1000) => /lib/tls/i686/cmov/ (0xb67ae000) => /lib/tls/i686/cmov/ (0xb67aa000) => /usr/lib/ (0xb6793000) => /usr/lib/ (0xb6762000) => /usr/lib/ (0xb671c000) => /usr/lib/ (0xb66fc000) => /usr/lib/ (0xb66f6000) => /usr/local/lib/ (0xb66ec000)

Not sure if that will help to zero in on why my timeline won't play.

I'm determined to get Kdenlive to be the video editor for all my projects. If there's anything I can do as a user to help diagnose and find problems, please let me know.

Thanks for all your hard work on this.

I think Kdenlive must have a setting in there to deliberately mess with people's minds.

I wanted to try and record what my screen looked like with XVidCap and upload the video somewhere, so that I could convey exactly the troubles I was seeing.

But, after getting XVidCap set up, and preparing a demonstration of the problem... Kdenlive started working fine again.

I think though I'm not sure, that the trouble might have something to do with screen size. In order to record with XVidCam, I reduced the Kdenlive window down from full size to a window about 1000X1000 pixels square.

Or it might have to do with playing wide screen footage. Or large MPEG files.

There are a lot of variables floating around. If I can determine which is the most reliable cause of the problem, I'll report it here.