can only render to DV? did install libmlt-dev and redid config

Hello, I have seen bug 674

http://www.kdenlive.org/mantis/view.php?id=674

Which mentions installing libmlt-dev and redoing the config, I did that, but I still can only export to DV.

kdenlive(7596) RenderWidget::refreshView: *****  UNSUPPORTED VCODEC:  "mpeg2video

kdenlive(7623) RenderWidget::refreshView: *****  UNSUPPORTED VCODEC:  "mpeg4"
kdenlive(7623) RenderWidget::refreshView: *****  UNSUPPORTED ACODEC:  "libmp3lame"
denlive(7623) RenderWidget::refreshView: *****  UNSUPPORTED ACODEC:  "libfaac"
kdenlive(7623) RenderWidget::refreshView: *****  UNSUPPORTED VCODEC:  "libx264"
 

and so on. This ubuntu jaunty, latest packages (kdenlive 0.7.3, mlt 0.3.8).

i installed libmlt-dev and also libmlt++-dev.

I also installed frei0r plugins.

I deleted completely my .kde and restarted kdenlive with all those packages installed, to force him to re-run the config wizard but it doesn't help.

The config wizard doesn't give any warning, and list all the codecs in the tab "Available codecs (avformat)".

Any help welcome!

Forums:

hi emmanuel,

 

this is problem exists because the ubuntu packager forgot to rebuild libmlt++1 after the latest libmlt1 rebuild. If you want to see this look at the number of package revision :

 libmlt1 is at version 0.3.8-0ubuntu2

 libmlt++1 at version 0.3.8-0ubuntu1

 

I have rebuilt mlt++ against actual mlt , cleaned .kde directory, and now all is ok.

 

edit : I have open a bug on launchpad to ask mlt++ rebuild : https://bugs.launchpad.net/ubuntu/+source/mlt++/+bug/363805

I hope it's fixed in time for the final release (thursday!).

Thanks for the help so far. I'll try to rebuild that package from source if the fix doesn't make it in the final release, which gets more likely by the hour :-(

 

I have got the same problem since I upgraded to Ubuntu 9.04, this afternoon. I can not anymore render to mpeg2.

hi all,

to workaround this you can use my ppa https://launchpad.net/~sunab/+archive/ppa

the building process is launched at this time, not completed ...

when ubuntu will release the proper version of libmlt++1 my package will be superseded in the update process.

 

enjoy ;) and give feedback

Thank you. I downloaded and installed your i386 DEB file. After launching the config wizard and starting again kdenlive, I can now render again in MPEG2.

Doesn't work for me on xubuntu 9.04 :(

Just have to wait for an update !!

Well I've been having similar problems, only now Kdenlive won't even run. I did a fresh install of Jaunty a few days ago.

I first installed and it would run. But noticed that I could not render to h264, mpeg2, mp4, Flash, only could go with DV, AVI, and Ogg.  But even if I went with one of the available codecs, all renders crash as soon as they start.

So I noticed this thread, added Sunab's ppa, and loaded that libmlt++.

But now when I run Kdenlive, the config wizard starts, but then fails: "Fatal Error - MLT's SDL module not found. Please check your MLT install, Kdenlive will not work until this issue is fixed."

Help please.

 

 

hi Artinvent,

look at this : https://bugs.launchpad.net/ubuntu/+source/kdenlive/+bug/363430

I reported that bug and I found a workaround (described at the top of the bug report)

Feel free to add a comment on the launchpad thread to confirm this problem.

 

But I don't know why this problems appears and if someone have an idea ...

Thanks much for the workaround. Uninstalling frei0r allowed me to run the setup wizard again and get a functioning Kdenlive. Then I reinstalled frei0r. However, rendering still failed every time. Also, although the setup wizard confirmed the presence of seemingly every conceivable codec, when I go to set up a render most of them are greyed out and not available. HDV, MPEG-2, MPEG-4, XVid4, H.264, and Flash are all not available.

So then I removed frei0r again and restarted Kdenlive. Now I can render, but again, the codecs above not available. I rendered a 640x480 video to DV format, and it plays fine. I rendered to Ogg but no media player can play the video, though the audio plays. I tried rendering to Real, but RealPlayer 11 did not play it at all well. (I would never use Real codec but that was the only other one available.)

Moving on to AVCHD, I was able to edit a 30 second sequence of 5 clips from my Canon HF100. I added a fade from black and a couple of luma cross fades. I was able to render this in 1m42s to AVI DV which reduced the dimensions to 720x480. The file played beautifully though. Ogg and Real renders were no good.

It would be awesome to get this codec problem cleared up because at this point I can't render to any kind of full resolution HD format. (HDV is also greyed out.) On the other hand, this is the first time I have been able to edit and render directly from AVCHD in any way whatsoever on Linux, so I would have to say that alone is actually fantastic. Just a wee bit more progress, gang. . . !

hi ArtInvent,

use the unstripped version of ffmpeg libraries, because by default the restricted ones are installed, this prevents from rendering with many codecs. to install them do this :

sudo apt-get install libavcodec-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libswscale-unstripped-0

 

 

By installing the *unstripped packages and deleting my .kde to re-run the wizard, i can now render to anything, without installing from the sunab PPA, so it appears maybe it's not needed (I'd rather stay with official packages if possible)

Emmanuel you are wright. But mlt++ still needs rebuild :

- in case of using regular (stripped) versions of ffmpeg libs.

- if you want to use any frei0r plugin with stripped or unstripped ffmpeg libs. When mlt was rebuilt the packager introduced the frei0r option, but mlt++ was not rebuilt, causing problems in kdenlive when installing frei0r plugins even if none are use in the current project. (install kdenlive, install frei0r plugins after and create a project as simple as a single track with no transitions and no effects and try to render it to any format ...

 

can you confirm the problem I met with the original mlt++ package and frei0r plugins installed? (anything can be rendered in that case). And if using my mlt++ package solves the problem?

This worked.

!

I just rendered a full frame mpeg-4 from AVCHD. That's pretty much a miracle as far as I'm concerned.

 

All is not perfect however: H.264 rendering completes fine but it doesn't seem to want to play right on my machine. Generally I have had good success playing 1080p30 H.264 with the new VDPAU extensions. I have a dual core Athlon 64 and an Nvidia 9400 with the 180.44 driver.

This is really coming together, so very close. Hopefully all of these packaging bugs and incompatibilities will get worked out soon. Really on the verge of becoming one of the truly great Linux apps. Great work guys.

 

Hi Sunab,

In fact I installed the package frei0r-plugins and i can render stuff (though my tests are very simple so far and i was a bit disappointed with the quality but i think it's normal). i didn't use any frei0r specific effects yet though, i used only a composite transition.

after any package installation etc, i removed completely my .kde.

but again i'm just starting with kdenlive and not spending much time on it, so i'm not really a reference...

I seem to be having the same problem you guys have. I go to render, and all the options except for Raw DV, AVI DV, Realvideo, and Theora are grayed out. I've tried following the instructions here, but I don't think I fully understand them and it hasn't worked for me.

I downloaded the libmlt++1_0.3.8-0ubuntu2~ppa1_i386.deb file from https://launchpad.net/~sunab/+archive/ppa and it automatically ran in gDebi package installer. After that I deleted the .kde folders and reran the configuration wizard, but it still didn't work.

I've got the latest Ubuntu version running (9.somethingorother) and I'm using whatever version of Kdenlive gets spit out of the application finder as of the 10th of May, 2009.

hi,

have a seen on

https://bugs.launchpad.net/ubuntu/+source/mlt++/+bug/363805


https://bugs.launchpad.net/ubuntu/+source/mlt++/+bug/363805/comments/20
"Guillaume wrote on 2009-05-06: (permalink)"

all rendering options seems working for me on ubuntu jaunty with libmlt++1 0.3.8-0ubuntu1 and kdenlive 0.7.3-0ubuntu2 from synaptic repository ) after:

1/ sudo apt-get install libavcodec-unstripped-52 libavdevice-unstripped-52 libavfilter-unstripped-0 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0
2/ "relaunch the configuration wizard from the configuration menu to get all missing codecs"
relaunch configuration wizard

I can't render anything and my configuration wizard also shows that Kdenlive can't find the MLT SDL module. I've tried sunab's ppa, tried the unstripped versions of ffmpeg, but neither (nor both) of those worked for me. I don't know what to do. What is the .kde stuff that i see people mentioning? I don't know what that is, but what should i do to it and what is it? Might that help?

After uninstalling the frei0r plugins, i've tried to render my project into an .ogg file, but it crashed after about 34% rendered. I was really excited when it started rendering, but it just seems like it's gotten closer to normal, but not quite there yet.

Ok, I tried rendering the project into an mp4 and it worked. AVI also worked. Flash also worked. However, .ogg (theora) doesn't work.

At this point, should i try to reinstall the frei0r plugins or just leave them uninstalled? Any reccomendations? I really like rendering to theora .ogg, so i hope i can figure out how to fix it soon.