Cannot connect to camcorder

Have browsed the forum relentlessly for hours today in a vain attempt to fix this issue.
It may be that this is a genuine bug but I'll run it by the group first and see what the consensus is.

Linux 3.1.10-1.9-desktop x86_64
System: openSUSE 12.1 (x86_64)
KDE: 4.7.2 (4.7.2) "release 5"
kdenlive 0.8.2.1-2.1 via packman@links2linux.de
Sony DCR-TRV320 NTSC camcorder. Old but hella nice.
Attached via firewire to the system, hardware monitor reports indicate firewire support is working.
Indeed I have actually transferred video from this same camcorder to this same hardware before when I was running an earlier version of openSuSE. But that was about 2 years ago so I'm kinda relearning the process. I don't recall if I used kdenlive before actually, but after some reading I thought I'd prefer kdenlive as it seems widely reported a nice stable tool with robust features.

The problem:
If I run kdenlive either from terminal or from gui, it gets only up to the point of telling me that it doesn't find a device.

Among other things, testing has included :
Running dvgrab as user in a terminal -it fires right up capturing video.
Creating a file called 20-udev-firewire.rules in /etc/udev/rules.d with these contents:

# allow video group to read/write /dev/raw1394
SUBSYSTEM=="firewire", GROUP="video",MODE="0660"
KERNEL=="raw1394", GROUP="video", MODE="0660"

but that was no help.
Calling # modprobe raw1394 returns FATAL: Module raw1394 not found.
YaST reports there is no raw1394 file to install in any repo, however I note that libraw1394 is installed as is libavc1394.
In short, I've tried many and varied suggestions. None have helped.

In desperation I uninstalled kdenlive, deleted the file created in /etc/udev and installed Kino.
It recognized the camera immediately.
Any ideas why I cannot seem to get kdenlive to recognize the camera?

Thanks!

Could this be a dvgrab permissions issue ? I know you state you ran "dvgrab as user" but I am wondering if you used 'su -c' or 'sudo' .

Have you tried the solution here: http://mylinuxramblings.wordpress.com/2010/01/02/grabbing-dv-from-a-vide...

My only other thought is could it be a different version of libraw1394, and libavc1394 and libdc1394 in openSUSE makes a difference ? I note there are two different packaged versions of each, and I do not know the significance as to which one is needed for kdenlive in openSUSE.

Copying a post from the openSUSE forum:

... the form of udev entry you have for firewire and the raw1394 module is relevant for the old firewire stack only. The current firewire stack is referred to here:

http://www.kdenlive.org/user-manual/troubleshooting-and-common-problems/...

The simplest rule to deal with firewire would be

SUBSYSTEM=="firewire", GROUP="video"