Cannot install on Ubuntu 9.10

I'm trying to install kdenlive on Ubuntu 9.10. When I do, I get the following error:

Could not mark all packages for installation or upgrade:

kdenlive:
Depends: kdebase-runtime but it is not going to be installed
Depends: kdelibs5 but it is not going to be installed
Depends: libmlt++2 but it is not going to be installed
Depends: libmlt1 but it is not going to be installed
Depends: libqt4-dbus (>=4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqt4-network (>=4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqt4-svg (>=4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqt4-xml (>=4:4.5.3) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqtcore4 (>=4:4.6.2-0ubuntu3~karmic1~ppa1) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: libqtgui4 (>=4:4.6.2-0ubuntu3~karmic1~ppa1) but 4.5.3really4.5.2-0ubuntu1 is to be installed
Depends: melt but it is not going to be installed

Any help would be greatly appreciated. Thanks.

Rick

From which repository do you try to install?
It looks like you are trying to install kdenlive from sunab2 which is built against KDE 4.4. But you use KDE 4.3.
Take a look at this page:
http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-...