Cannot Render MPEG4,XVID4,H.264,FLASH

Hello there. I really like KDEnlive. No VideoEditor which uses GTK (which I would prefer due to the fact that I am using Ubuntu) is so good as KDEnlive. I used it on carmic and now on lucid.

With Carmic I got no errors on KDEnlive rendering MPEG4 or DivX etc. but now I cannot render into the most formats.

I attached some screenshots of the errors which I get at KDEnlive (0.7.7.1).

"Nicht unterstützter" means "Not supported" or "unknown"

Executing "ffmpeg -formats |grep aac:" in terminal gets:
------------------------------------------------------------------------------------------------
[QUOTE]FFmpeg version SVN-r23548, Copyright (c) 2000-2010 the FFmpeg developers
built on Jun 9 2010 11:41:56 with gcc 4.4.3
configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libfaad --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-x11grab
libavutil 50.18. 0 / 50.18. 0
libavcodec 52.75. 1 / 52.75. 1
libavformat 52.68. 0 / 52.68. 0
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.20. 0 / 1.20. 0
libswscale 0.11. 0 / 0.11. 0
libpostproc 51. 2. 0 / 51. 2. 0
------------------------------------------------------------------------------------------------

I installed ffmpeg from the official FFmpeg SVN and x264 from the official git repository, and It compiled and installed propperly.. With this installation it worked on Carmic Koala but not on Lucid Lynx anymore.
Does anyone have a clue how to resolve this issue? On Carmic i didnt got any errors whith ffmpeg and x264 self compiled from the source.

DO you need any additional information?

Thank you very much. Greetings from germany as you can see from the screenshots! :D ):P

Forums:

Install the unstripped ffmpeg lib packages and then in Kdenlive: Settings > Run Config Wizard.

Hello!

Thank you for helping me.

I deinstalled ffmpeg SVN version and installed the version which was given by the ubuntu repositories and the unstripped packages.
I deinstalled KDENLIVE and installed it again.

And then it worked..

Here the packages which I installed to get it working:

sudo apt-get install libavcodec-unstripped-52 libavdevice-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0

Thank you very much.
I am not depressed anymore! ;-)

Hi!

Kubuntu 10.04 LTS, Kdenlive 0.7.7.1

After applying your instructions h.264 is still unavailable. Which libs are missing?

TIA

I'm having the same problem. Recompiling FFMPEG didn't do a damn thing to make it work. Deinstalling and reinstalling kdenlive didn't do it, even when I ensured I removed all the configuration files from my user profile. Here's my FFMPEG outputs:

ffmpeg -codecs | grep aac
FFmpeg version SVN-r23791, Copyright (c) 2000-2010 the FFmpeg developers
built on Jun 25 2010 21:19:10 with gcc 4.4.1
configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab
libavutil 50.19. 0 / 50.19. 0
libavcodec 52.78. 0 / 52.78. 0
libavformat 52.71. 0 / 52.71. 0
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.20. 0 / 1.20. 0
libswscale 0.11. 0 / 0.11. 0
libpostproc 51. 2. 0 / 51. 2. 0
DEA aac Advanced Audio Coding
EA libfaac libfaac AAC (Advanced Audio Codec)

ffmpeg -codecs | grep xvid
FFmpeg version SVN-r23791, Copyright (c) 2000-2010 the FFmpeg developers
built on Jun 25 2010 21:19:10 with gcc 4.4.1
configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab
libavutil 50.19. 0 / 50.19. 0
libavcodec 52.78. 0 / 52.78. 0
libavformat 52.71. 0 / 52.71. 0
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.20. 0 / 1.20. 0
libswscale 0.11. 0 / 0.11. 0
libpostproc 51. 2. 0 / 51. 2. 0
EV libxvid libxvidcore MPEG-4 part 2

ffmpeg -codecs | grep x264
FFmpeg version SVN-r23791, Copyright (c) 2000-2010 the FFmpeg developers
built on Jun 25 2010 21:19:10 with gcc 4.4.1
configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-postproc --enable-pthreads --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libx264 --enable-libxvid --enable-x11grab
libavutil 50.19. 0 / 50.19. 0
libavcodec 52.78. 0 / 52.78. 0
libavformat 52.71. 0 / 52.71. 0
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.20. 0 / 1.20. 0
libswscale 0.11. 0 / 0.11. 0
libpostproc 51. 2. 0 / 51. 2. 0
EV libx264 libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10

What am I doing wrong here?

On a slightly unrelated note, when I render in MTS, the audio and video get out of sync. This is a huge problem; anyone know of what may be causing it?

If you recompile ffmpeg you also have to recompile MLT

Kubuntu LL 10.04 amd64 - KDE 4.4.2 - Kdenlive 0.7.7.1 amd64

Please note that I'm an average GUI user. I don't know how to compile, and use terminal only with a manual to help me with the commands. All apps and libs were installed via KPackageKit, with the default settings.

I'm still having the same problem here, even after applying the recommendations and instructions regarding unstripped libs, uninstalling and reinstalling Kdenlive, running the config wizard etc. AFAIK, all libs are installed in /usr/lib$

ffmpeg -formats | grep aac
FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5.1-1ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Mar 4 2010 12:41:55, gcc: 4.4.3
D aac raw ADTS AAC
D A aac Advanced Audio Coding

ffmpeg -formats | grep x264
FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5.1-1ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Mar 4 2010 12:41:55, gcc: 4.4.3
EV libx264 libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10

ffmpeg -formats | grep xvid
FFmpeg version SVN-r0.5.1-4:0.5.1-1ubuntu1, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5.1-1ubuntu1 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-runtime-cpudetect --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 1 / 52.20. 1
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Mar 4 2010 12:41:55, gcc: 4.4.3
EV libxvid libxvidcore MPEG-4 part 2

TIA for any help.

SOLVED!

After following the instructions at http://ubuntuforums.org/showthread.php?t=1117283, all rendering formats are available again.

Thanks anyway for your interest.

I'm using Ubuntu 9.10 and It's a no go for me. I've tried everything Pipoca said and everything everyone else said. Nothing works. I've recompiled from source, reinstalled everything and yet no h.264 rendering. I don't know what I'm doing wrong here. I wish there was a way to force KDENLIVE to see my codecs and use them.

I forgot to mention that I used the Medibuntu option at http://ubuntuforums.org/showthread.php?t=1117283.

@JULinux: let me repeat it again: You also have to make sure MLT is compiled against the ffmpeg version installed.

If the H.264 options are disabled, then it is probably because you are missing an AAC encoder. Ubuntu 10.04 uses unstripped ffmpeg libs based on a 0.5 version of ffmpeg from Debian. This version does not contain an AAC encoder, but anything newer based on ffmpeg v0.6 does.

Awesome! I've been struggling to get the H.264 rendering enabled. Followed the instructions above, using Medibuntu option and all render formats are now available! Woot!