Cannot start kdenlive

New to linux, and not very knowlegable regarding command line type of computing, having come from windows.
Always had trouble with kdenlive, starting with certain effects/functions not working, so have reinstalled several times with varying degrees of success. Latest "successful" install seemed to work ok till I tried using the speed effect, which showed tools for, I think, pan & zoom. I really need to slow down portions of video, so I again tried reinstalling, and now kdenlive crashes every time I try to load a video clip.
Please can someone help? I am getting very frustrated and annoyed with this whole linux/kdenlive issue.
Running linux mint (lisa) if that helps.

What version of kdenlive are you using and how did you install it? Don't know what version of Mint lisa is? Is it the latest?

kde 4.7.4.
Installed via software manager, and also via copying and pasting link from this site from compiled software. Not sure what I am doing - last real experience of "command line" was trying to draw circle on screen in MSX back in 80's!
Don't know how to find details of "lisa", but that's what I installed, and have previously seen screen giving that info, but don't know how to get details back!
Please show mercy! - am new to all this.

Ok, Lisa is v12 based on Ubuntus Oneiric, the latest Mint is v13 based on Ubuntus Precise Pangolin.

kde 4.7.4 is your desktop environment not kdenlive version. So what version of kdenlive are you trying to install/use?

If you open up a terminal and type kdenlive, press return, what error message do you get when kdenlive fails to start?

It may be beneficial to update your Mint to v13 and use sunabs PPA for an upto date stable release of kdenlive rather than older version from Mints package system.

I would steer well clear of installing apps outside of the package management process as it can cause issues with dependacies and incompatibilites in library versions. Using sunabs PPA however is a good route to latest version of kdenlive/MLT etc.

If you look over this site or search 'sunabs PPA' you should find plenty of info on how to go about setting that all up.

Thaks yellow, this is error message from terminal:

kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
kdenlive: symbol lookup error: kdenlive: undefined symbol: mlt_service_cache_get_size

Will have a go with your other suggestions, but strugling to understand some of what you say due to my "ignorance" - sorry.

Yellow: kdenlive now seems to be working ok after I ran update from desktop! Was looking around to try your suggestions when I noticed update reminder and ran it.Very grateful for your suggestions and will try to impliment them when I've cleeared backlog of projects left pending after crash. Again very many thanks for your help so far, hopefully everything will continue workin.g

No problem, pleased to have helped.