Can't get aspect ratio correct on rendering

Recently another forum member discovered how to make custom project settings:
http://www.kdenlive.org/bbforum/viewtopic.php?f=11&t=288&p=1065#p1065

My goal is to render output that is as much as possible in the same format as the video files I am putting in. The video I'm putting in comes from my Sony HDD camera, and what I know about their format is this:
[attachment=1]

format_info.png

[/attachment]

So I created a project configuration that looks like this:
[attachment=0]

config_settings.png

[/attachment]

I then created these custom rendering settings in the "export timeline" interface:
format=mpeg video_rc_min_rate=0 video_bit_rate=12000000 audio_bit_rate=384000 frequency=48000 size=720x480 progressive=1

However, when I render, it comes out as 25 frames per second, and, more importantly, the image is compressed horizontally, with black space on the left and right.

When I play it in Movie Player, it displays it at 640x480 for some reason, although I think it's actually 720x480, but the pixel aspect ratio on the rendering might be wrong (should be 1, might be .9).

Bottom line, the frame size is not under control at all, and I'm getting bad results.

Does any of the info I've described above indicate where I'm losing control of how this thing renders?

Thank you for any advice.

Forums:

I am trying to find out what, if anything, can be done about this problem of excess black on rendering output.

I've uploaded an example Kdenlive project that demonstrates the problem. Anyone can download all the files here:
http://www.savefile.com/files/1140092

The above TAR file includes:
Kdenlive project file.
Input MPEG file.
Output MPEG file (has the problematic black borders)
Custom project settings files (these were used to set up project configuration - may not be necessary to reproduce the problem.)

Included in this post are some screen grabs that show the problem clearly.

If anyone can help with this issue, it would go a long way to making Kdenlive reliably useful.

Here is how the input looks:
[attachment=1]

input.png

[/attachment]

And here is how the output looks:
[attachment=0]

output.png

[/attachment]

Hello? Anyone out there?

As far as I can tell, this problem isn't unique to me.

Is it a bug? A settings issue?

Is there no hope for getting rid of these black spaces on either side of the image?

Sorry to be a pest, but this image distortion is apparent on all rendering, so it's kind of a show stopper for using Kdenlive.

I'm eager to hear any suggestions at all.

Thanks for reading this, and I hope someone has some ideas.

Hi Dave,

I've tested your files using kdenlive SVN version and confirmed the bug.

I think this is related with the bug already reported in Mantis and it has something to be with wrong handle of NTSC files in kdenlive due to a bug in MLT (see this link

http://www.kdenlive.org/mantis/view.php?id=23

).

I've tried Dan suggestion about starting kdenlive from a terminal using "MLT_NORMALISATION=NTSC kdenlive" and the result is much more better. The rendered file is recognised by ffmpeg being the same format as the original and the output played in TOTEM seems not to have black spaces (or at least they are much more narrow !!).

Try it by yourself and let us know if you see any improvement. Anyway, to have the right solution you'll need to wait for the bug to be solved in MLT.

Regards.
JM

JM,

Thank you so much for getting back to me.

I tried starting Kdenlive with the command you suggested and did another test rendering, with no other changes to the project settings.

Unfortunately, the result was that the black borders now appear on the top and bottom of the rendering.

This screen shot shows the new output:
[attachment=0]

newouptut.png

[/attachment]

I'm guessing that this is an indicator that I'll simply have to wait fir the MLT bug relating to NTSC to be fixed.

If such a fix happens, will the change be reflected in the version available in the Ubuntu repositories? Or is the delay between the repository version and the SVN version a long wait?

Just wondering...

I was just poking around on the Kdenlive bug tracking system, and I don't see any mention of anything like this bug. I also tried to find any mention of NTSC bugs on Sourceforge's MLT page...

But there's no mention of anything like this. So I thought I would report this myself, but I'm not sure if I should be posting it on the MLT or Kdenlive bug tracking system.

Am I the only one seeing these excess black bars? I mean... I would assume this kind of thing to be a deal breaker for anyone, so if others are getting any rendering done, then it would seem that everyone else is fine.

I'm dying to use Kdenlive... is there any way I can provide information or anything that would help get this problem addressed?

Sorry to be a pest, and thanks to all the developers for their hard work. Kdenlive is a great editor, and I'm really looking forward to when I can start using it full time.

Potentially this problem is solved.

I downloaded the latest SVN of MLT, and then started Kdenlive with the "MLT_NORMALISATION=NTSC kdenlive", and it has made a couple of test renders go okay.