Can't install kdenlive 0.9.2 [SOLVED]

I'm unable to install kdenlive 0.9.2-0ubuntu0~sunab~oneiric1 on Ubuntu 11.10. Ubuntu Software Center gives me the following error.

The following packages have unmet dependencies:

kdenlive: Depends: libc6 (>= 2.4) but 2.13-20ubuntu5.1 is to be installed
Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.1-9ubuntu3 is to be installed
Depends: libkdecore5 (>= 4:4.4.95) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libkdeui5 (>= 4:4.6.80) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libkio5 (>= 4:4.6.2-0ubuntu2) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libknewstuff3-4 (>= 4:4.4.0) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libknotifyconfig4 (>= 4:4.3.4) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libnepomuk4 (>= 4:4.5.85) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libqt4-dbus (>= 4:4.6) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libqt4-opengl (>= 4:4.6) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libqt4-script (>= 4:4.6.1) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libqt4-svg (>= 4:4.6) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libqt4-xml (>= 4:4.6) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libqtcore4 (>= 4:4.7.0~beta1) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libqtgui4 (>= 4:4.6.2) but 4:4.7.4-0ubuntu8.1 is to be installed
Depends: libsolid4 (>= 4:4.3.4) but 4:4.7.4-0ubuntu0.1 is to be installed
Depends: libstdc++6 (>= 4.4.0) but 4.6.1-9ubuntu3 is to be installed
Depends: kdenlive-data (= 0.9.2-0ubuntu0~sunab~oneiric1) but 0.9.2-0ubuntu0~sunab~oneiric1 is to be installed

I've read the other posts in this forum from people who appear to have had the same problem, but I'm afraid I don't understand what they did to solve it.

Any help would be greatly appreciated.

Sunab's answer here
http://www.kdenlive.org/forum/dependency-error-during-install-092-using-...
says 'You updated your package list in the "middle" of the build process'.

Does that mean that if I wait longer, then it should work? If so, how long is typical? (The above thread is already a couple of days old.)

A day later, and still having the same problems, so I suppose waiting is not the solution. Removed sunab ppa and reinstalled from Ubuntu repositories, so at least I have a program to work with.

Hi,

After some testing (virtual machine new install Ubuntu 11.10 i386) the packages from my ppa (ppa:sunab/kdenlive-release) install fine without any error.

Are you sure your package list is up to date?

Ah, there's one problem: I had kdenlive-release and kdenlive-svn added, but not kdenlive-stable.

I just added it and updated the package list, but update gives me the following error:

W: Failed to fetch http://ppa.launchpad.net/sunab/kdenlive-stable/ubuntu/dists/oneiric/main... 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/sunab/kdenlive-stable/ubuntu/dists/oneiric/main... 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I looked at http://ppa.launchpad.net/sunab/ and I don't see that directory. Am I missing something or doing something wrong? Let me know if I'm being a complete idiot here ...

Many thanks for your answer (and of course for all of your hard work maintaining the ppa)!

Hi,

sorry for the misspelling : kdenlive-release (post edited)

The problem is identified : don't mix kdenlive-release with kdenlive-svn, never! ;)

At this moment, in the middle of kdenlive and mlt multiple releases, both ppas are not compatible.

Hi Sunab,

After removing the kdenlive-svn ppa, uninstalling the old version of kdenlive (for some reason apt-get upgrade "kept back" the kdenlive packages), updating package lists, and installing the new version from the kdenlive-release ppa, everything appears to be working now.

As you mention above, the problem must have come from the conflict of ppas.

Thanks so much for your help and patience!

(EDIT: Marked thread title as solved.)