Can't start kdnlive (SDL module missing in MLT)

When i start firstime kdenlive, the configuration assistant is opened, and i see the message "MLT's SDL module not found. Please check your MLT install. Kdenlive will not work until this issue is fixed.".

NOTE: my distribution is archlinux

Can anybody help me?

Thanks

Did you install from the repositories (which worked like a charm for me) or did you build from source?

I install from the repositories, but the last version don't work. I have resolved the problem downgrading mlt (0.7.4-1.1 => 0.7.2-1.1).

Thanks

Kdenlive executes melt -query to get options supported by mlt. Until version 7.4 melt wrote the query response to stderr. From version 7.4 on, the response is written to stdout. The attached patch for kdenlive should resolve the problem.

Hi,

I also have this showstopper bug that affects both Kdenlive 0.8 and Openshot 1.3.1 in AV Linux 5.0 (based on Debian Squeeze). Is there a chance a more global MLT patch could be provided for all apps using MLT? I had been using a 0.7.3GIT MLT build that still works very well however I'd like to package 0.7.4 as an update.

Well there are 2 possibilities:

- Modify mlt to again output data to stderr, but I don't like this approach as the author of mlt decided to output data to stdout which in my opinion is the right decision.

- Modify applications using mlt to read data from stdout. I don't use openshot and have no python experiences but from looking at the sourcecode it seems to me that openshot already reads mlt data from stdout, but I might be wrong. I think you should ask on the openshot forums for more information.

Hi

Thanks for the reply,

After some advice from ddennedy on mlt-devel mailing list and a little experimentation, I have found that Openshot seems OK after updating to MLT 0.7.4 and starting a fresh project, it didn't seem to like me updating MLT on project I had been working on. Also the Kdenlive issue seems limited to the initial launch of the config wizard. On a Kdenlive install that had already been configured MLT 0.7.4 also works correctly so hopefully the next 0.8.2 Kdenlive release has your config wizard patch included.

Thanks,

The patch won't be included since we do now use the MLT API to get the required information:
http://kdenlive.svn.sourceforge.net/viewvc/kdenlive?view=revision&revisi...

But anyways thanks for having a look at this. If you have a patch the next time please post it on our mailing list or in the bug tracker.

Ok, but how do I install this patch?

Well there be a easier way to get kdenlive to work with the MLT issue if I wait it out. I tried the solutions and I got the program to open and it crashes. I reinstalled the normal version and hoping to wait it out tell there a fix. Will a easier fix be coming?

Is there a simple way to do this? I just upgraded to Ubuntu 11.10 in order to get Kdenlive to work since it stopped working for me on Lucid. How do I use this patch? My guess it that I download it. Once I can locate it on my desktop how do I use it then or execute it? Is it easier to go back to an older MLT version? Since I have no idea what that is or how to even begin to do that could you give me "simple" directions on how to do this? I'm starting to think that Kdenlive is just too much trouble anymore. It seems as if it just never wants to work. Please advise? Thanks, Rich H

we have now released Kdenlive 0.8.2 that solves this issue, except on ubuntu 10.04 with KDE 4.4.5 where it crashes. For all other ubuntu versions, simply add the sunab repository and upgrade kdenlive as described in our download > ubuntu section.

Okee dokee....I click on the patch and see a buncha source-code that I guess I am to paste somewhere or other.

So....where is the somewhere or other? I am not a techie. Just a guy who wants to benefit from this program.

In advance, thanks

In this case the forum search will help you out. Using the sunab repository has been described several times.