Clip is invalid and will be removed from project

So I made a simple project (a background that slides up and some icons that fade in) to re-use in many projects.

The project loads fine, plays fine, saves fine, but as soon as I try and insert it into any other project, I get this error message in a popup:

"Clip
is invalid and will be removed from project"

Any ideas why that's happening?

NB: There is probably a typo in the source code as there seems to be a newline after the word 'Clip' on that popup

This is continuing to happen on almost every clip I've been making in the past few hours.. sometimes they load fine, then I go back and make some changes to the clip, and when I come back to the 'master' project (the one that contains those projects as clips), I get that error. Started with 6 clips that all worked, now down to only 1 loading, seems every time I change anything on one of them, the master project is no longer able to load them.

This is a pretty serious bug IMHO, together with a number of annoyances I've found in only a few hours of using 0.8.2, I think I'll have to go back to 0.8. Was so excited to see 0.8.2 finally release :-(

Unfortunately I've tried re-producing it and can't figure out how to. At first I thought it was caused when I removed something from the timeline in one of the 'sub' projects, but that doesn't always seem to be the case. Since the 'broken' projects play fine, I'm guessing it's a problem with loading them into another project, and not those 'sub' projects themselves?

PS: Sorry its a little confusing!

So, do you have a clip(project file) that constantly fails to load into another project? If so, please mail it to me so that I can have a look at it: jb at kdenlive org

I have that problem too.
j-b-m: Do you need one more file?

@December: Thanks for the project file. The problem is that the .kdenlive project file contains some invalid chars for the "thumbnail" value of the clip producers. For example, it contained this:

thumbnail="@" (where the '@' is an invalid char).

As a workaround, you can open your project file in a text editor and remove the 'thumbnail="..." ' strings since it is not important, then the project can be included again. I will check soon the Kdenlive code and fix this issue for next week's release.

@Tikaey, can you check that this is also the problem for your clips?

I just found the bug in Kdenlive's code. Another better workaround is to open the project in Kdenlive, then for each clip, go in the clip monitor's context menu and select: "Set current image as thumbnail". Do this for all clips in the project and it can then be inserted without problems.

j-b-m: I've found a invalid char, too.
Workaround do it fine. Thx. :o)

That's great, thanks for the workaround :)

I just put on Kdenlive 9.4 on Suse 12.3 x64 and get this error for any clip I try to put in, the first time Kdenlive was run. It also complained about not having avformat/ffmpeg but then has the correct directory in preferences on the wizard startup.

UPDATE: Saw some threads about on forums.opensuse.org advises switching all versions of kdenlive/MLT/codecs to Packman, so I'm rebuilding everything let's see how that works. It's a security issue to have to do that, and I do consider it a hack to mandate an entire software repository to get a video editor to work. Just sayin.