clip from VOB only imports partially

Hi, I am a newbie, so my problems may have a simple solution.
Use 0.8.2.1 on ubuntu 11.10.
Can read vob files, put them on timeline and replay. fine.
However, when loading one vob it gives me 6 seconds, another 21 seconds clip, but the original files have 20 minutes+.
These first few seconds work fine but I could not get the rest of the file to import.
I tried to change the default length to import (under settings) but it didn't help.
An other problem: one vob shows 26 hours of duration though it is only 1 hour. That one is impossible to work with beyond one single frame.

All the vob files show without errors in many viewers.
File size 1.1 GB , size on disk 8.5 GB
720 x 576 codec N/A, 25 frames/sec bitrate 9400 kbps. Audio Dolbydigital AC-3, Stereo, 4800 Hz, 256 KBPS.
The files were reexported from a SONY HD-recorder and originally recorded to it from my own, non protected, non-copyrighted SCART input from a VHS.

Ideas appreciated

Try using mkvmergegui, available via Synaptic (although if you can find a more recent build than from Ubuntu's repositories it may be better.) http://www.bunkus.org/videotools/mkvtoolnix/downloads.html or Avidemux

Remux your vobs into matroska (.mkv) files, they'll then hopefully import into kdenlive better and give correct durations. Hopefully audio will still sync. If not you could use mediainfo to find the audio delay in milliseconds and add that as shift in Avidemux or Delay in mkvmergegui.

Same here regarding the 26hr vob and other odd durations, identical results.

1) Works like a charm. Solved.
2) Still wonder what the problem is ;-)

Either a bug or just poor support for vob container with mpeg 1 & 2 in ffmpeg maybe. Could report a bug over at ffmpeg if you wanted to.

Yesterday I had a similar effect with a 11Gig MPEG2 .mpg file. Remuxing with ffmpeg has also solved this issue.

Note: I'm currently cutting my own wedding video. Source files originates from one of the first generation JVC Full HD Cams which is not AVCHD compliant. Every 18 minutes the cam has written a new .mpg file because of the size/file system limitations.
I've tried several ways to import the complete sequence (~1 hour) without loosing perfect synchronized audio. When importing the parts direct into kdenlive the audio is out of sync and has gaps on the borders to the next clip. Doing a joined remux with tsmuxer before, results also in a clip with unsynchronized audio. Also when playing direct with vlc, ffplay...
When I do a simple binary join via cat, then the result is perfect in vlc, ffplay but kdenlive imports only the first 8 minutes. I've no idea if this happen about the simple cat or if this is the same issue as you have posted on top.
cat part2.mpg >> part1.mpg
cat part3.mpg >> part1.mpg
Kdenlive has a simple trans-coding profile which is only remuxing (audio copy, video copy). Doing so with the cated source, the result is perfect for Kdenlive and other players.