Composite trans. pan/zoom motion only patial working. [SOLVED]

I'm doing a pan/zoom using the composite transition to be able to keyframe it but it only applies some of the motion;

I set one key at the start then another at fr. 50 to be the same as 1st. Then a key at last frame (#100) where I do a resize to 300% and a move to zoom in to a specific area.

When playing the timeline the clip resizes to about halfways (~75fr and 150-200%scale) and then stops zooming while the move on the layer continues to last keyframe.
The red rectangle in transition scales to the last frame but that doesn't seem to be applied on the footage in the timeline.

I've tried restart of Kdenlive and computer as well as reapplying the effect. Rendered files are also not correct so it's not just a viewing glitch.

Any suggestions?

Kdenlive 0.76 on Ubuntu 8.10, 64-bit.

Forums:

Enable the Fill option in the transition settings.
I just made this enabled by default for the next release.

Ah, that was a simple solution that did work.
Thank you!

I think I'm experiencing the same feature/bug but I can't follow the suggestion to enable Fill in the transition settings.

There doesn't seem to be any such option either against the Transition (I'm using a dissolve, which only offers a 'Reverse' checkbox and a selection of the track to dissolve into).

The Pan and Zoom doesn't seem to have this option either. It's currently stopping the Pan suddenly as soon as the dissolve starts - looks quite bad).

I can see the logic of 'filling' the whole clip with the Pan and Zoom effect, but can't see where that control could be.

I'm running version 0.7.8 from the Kdenlive Release PPA. Is there a place I haven't looked, or maybe the UI or the advice has changed between versions?

For extra clarity I think the pan is stopping half-way-through the dissolve, not when the dissolve starts. It seems to halt when opacity goes below 50% and the other video becomes dominant. At that point it stops panning, but this is still quite visible.

The Fill option mentioned here is the Composite transition - not Pan and Zoom or Dissolve. I could not reproduce the problem you describe using latest unreleased code. I made a simple test dissolving from Track 1 to Track 2 with the Pan and Zoom on the first clip, on Track 1. I am trying to recall if there is a fix since the v0.7.8 release that would explain why it works for me but not you, but I am not recalling anything at the moment. Can you make a simple project that exhibits the problem? If so, how is it different than what I described? If so, please answer in a bug report, and attach the project file without media to it.