"crackling" Audio

Ubuntu 9.04, replicated on two computers, kdenlive .75, all updates done.

I have a video of a man playing a flute that I have cut up for a video. Video capture was done with kino, although kdenlive was also used to test at one point. The audio is relatively quiet, as the flute has a large dynamic range, so it is not peaking. However, on really high notes the audio get crackly, as if it is clipping.

After reading through the bug database, I tried to play the file through ffplay, and there are no audio issues there, nor through kino.

I have tried it with normalization for thumbs on and off, recapturing the file, and on multiple comps. I have also been trying to get a good liveusb to test it on a different distro, but there have been problems with persistence, and the kdenlive debian link no longer works.

I would have been ok if I just had an edl, but there doesn't seem to be a function to get the edl so I can cut the audio in another program.

This is a rather time sensitive project, and I finished all the cuts before I realized it was an internal kdenlive error.

Anyone out there with ideas?

As an addenda, it RENDERS with this audio crackling too, which is the major issue. I could deal with it just in the timeline, but the output (flash and dv tested) is also bad, which leads me to believe it is not due to pulseaudio,etc, although I am trying out the alsa note from the common problems, but am running into issues with the hardware.

Next update. After searching the bug lists, I found one mention of staticy audio going away by using sudo to run kdenlive.

However, that did not fix the problem in this case.

Did you try removing all audio effects from the entire project (probably should make a file copy of the kdenlive file first). If so, then only think I can think of is it the audio resampler. However, the DV output uses 48KHz, and usually there is no resampling because the source is also 48KHz. Check the clip properties to be sure. Kino also uses the same resampling lib, but possibly with different settings.

Try this with your clip at the command line:
$ ffmpeg -i flute.dv -target pal-dv out.dv

then listen-test out.dv. problem?

Next, try this:

$ melt -profile dv_pal flute.dv -consumer avformat:out.dv

hear it now?