Crash on startup with signal SIGSEGV

I've just compiled a fresh install of Kdenlive using the wizard and i seem to get a segfault on startup. I launch Kdenlive, I'm asked for the mlt profiles folder (/usr/share/mlt/profiles/, the path is correct) and then it crashes.

Would anyone know how to solve this problem ?

Thanks.

Here's the backtrace :

Application: Kdenlive (kdenlive), signal SIGSEGV
[Current thread is 0 (LWP 8752)]

Thread 2 (Thread 0xb3946b90 (LWP 8754)):
#0 0xb8030430 in __kernel_vsyscall ()
#1 0xb67007b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2 0xb74103d0 in ?? () from /usr/lib/libQtCore.so.4
#3 0xb733e56e in ?? () from /usr/lib/libQtCore.so.4
#4 0xb660c4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5 0xb670849e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5c7f920 (LWP 8752)):
[KCrash Handler]
#6 mlt_properties_fetch (this=0x0, name=0xb3c3dc54 "forced") at mlt_properties.c:348
#7 0xb801b94f in mlt_properties_set_int (this=0x0, name=0xb3c3dc54 "forced", value=3) at mlt_properties.c:738
#8 0xb3c3bc86 in consumer_start (parent=0x8d43b58) at consumer_sdl_still.c:159
#9 0xb8024ac9 in mlt_consumer_start (this=0x8d43b58) at mlt_consumer.c:420
#10 0xb3c3b108 in consumer_start (parent=0x8d34c50) at consumer_sdl_preview.c:208
#11 0xb8024ac9 in mlt_consumer_start (this=0x8d34c50) at mlt_consumer.c:420
#12 0xb7ff7e50 in Mlt::Consumer::start () from /usr/lib/libmlt++.so.2
#13 0x080bb6ca in Render::connectPlaylist (this=0x8d34350) at /home/hugh/compil/kdenlive/kdenlive/src/renderer.cpp:972
#14 0x080c1bc9 in Render::setSceneList (this=0x8d34350, playlist=
{static null = {}, static shared_null = {ref = {_q_value = 20674}, alloc = 0, size = 0, data = 0x827447a, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, static shared_empty = {ref = {_q_value = 114}, alloc = 0, size = 0, data = 0xb752646e, clean = 0, simpletext = 0, righttoleft = 0, asciiCache = 0, capacity = 0, reserved = 0, array = {0}}, d = 0xbf94d160, static codecForCStrings = 0x0}, position=0) at /home/hugh/compil/kdenlive/kdenlive/src/renderer.cpp:876
#15 0x080d15b0 in KdenliveDoc::setSceneList (this=0x93ff450) at /home/hugh/compil/kdenlive/kdenlive/src/kdenlivedoc.cpp:243
#16 0x080e0c22 in TrackView (this=0x93ffd10, doc=0x93ff450, parent=0x889a7e0) at /home/hugh/compil/kdenlive/kdenlive/src/trackview.cpp:83
#17 0x080886b1 in MainWindow::newFile (this=0x889a7e0, showProjectSettings=false) at /home/hugh/compil/kdenlive/kdenlive/src/mainwindow.cpp:1235
#18 0x08094e40 in MainWindow (this=0x889a7e0, MltPath=@0xbf94d548, Url=@0xbf94d530, parent=0x0) at /home/hugh/compil/kdenlive/kdenlive/src/mainwindow.cpp:371
#19 0x0807db59 in main (argc=136582764, argv=0x8899d08) at /home/hugh/compil/kdenlive/kdenlive/src/main.cpp:83

Deleting /home/MyName/.kde/share/config/kdenliverc did the trick, seems to be a common problem...

Edit : Ah no. Now when I start Kdenlive it launches the config wizard, which tells me Avformat is missing, and if I continue it will segfault after finishing the wizard.

ffmpeg -formats indicates that AVformat is installed (at least I expect that's what the line "libavformat 52.34. 0 / 52.31. 0" means) and the configuration options correspond to the recommended ones in the compilation instructions (it was done by the build wizard anyway).

If you are using the wizard, try doing a completely clean reinstall to /tmp/kdenlive and make absolutely sure that you use kdenlive_start -g to start kdenlive.

Please retain the build log and the crash log, and mail/attach it here.

Regards

Mads

Hi,

I've tried re-building from scratch (using the wizard) but I still get the same problem. The missing avformat seems to indicate a problem with ffmpeg configuration but I can't figure out what would cause that...

Please *do* attach/mail me the build log. Also: make sure you have gdb installed, then run "kdenlive_start -g" and mail me the log produced by this too.

Also, you consider doing a wizard build with the install dir being /tmp and try this.

Regards

Mads

Sorry but I haven't been able to spend much time on this recently. I actually think I've found where the problem comes from and it isn't really Kdenlive.

As I said, the startup wizard states it doesn't find avformat (so ffmpeg related problem). I suppose it then shouldn't allow to continue with the wizard because Kdenlive will be totally useless without ffmpeg.

I actually had several ffmpeg installations. When launching ffmpeg from the command line it used the executable found in /usr/local/bin and Kdenlive tried using the one ine /usr/bin (or the other way round). I removed all ffmpeg related files, libraries and such and recompiled/installed a new ffmpeg in /usr/.

I now get an error message when trying to launch ffmpeg, concerning "av_free_packet" (I'll try to post the actual error message later). I remember I had that problem earlier and it was probably resolved when I messed around with ffmpeg and got two versions installed...

Anyway, I can't seem to get ffmpeg to install correctly. I'll check all the right dependencies are installed (it should tell me if something is missing on configure or make, no ?) but apart from that I can't see where the problem would come from. I'm under jaunty.

I found some other people with similar issues by googling the error message, but no solution...

If you installed using the build wizard, you must use "kdenlive_start" to start kdenlive....

It makes sure that paths and a lot of other stuff is set correctly to get the correct versions of ffmpeg/etc.

After quite a lot of fiddling aournd (basically removing all the was left behind from previous ffmpeg and mlt installations) I got everything to compile correctly by installing a recent ffmpeg package (dating from april) and not using the wizard (I want more flexibility than is allowed by the wizard, especially concerning ffmpeg).

Now Kdenlive actually runs alright, but it still tells me avformat is missing and it refuses to import most videos and images and doesn't seem to be able to export at all... And after checking ffmpeg I realized it wouldn't actually work at all !

So basically I think I simply made a mess somehow, probably mixing packages and manually compiled of the same programs/dependencies, and now ffmpeg is brocken. I think I'll just end up formatting and reinstalling my system from scratch, at least that should solve my problems...

Anyway, thanks for yout help.