crash when saving project

I'm posting this here as opposed to in bugs because I'm not sure if I screwed up or the code contains a bug...
To my uninitiated eyes it seems like mlt and kdenlive somehow are not entirely compatible at this point in time?

software versions latest from git/svn:

MLT last commit:
commit 2657693db7ce32ddb0a48b677e4cec6101a35e20
Author: Dan Dennedy
Date: Fri Jul 3 14:55:15 2009 -0700
Massive refactoring of image conversion.

kdenlive: r3728 | xzhayon | 2009-07-08 10:06:30 +0200 (wo, 08 jul 2009) | 1 line

backtrace:

#0 mlt_properties_fetch (this=0x0, name=0x82aaa6a "terminate_on_pause") at mlt_properties.c:348
#1 0xb805a84f in mlt_properties_set_int (this=0x0, name=0x82aaa6a "terminate_on_pause", value=1) at mlt_properties.c:738
#2 0xb80419b0 in Mlt::Properties::set () from /usr/lib/libmlt++.so.2
#3 0x080c23ca in Render::sceneList (this=0xa7f8e80) at /home/development/kdenlive/kdenlive/src/renderer.cpp:910
#4 0x080b3df0 in Monitor::sceneList (this=0xa7f0418) at /home/development/kdenlive/kdenlive/src/monitor.cpp:744
#5 0x08081bce in MainWindow::saveFileAs (this=0xa21c680, outputFileName=@0xbf889bf0) at /home/shimpe/development/kdenlive/kdenlive/src/mainwindow.cpp:1335
#6 0x08091c28 in MainWindow::saveFileAs (this=0xa21c680) at /home/development/kdenlive/kdenlive/src/mainwindow.cpp:1369
#7 0x08091d48 in MainWindow::saveFile (this=0xa21c680) at /home/development/kdenlive/kdenlive/src/mainwindow.cpp:1376
#8 0x0809d9d0 in MainWindow::qt_metacall (this=0xa21c680, _c=QMetaObject::InvokeMetaMethod, _id=12, _a=0xbf889d9c) at /home/shimpe/development/kdenlive/kdenlive/build/src/cmake_bindir/mainwindow.moc:272
#9 0xb746ab98 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#10 0xb746afd0 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#11 0xb6a00141 in QAction::triggered () from /usr/lib/libQtGui.so.4
#12 0xb6a016bf in QAction::activate () from /usr/lib/libQtGui.so.4
#13 0xb6ed0d72 in QToolButton::nextCheckState () from /usr/lib/libQtGui.so.4
#14 0xb6de96a3 in ?? () from /usr/lib/libQtGui.so.4
#15 0xb6de9976 in QAbstractButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#16 0xb6ed126c in QToolButton::mouseReleaseEvent () from /usr/lib/libQtGui.so.4
#17 0xb6a5d3b3 in QWidget::event () from /usr/lib/libQtGui.so.4
#18 0xb6de791e in QAbstractButton::event () from /usr/lib/libQtGui.so.4
#19 0xb6ed3c9a in QToolButton::event () from /usr/lib/libQtGui.so.4
#20 0xb6a067bc in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#21 0xb6a0f441 in QApplication::notify () from /usr/lib/libQtGui.so.4
#22 0xb7e175ed in KApplication::notify () from /usr/lib/libkdeui.so.5
#23 0xb7454a2b in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#24 0xb6a0e4ae in QApplicationPrivate::sendMouseEvent () from /usr/lib/libQtGui.so.4
#25 0xb6a7ddc5 in ?? () from /usr/lib/libQtGui.so.4
#26 0xb6a7d266 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#27 0xb6aa79a2 in ?? () from /usr/lib/libQtGui.so.4
#28 0xb613a368 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#29 0xb613d8c3 in ?? () from /usr/lib/libglib-2.0.so.0
#30 0x0a1b2690 in ?? ()
#31 0x00000000 in ?? ()

They *should* be compatible. Try doing a make uninstall of mlt and kdenlive following by 'make clean all install' in each project.

Problem solved!
Turns out I did mess up something (as I expected ;) )

Problem was that my libxml2 was missing (according to apt-get it was installed and at the latest version, but according to configure it was missing. An "apt-get install libxml2 libxml2-dev --reinstall" solved the problem.

Thanks and best regards,
Stefaan.