Deinterlacing doesn't work for me [SOLVED]


I would like my film to be deinterlaced during rendering, but it doesn't seem to work.

In the project settings, the video profile is set to DV/DVD PAL.

The only video clip is originally VHS PAL and has been digitalized as an mjpeg.

In the clip properties, I have tried changing the field order to top and bottom frames to no avail.

In the render dialogue, I have set the scanning to force progressive and force interlaced, both to no avail. I have tried rendering to DV PAL, Mpeg2 and H.264. I have also made my own custom rendering profile where I added the option interlace, interlace=0 and interlace=1 on seperate occasions, all of which didn't work.

Transcoding the clip using FFMPEG with the -vf yadif option deinterlaces properly.

I am using debian wheezy, kdenlive, ffmpeg 0.8.5-6:0.8.5-1, melt 0.7.8

What am I doing wrong?



Current release is 0.9.6, I'd recommend upgrading to the latest release then retry.

I've upgraded to 0.9.2 and still have the same problem. Do you really want me to install from source? Seems daunting. Or should I install the daily builds? However, I think my problem is more related to my settings. I image kdenlive would usually just leave a film interlaced or progressive depending on the source material. How do I explicitly tell it, I want to deinterlace my interlaced film?

hi, was just too out of date, ffmpeg and MLT have moved on since then. Options for getting latest I'd suggest via the build script, rather than building from source tarballs or sunabs PPA if you can use PPA's on your distro, or a daily build from

The force progressive at render time should do the deinterlacing. But you say your project settings are DV/DVD PAL, which is an interlaced project profile, so perhaps that overrides 'force progressive' at render time regardless.

Try creating a custom project for your desired output and choose progressive there, then maybe force progressive at render time to be sure.


thanks for the tips so far. Unfortunately still no luck.

> The force progressive at render time should do the deinterlacing. But you say your project settings are DV/DVD PAL, which > is an interlaced project profile, so perhaps that overrides 'force progressive' at render time regardless.

I saved the project as 768x576 4:3 PAL Progressive an rendered with force progressive set. The resulting film is however still interlaced.

> Options for getting latest I'd suggest via the build script

I installed the build script (really cool) so that I am now running kdenlive 0.9.4-114-g014689d. All to no avail.

Here is the render output on the console:

//STARTING RENDERING: true , false , "/home/rob/kdenlive/20130412/bin/melt" , "square_pal" , "avformat" , "-" , "/tmp/kde-rob/kdenlivewS4450.mlt" , "/home/rob/movies/kdenlive/bollerwagentour.mpg" , () , ("f=mpeg", "acodec=mp2", "ab=384k", "ar=48000", "vcodec=mpeg2video", "minrate=0", "vb=12000k", "bf=2", "b_strategy=1", "trellis=1", "aspect=@4/3", "progressive=1", "threads=1", "real_time=-1") , 0 , 772

Started render process: "/home/rob/kdenlive/20130412/bin/melt" "/tmp/kde-rob/kdenlivewS4450.mlt in=0 out=772 -profile square_pal -consumer avformat:/home/rob/movies/kdenlive/bollerwagentour.mpg progress=1 f=mpeg acodec=mp2 ab=384k ar=48000 vcodec=mpeg2video minrate=0 vb=12000k bf=2 b_strategy=1 trellis=1 aspect=@4/3 progressive=1 threads=1 real_time=-1"

I also tried using the deinterlace=1 option in a custom render profile to no avail.

With the ffmpeg version build with the script (version 1.2), I ran the following command on the original file:

./ffmpeg -i ~/movies/bollerwagen/mplayer_bollerwagen.avi -t 30 -vf yadif -vcodec mpeg2video -b:a 96k -b:v 4000k ~/movies/kdenlive/test.mpeg

And it deinterlaced perfectly.

I'm attaching pictures of the film where it is interlaced by ffmpeg and not interlaced by kdenlive. Maybe it can give someone an idea.

Thanks for the help.

I think you missed one of the steps I mentioned, did you create a custom DV Project Profile for progressive output rather than trying to force progressive in the interlaced DV/DVD PAL project profile?

I took the pre-existing project profile "768x576 4:3 PAL" which is stated to be progressive. See attachment.
Not sure where to create a custom project profile, but 768x576 is actually perfect for me.

If you look in the clip properties of the original mjpeg source file in kdenlive has the clip been interpreted as interlaced? What does a tool like mediainfo say about the original source file does it state its interlaced?


How about doing the test with one or both of these render presets:

- DNxHD 1920x1080p/25 120M
- H.264 1280x720 Normal (here use force progressive)



Not sure what you meant by "DNxHD 1920x1080p/25 120M". It isn't offered as a preset in the rendering window in my version of kdenlive. However, I rendered using the HDV PAL 1080 25p and the output was still interlaced. I also rendered to H.264 resizing to 1280x720 and forcing progressive, and the output was still interlaced.


Clip properties says the following:

Video Codec: MJPEG (Motion JPEG)
Frame size: 720x576
Frame rate: 25.000000
Pixel aspect ratio: 1.06667

Mediainfo says the following:

Complete name : mplayer_bollerwagen.avi
Format : AVI
Format/Info : Audio Video Interleave
Format profile : OpenDML
File size : 2.95 GiB
Duration : 23mn 58s
Overall bit rate : 17.6 Mbps
Writing application : MEncoder dev-SVN-rUNKNOWN-4.1.2
Writing library : MPlayer

ID : 0
Format : JPEG
Codec ID : MJPG
Duration : 23mn 57s
Bit rate : 16.1 Mbps
Width : 720 pixels
Height : 576 pixels
Display aspect ratio : 4:3
Frame rate : 25.000 fps
Standard : PAL
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Compression mode : Lossy
Bits/(Pixel*Frame) : 1.552
Stream size : 2.69 GiB (91%)

ID : 1
Format : PCM
Format settings, Endianness : Little
Format settings, Sign : Signed
Codec ID : 1
Duration : 23mn 58s
Bit rate mode : Constant
Bit rate : 1 536 Kbps
Channel(s) : 2 channels
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Stream size : 263 MiB (9%)
Interleave, duration : 500 ms (12.50 video frames)

Thanks so much for looking at this.

Ok, tested this problem with a interlaced dv clip and transcode to mjpeg with MPlayer with the latest kdenlive/MLT build but I think any recent build should work and the problem I found goes back to Project Profile and ensuring it's 'Progressive' rather than 'Interlaced' and that the mjpeg files don't flag interlaced scan type so assumed progressive by kdenlive / MLT as you may see from the mediainfo output, there's no mention of the 'Scan Type' and 'Scan Order' items in your output, for correctly flagged interlaced files there will be.

But just forcing the scanning in the clip properties is not enough if the Project Profile is 'Interlaced', if the Project Profile is not 'progressive' deinterlacing in the monitor using the recently added deinterlacer options and force progressive at render time don't work.

Together with a progressive project profile with regard to mjpeg avi, you also need to force scanning to interlaced and force field order to top or bottom field first if known (BFF is generally the method used), because the mjpeg stream information does not state 'interlaced' and therefore assumed progressive kdenlive / MLT so deinterlacing and force progressive at render time are ignored.

Thanks yellow, that did the trick. Somehow I never tried setting the scanning option to interlaced in the clip properties window. To sum things up, in order to get my mjpeg file deinterlaced: I had to set my project profile to "768x576 4:3 PAL" with progressive; in the clip properties, I had to set scanning to interlaced and set force fields to bottom frame first; in the render dialog, I had to set force progressive.

Thanks to everyone for their help.