Disabled containers in render dialog [SOLVED]

I have built kdenlive from trunk using build-kdenlive.sh.
However the render dialog shows red crosses for all the options under mpeg-4, xvid4 and flash.
I *think* I have all the correct build requires, and I am launching it with the start_kdenlive.sh script to set up the environment.

The configuration wizard shows mlt version 0.6.0 and mlt dir is correct.

I also have 7.8 installed on the system, and this is also now showing the same behaviour with mlt 5.10. It worked fine with mpeg-4 previously.

Since the script builds it's own major dependencies from git/svn there should be no interaction between the two installed versions AFAICT.

I have tried renaming the kdenlive dir under ~/.kde4 with no change.

Otherwise, the latest trunk is working well and appears to have solved a transcoding to mkv and sound sync issue that I had in 7.8.

Any ideas anyone?

This is so frustrating.

I tested kdenlive 7.8 in a new user account and it offered all the mpeg-4 render to file options. No problem.
I built kdenlive trunk in the new user account and it still showed all mpeg-4 render to file options with red cross.
I used the trunk version to create a small project and then closed trunk and ran 7.8 to render it to mpeg-4 file - which worked fine twice.
I then copied an existing project file from my normal user account to the new user and (after sorting file permissions) loaded it into 7.8 - on doing this the mpeg-4 render to file options became red crossed.
After re-running 7.8 with no project loaded they are still the same, so I now have 4 versions of kdenlive in two user accounts - none of which will render to file using mpeg-4.

Has nobody got a clue what is happening here? I have been at this for days now and I have hit a brick wall.

Attached is part of the ffmpeg build output showing enabled modules, which (edit) - I now notice does not show mpeg-4 in the list of available muxers - is this the reason? and how can I fix it?

I finally fixed it.
The build script defaults to excluding libmp3lame support in the configure for the ffmpeg build.

I can at last get back to work!

Thanks for all the ideas everyone ;-/ ouch - only kidding.