Does the Contour ShuttlePRO v2 really works ?

I'm considering buying the ShuttlePRO v2:
But before I do that I want to know that this is working like it shood.
If I'm searching the internet there are a lot of issues with it, nevertheless there is a nice menu in Kdenlive to set up the 15 keys of that shuttle.
So, are there some users on the forum who can give some feedback of the shuttlePRO v2 ?

I've the ShuttlePro (not v2), and that one now seems to work in actual version on short test.

So today I received my ShuttloPro v2 and give it a try in Kdenlive.
At first it was not possible to select the ShuttlePro in Kdenlive, so nothing worked.
Then I did some searching on the internet and I red something about Kino and the ShuttlePro that you must run Kino as Root.
So I decided to do the same with Kdenlive (sudo kdenlive in the terminal) and by surprice I could select the ShuttlePro and progam the 15 buttons and afterwards everything worked fine :-)
Now my question is, how can I work with the Shuttle pro without running Kdenlive as root?
Has this something to do with Rights and USB equipment?
I am working with Ubuntu 12.04

Check the permissions on the Shuttle's USB device file.

Try something like

dmesg | grep Shuttle

to find out what that is, then

sudo chmod 666 that_device

However, it could be that you'll need to do that each time, as the hotplug system tends to revert the permissions.

I haven't yet found out how to prevent that.

Thanks Marko, but I want a permanent solution.
I found this:
I'm gone try that on my other computer first one of these days.

Ok, it's working by running Kdenlive in normal mode :-)
This is what I did:
sudo groupadd -f input
sudo gpasswd -a username input (username=your loginname)
gksudo gedit /etc/udev/rules.d/99-input.rules
and put the next text in it:
KERNEL=="event*", NAME="input/%k", MODE:="660", GROUP="input"
KERNEL=="js*", NAME="input/%k", MODE:="664", GROUP="input"
Save this file and reboot the computer and the ShuttlePro v2 is available.