Does not rescale video

I have installed Kdenlive 0.7.2.1 and tried to render final video. But it does not proceed the option "rescale". Video has always the same resolution as original. Rendering output:

//STARTING RENDERING: true , false , "/usr/bin/inigo" , "/home/marek/.kde4/share/apps/kdenlive/profiles//customprofile0" , "avformat" , "-" , "/tmp/kde-marek/kdenlivek19598.westley" , "/home/marek/working_directory_images/temp2/untitled.flv" , () , ("f=flv", "acodec=libmp3lame", "ab=128k", "ar=44100", "vcodec=flv", "minrate=0", "b=200k", "s=0x0") , -1 , -1

Started render process: "/usr/bin/inigo" "/tmp/kde-marek/kdenlivek19598.westley -profile /home/marek/.kde4/share/apps/kdenlive/profiles//customprofile0 -consumer avformat:/home/marek/working_directory_images/temp2/untitled.flv progress=1 f=flv acodec=libmp3lame ab=128k ar=44100 vcodec=flv minrate=0 b=200k s=0x0"

Rendering of "/home/marek/working_directory_images/temp2/untitled.flv" finished

Forums:

I have found the same thing to be true.

Using 0.7.2.1 in Ubuntu "Intrepid"

Did you also upgrade MLT? Resizing is a new MLT feature.

I have MLT from debian-multimedia.org:

unstable: mlt (1:0.3.6-0.1) http://www.debian-multimedia.org/dists/unstable/main/binary-amd64/packag...

Rescaling does not worked for any format I tested. Beside of it, there was no difference for various H.264 subformats. Output file was always the same size. And quite big.

Yes, I think there is a bug in Kdenlive 0.7.2.x which prevents rescaling while rendering. As a workaround, you can edit a profile and manually add "s=320x200" to the parameters to create a 320 x 200 video.

I plan to release Kdenlive 0.7.3 in 2-3 weeks for a real fix to this issue.