every clip is invalid [FIXED WITH MLT 0.8.2]


Well, things were going along fine, until I decided to add a new user and migrate to it and ditch the old user. After that, I noticed K3b can't detect 3 executables it needs for burning disks. Then I started Kdenlive and added some clips. All of them wer invalid and removed from project. That was with MTS clips, and then I tried .flv.

I really can't say if the Kdenlive problem is from migrating user, it could be something else. But it might be both KDE app's have got stuck because my new user lacks permissions or is not member of a certain group. Just wondering if anyone could put a finger on it from previous experience or knowledge about users. I did an apt-get remove and install of kdenlive but that did'nt fix it.

Otherwise its time to install all over again, but surely that is the last resort.
Debian Wheezy vmlinuz-3.2.0-2-amd64, LXDE

cheers a lot

OK its fixed, kdenlive with upgrading mlt to 0.8.2
k3b with programme permissions chown user

This same error "Clip invalid" came up when I updated to MLT 5 0.8.6 in OpenSuse 12.2 64bit. I had a project with 7 clips all .MP4. It removed all 7 clips. Once I flipped back to 0.8.2, the project loaded properly.

If there is that tight of integration between KDEnlive and MLT, maybe the app should check every time it starts for the correct MLT version--not just on first install.