Fedora 10 - successful install using Kdenlive Builder Wizard

Hi there,

I have been able to get Kdenlive to build successfully on Fedora 10 using the Kdenlive Builder Wizard so I thought it might help anyone else trying to build on Fedora/Centos/Redhat platforms.
Many thanks to j-b-m as I've basically adapted his guide on this forum to work with Fedora 10.

You will need to have rpmfusion installed before you begin (see rpmfusion configuration).
I would also suggest that the development libraries/tools and subversion are installed, althought I haven't gone into detail to check actual requirements as yet.

Development Libraries/Tools/Subversion (recommended for compiling from source)
sudo yum groupinstall "Development Libraries"
sudo yum groupinstall "Development Tools"
sudo yum install subversion

General libraries
sudo yum install qt-devel kdelibs-devel kdelibs3-devel kdebase-runtime
sudo yum install SDL-devel SDL_image-devel
sudo yum install libxml2 libxml2-devel

Screen capture

sudo yum install recordmydesktop

Firewire and DV
sudo yum install dvgrab
sudo yum install libdv libdv-devel

Audio and Video codecs
sudo yum install x264 x264-libs x264-devel
sudo yum install libtheora libtheora-devel
sudo yum install xvidcore xvidcore-devel
sudo yum install libogg libogg-devel
sudo yum install libvorbis libvorbis-devel
sudo yum install schroedinger schroedinger-devel
sudo yum install lame lame-devel
sudo yum install libquicktime libquicktime-devel
sudo yum install faac faac-devel
sudo yum install faad2 faad2-devel
sudo yum install gsm gsm-devel
sudo yum install amrnb amrnb-devel amrwb amrwb-devel

Sound Processing and Effects

sudo yum install libsamplerate libsamplerate-devel
sudo yum install jack-audio-connection-kit-devel
sudo yum install sox sox-devel
sudo yum install ladspa-devel
sudo yum install ladspa-swh-plugins
sudo yum install libmad-devel

Video effects and image processing

# Install frei0r video effects
cd ~/Download
git clone git://code.dyne.org/frei0r.git
cd frei0r
./autogen.sh
./configure
make && sudo make install

Note: frei0r should be enabled in the Kdenlive Builder Wizard - you don't need to manually install frei0r.

sudo yum install gdk-pixbuf gdk-pixbuf-devel
sudo yum install pango-devel

Performance
sudo yum install yasm yasm-devel

kmdr-executor (Kommander)
sudo yum install kdewebdev
sudo yum install soprano-devel

Alsa-lib-devel (Otherwise you will get an lasound error in kmdr builder)

sudo yum install alsa-lib-devel

gtk2-devel (Otherwise Kdenlive Builder Wizard will fail MLT build
sudo yum install gtk2 gtk2-devel

Kdenlive Builder Wizard Options (Required for MLT to build and for additional features)
Kdenlive Builder Wizard > Compile Options > Advanced

- Enable fre0ir support
- Enable Theora support
- Enable AAC support
- Enable MP3 support
- Enable h264 support
- QImage Lib dir = /usr/lib (for i386) or /usr/lib64 (for x86_64)
- QImage include dir /usr/include/Qt

Download the Kdenlive Builder Wizard Kommander script
Download from http://www.kde-apps.org/CONTENT/content-files/85826-kdenlive_builder_wizard.kmdr.bz2

Run the Kdenlive Builder Wizard
kmdr-executor 85826-kdenlive_builder_wizard.kmdr

The Kdenlive Builder Wizard completes successfully, with the only issues being:

Some modules were disabled in MLT
- mmx

mmx will be disabled if you are running x86_64, this is ok.

This installed:

FFmpeg revision 15910
Mlt revision 1240
Mlt++ revision 1240
Kdenlive revision 2720

Kdenlive looks great, with more features than the current Fedora 10 packages at russionfedora.
The stability is an issue though, with it crashing out mainly when moving between the clip monitor and project monitor.
I also can't create a new project for some reason, but I can work with an existing project.

Hopefully if more people are able to build the latest version against Fedora 10 we can speed up the submission and resolution of these bugs.
Hope this helps anyone running Fedora 10!

Cheers,
Andrew

Cheers, this'll come in handy. Helping a friend install kdenlive on his fedora 10 soon, should save me a couple of headaches.

Great help with your tuto. (first compile abort because I misread qimage inc dir)

For frei0r we can get source from :

http://www.piksel.org/frei0r

And after compile && install that's OK for MLT.

 

I've edited my original post to add the frei0r build procedure.

Unfortunately kdenlive is currently very unstable on Fedora 10, see Mantis bugs 0000684 and 0000688

Andrew,

great  tutorial!!

Afaik -mmx must be disabled with x86_64 systems.

I can confirm stability is a big issue both from binaries and from source with Fedora.

Can you reproduce bug 410?

http://www.kdenlive.org/mantis/view.php?id=410

It turned out to be Fedora-related....

thanks

luca

 

Hi Luca,

I've just checked further and it is definitely the clip monitor that is the issue.

If I add clips and drag them directly to the timeline without editing them in the clip monitor kdenlive is stable and I can edit tracks in the timeline.
I don't mind cutting clips directly in the timeline, so this will be useable for me for the meantime.

Cheers,
Andrew

 

Luca - I've updated bug 0000410, after further testing it seems to be caused by playback of video, once this occurs you can't click on any clip in the project manager or go into the clip monitor without kdenlive crashing.

Andrew

 Hello,

 Your instructions for Fedora compiling of kdenlive is great! But, I if you do not have installed gtk2 and gtk2-devel libraries, the mlt compiling will fail, so please update your first post and add

 yum install gtk2 gtk2-devel

The second problem is enabling x264 and xvid encoding in kdenlive's renderer.

So, I enable ffmpeg x264 and xvid compiling (with adding --enable-libx264 –enable-libxvid options in KWB's script)
Compiling of ffmpeg was successful, but after compiling and installing kdenlive, this two render options is still grayed in kdenlive.

Why?

 

This is part of my log file:

KBWTRACE: Entering cmd @ = ./configure --prefix=/home/zarko/kdenlive --disable-network --disable-ffserver --enable-gpl --enable-shared --enable-debug --enable-pthreads --enable-libx264 --enable-libxvid --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-x11grab --enable-libfaac --enable-libfaad
KBWLOG: About to run command: ./configure --prefix=/home/zarko/kdenlive --disable-network --disable-ffserver --enable-gpl --enable-shared --enable-debug --enable-pthreads --enable-libx264 --enable-libxvid --enable-libtheora --enable-libvorbis --enable-libmp3lame --enable-x11grab --enable-libfaac --enable-libfaad
install prefix /home/zarko/kdenlive
source path /home/zarko/src/ffmpeg
C compiler gcc
.align is power-of-two no
ARCH x86 (generic)
big-endian no
yasm yes
MMX enabled yes
MMX2 enabled yes
3DNow! enabled yes
3DNow! extended enabled yes
SSE enabled yes
SSSE3 enabled yes
CMOV enabled no
CMOV is fast no
EBX available yes
EBP available yes
10 operands supported yes
gprof enabled no
debug symbols yes
strip symbols yes
optimizations yes
static yes
shared yes
postprocessing support no
new filter support no
filters using lavformat no
network support no
threading support pthreads
SDL support yes
Sun medialib support no
AVISynth enabled no
libamr-nb support no
libamr-wb support no
libdc1394 support no
libdirac enabled no
libfaac enabled yes
libfaad enabled yes
libfaad dlopened no
libgsm enabled no
libmp3lame enabled yes
libnut enabled no
libopenjpeg enabled no
libschroedinger enabled no
libspeex enabled no
libtheora enabled yes
libvorbis enabled yes
libx264 enabled yes
libxvid enabled yes
zlib enabled yes
bzlib enabled yes

 

 

 

Thanks Grof, I've updated the Fedora 10 build guide above.

I haven't tried enabling x264 and xvid encoding, will take a look tomorrow and see if I can sort it out.

Cheers,
Andrew

Finally, I successfuly build mlt, mlt++ and kdenlive from source, according manual from kdenlive site (without KBW). Of course, I used ffmpeg, ffmpeg-libs anf ffmpeg-devel packets from Fedora repos (I do not rebuild ffmpeg).

But, I successfuly build .RPM packets for Fedora 10 and I thnking about put them to rpm-fusion repo.

I opened a new topic on forum for Kdenlive RPM packets with links to my dropbox's files.

 

I've tried to get x264 and xvid render support working, but have had no luck.

I tried installed x264 from source (after removing x264 packages using yum - WARNING this may remove other apps e.g. vlc)

sudo yum remove x264*
cd ~/src
git clone git://git.videolan.org/x264.git
cd x264
make clean
./configure --enable-shared
make && sudo make install

I then changed configure for ffmpeg in the Kdenlive Builder Wizard to:

  CONFIG[0]="./configure --prefix=$FINAL_INSTALL_DIR --disable-network --disable-ffserver --enable-gpl --enable-shared --enable-debug --enable-pthreads --enable-libx264 --enable-libxvid --enable-libfaac --enable-libmp3lame"

The Kdenlive Builder Wizard builds everything successfully, but x264 and xvid are still greyed out in the renderer.
I tried encoding using ffmpeg with x264 and I get a segmentation fault, so maybe there is still another issue somewhere.

./ffmpeg -i 00009.MTS -vcodec libx264 OUTPUT.mp4
FFmpeg version SVN-r17855, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  configuration: --prefix=/home/andrews/kdenlive --disable-network --disable-ffserver --enable-gpl --enabd
  libavutil     49.15. 0 / 49.15. 0
  libavcodec    52.21. 0 / 52.21. 0
  libavformat   52.31. 1 / 52.31. 1
  libavdevice   52. 1. 0 / 52. 1. 0
  libswscale     0. 7. 1 /  0. 7. 1
  built on Mar  9 2009 22:22:21, gcc: 4.3.2 20081105 (Red Hat 4.3.2-7)
Input #0, mpegts, from '00009.MTS':
  Duration: 00:00:36.54, start: 0.767000, bitrate: 6884 kb/s
  Program 1
    Stream #0.0[0x1011]: Video: h264, yuv420p, 1440x1080 [PAR 4:3 DAR 16:9], 59.94 tbr, 90k tbn, 59.94 tbc
    Stream #0.1[0x1100]: Audio: ac3, 48000 Hz, stereo, s16, 256 kb/s
File 'OUTPUT.mp4' already exists. Overwrite ? [y/N] y
Output #0, mp4, to 'OUTPUT.mp4':
    Stream #0.0: Video: libx264, yuv420p, 1440x1080 [PAR 4:3 DAR 16:9], q=2-31, 200 kb/s, 90k tbn, 59.94 c
    Stream #0.1: Audio: libfaac, 48000 Hz, stereo, s16, 64 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
Segmentation fault
 

 

 

For remove grayed options you must start again Config Wizard (Settings/Config Wizard) to accept new encoders. Check them in wizard (Sec. screen - Checking MLT engine, tab Aviable Codecs).

After finishing Wizard, xvid and x264 will be ungrayed.

 

"Segmentation fault" I solved with using ffmpeg from Fedora's repos and do not compiling them from source! (see this link) Chapter: Installing FFmpeg packages.

 

 

Hi Andrew,

The following package is also needed for kconfig_compiler (not to be confused with kconfig_compiler4) or else the Kdenlive Builder Wizard fails (in my case anyhow):

o kdelibs3-devel

Fyi, I have also installed the following packages; all this enabled me to build a "Revision: 3140 Last Changed Date: 2009-03-11 23:11:52 +0100" version of kdenlive:

o dirac, dirac-devel, dirac-libs

o faad2-libs

o SDL_Pango, SDL_Pango-devel

o libresample-devel, libxml-devel

o ladspa-{amb,blop,caps,cmt,mcp,rev,tap,vco}-plugins

o gcc, make (!)

I am still having a lot of stability issues --- starting with simple things like adding or removing clips, so for the moment openSUSE still remains my distro of choice for Kdenlive...

Regards, Eric