ffmpeg needs option "--enable-nonfree

Hi,

I don't know since which version, but at the moment it's necessary to add the option:

"--enable-nonfree" under Install Options >> Advanced >> ffmpeg options >> additional options.

Otherwise you will get (using the wizard) an error Unable to configure ffmpeg.

CU
Tom

Please be clearer. What are you referring to? Installing Kdenlive? Installing ffmpeg? Compiling and installing Kdenlive using the wizard? The startup wizard when you start Kdenlive the first time?

This happens during compiling and installing kdenlive with the wizard.
I do this from time to time. At the end of April this was not necessary, but
at least since last week (sorry I don't know the release of ffmpeg) this seems
to be an issue.

Tom

Yes, FFmpeg recently changed the --enable-libfaac to require --enable-nonfree due to some inconsisent licensing declarations in the faac source. You can also workaround this by not enabling AAC in the wizard. They have a native AAC encoder in progress, but it is not ready and enabled yet.