Greenscreening interlaced footage?

Hello all,

I've got some greenscreen footage which is all interlaced. The interlacing seems to play hell with the various greenscreen effects. I don't see any difference in the project monitor when I apply "force progressive" in the clip properties.

How is everyone else dealing with greenscreening interlaced footage? Do you all just re-render all your footage to a progressive format, or is there a more elegant way in kdenlive without the rendering?

You may do better deinterlacing your source files before doing the greenscreen effects. I think the force progressive deinterlaces at render time. I haven't used the chromakey filters in kdenlive but believe they were updated quite recently or at least color spill added, so are you using a recent build.

Probably the chromakey tool works in RGB so deinterlacing would have to be done on the frames the filter is applied to so maybe the source files are too much for the filters to deal with?

Yes, I'm using the git version of Kdenlive. Still, I can't seem to get the force progressive option to make anything different, either in the Project Monitor, or in the renders. Everything comes out as interlaced as it went in.

Sorta solved this by rendering a deinterlaced version. Just edited the transcode > Lossless MKV, adding -deinterlace right at the start.

It meant doing a transcode, but works a treat.