HELP: Ubuntu 9.10 fresh install, ffplay and melt crash

Guys, I need your help: i just did a fresh install of Ubuntu 9.10, with no changes (i dl the live cd yesterday, and installed it, didnt upgrade it yet). I also installed ffplay (sudo apt-get install ffplay) and melt, and testet both of them with a .dv file that works: no luck, they both crash immediately.
Could you pls help me and get them to work? The thing is, that neither kdenlive (not the one installed from Karmics Softare Center, 0.75, and also not the 0.76 isntalled from the net) works (the preview monitor doesnt show the video when i press play, but if i move the cursor back and forth, i see the video)...

MELT ERROR:
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+
Segmentation fault 4

FFPLAY ERROR:
FFplay version SVN-r19352-4:0.5+svn20090706-2ubuntu2, Copyright (c) 2003-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5+svn20090706-2ubuntu2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --extra-cflags=-I/build/buildd/ffmpeg-0.5+svn20090706/debian/include --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 0 / 52.20. 0
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Oct 13 2009 22:15:16, gcc: 4.4.1
Segmentation fault

try installing:

libsdl1.2debian-pulseaudio

or

libsdl1.2debian-all

and test again

make sure that kdenlive audio prefs are set to pulseaudio

No changes with none of them: ffplay, melt and aviplay still crash. Mplayer works.

melt -query producers
---
producers:
- qimage
- pgm
- melt
- melt_file
- vorbis
- avformat
- frei0r.ising0r
- frei0r.lissajous0r
- frei0r.nois0r
- frei0r.onecol0r
- frei0r.partik0l
- libdv
- pango
- pixbuf
- xml
- xml-string
- framebuffer
- color
- colour
- consumer
- loader
- hold
- noise
- ppm
- kino

Please, someone, help me...

Contrary to rico's advice, I would suggest removing pulseaudio using synaptic if it is installed as discussed elsewhere on this forum. Agreed you probably want to make sure libsdl1.2debian-all is installed.

Test the file in ffplay and melt.

I set kdenlive preferences to default (which presumably uses alsa).

Hope this helps. As discussed in several posts, I've had numerous weird problems with ffplay/melt/kdenlive when using pulseaudio. However, some have been okay with pulse.

I now installed kdenlive from the karmic's software center (0.75) - all of the required packages are installed - still the same error. Project monitor works if i manually move the cursor, but if i press play, there's no video (the whole project monitor is black, only the upper 1/10 gets some coloured lines)... Sound works.

I removed pulse audio (sudo apt-get purge pulseaudio): ffplay, melt and aviplay still dont work. Kdenlive now crashes when i press play (yes, audio prefferences are set to automatic).
Damn, i knew i should have not upaded ubuntu...

Add

deb http://ppa.launchpad.net/sunab/ppa/ubuntu karmic main
to your /etc/apt/sources.list
remove melt/mlt/kdenlive/pulseaudio
update and upgrade your system
then install kdenlive/mlt/melt/frei0r

This worked for me on fresh 9.10 Ubuntu 64bit., didn't work without the system upgrade.

Did as you told me to, now kdenlive crashes immediately after pressing play. And still, ffplay and melt, they also crash...

don't set audio to automatic, set it to pulseaudio or alsa (depending which one you are using)

I have tried all good ideas about the sound, but they are not working. Video works fine.
I have set it to Automatic, OSS, ALSA and PulseAudio. OSS crashes, and the other three sounds like a trans-atlactic phonecall in the forties = 90 % noise.
I have a 3 minute sound-clip from a park. it is a wav-file. In Audacity it sounds perfect, but in Kdenlive it is 90 % noise. Without changing the settings in between.
Any suggestions?
The sound on my Ubuntu 9.10 seems to work fine - except in Kdenlive.
UPDATED:
I have installed OpenShot, which is another editor like Kdenlive. It is based on GTK, MLT and programmed in Python. OpenShot has same audio-problem. It sucks.
I have tried to remove audiopulse. No effect, so I installed it again.
So: I still have a fresh Ubuntu 9.10 install. Audio works perfect, except in Kdenlive and OpenShot - the two pieces of software that use MLT.
Is there a problem in MLT, or in the combination Karmic Koala and MLT?
Any suggestions? Help, please...

It seems like nobody has any suggestions, so I have made my own solution.

I have made a Ubuntu dual-boot installation on my PC.
1) I have a 180 Gbyte installation with Ubuntu 9.10. Here everything works, except Kdenlive
2) I have a 100 Gbyte installation with Ubuntu 9.04. Here everything works, including Kdenlive.

They are installed on the same harddisc, with the same soundcard, and standard settings. I have not made any special settings.

I would be very nice, if someone could explain why it is so...

Thanks!

David

David, I am the MLT developer. I have not reproduced your problem with Ubuntu 9.10 on 2 installations (one in a VM). What I do get is a little crackling on one system using PulseAudio and libsdl1.2debian-pulseaudio, but you describe problem as much worse. Here are some tests for you on 9.10.
Do you get the same problem if you play a clip with ffplay?

If not, in Kdenlive, render a small clip or portion of a clip and play the result with ffplay, vlc, totem or whatever that you know is good. Does it have this heavy distortion?

Hi All,

I have very similar experiences to many of the posts here. Most notably:

Fresh install: Ubuntu 9.10 and kdenlive (using sunab ppa) = problems with kdenlive
Fresh install: Ubuntu 9.04 and kdenlive (using sunab ppa) = kdenlive works fine

(By the way I am using Sun VirtualBox to run virtual machines and try these things out. Usually it works very well.)

My problems with 9.10 and kdenlive are, I think, related to MLT (but I am a novice in this area so I am willing to be proved wrong!).

Basic problem:
Since (fresh) installing Ubuntu 9.10 and kdenlive 0.7.6 using the ppa, the project & clips monitor view works when searching single frames but when asked to play the video file, they show the video squashed up into the top 1/10th of the frame with either a green block underneath or a mass of coloured lines. The project monitor then appears to hang at some point.

Tests done:
ffplay plays the original video file fine, as does Movie Player.
melt does not play the original video file OK but shows the same as the project monitor in kdenlive and then crashes with a segmentation fault at some point.
A short clip rendered from the original video file plays fine with Movie Player but not with ffplay which now shows something similar to the project monitor in kdenlive and then crashes with a segmentation fault error. When played with melt then the result is the same except that it seems to just hang instead of crash.
The sound when played in Movie Player is fine but when using melt the soundtrack sounds “cut up”.

Does all this give any clues as to what's going on?

Apart from this, I like Kdenlive very much!

I was having audio problems/program locking up on a clean Ubuntu 9.10 install. I performed step A below and that corrected my probelms.

http://ubuntuforums.org/showthread.php?t=789578

After a lot of removals and installations, it finally works - almost perfect.

DDennedy: I tried your suggestions. ffplay played a .wav file perfectly. Same file in Kdenlive sounded awful. I then tried to render a portion of a clip, and with the same problem.

After that I removed ffmpeg, Kdenlive and pulseaudio. I tried to install Kdenlive again, and suddenly (after a reboot) it worked. It must be the absence of pulseaudio, that made it work, but I have tried that once before, without any luck.

I'm back on the track, and I've been at the library to borrow some C++ books. I hope that I, sometime in the future, can be helpfull in the development of great software like Kdenlive, and the like...

TandJ, the version of SDL in Ubuntu 9.10 is incompatible with some X server drivers or X itself and a particular feature of SDL that MLT uses. I confirmed this is fixed in the latest version of SDL I built from source tarball, but I do not know when it will appear in Debian or Ubuntu. Looks like we need to start a campaign to request that upgrade if it has not already started. I will look around or file a ticket somewhere.

I think I'm having the same problem.
ffplay, melt, kdenlive and openshot all show a few frames (variable 3 > 20 frames ) seconds of what appears to be squashed video in the top 5% of the window with vertical lines and blocks of unrelated colour in the rest of the screen. Then it (all of them) exits with segmentation fault. I've tried with different audio configurations but to no avail. I've tried compiling SDL 1.2.14 but am complete novice at such things and got no result (I followed instructions at http://www.libsdl.org/cgi/docwiki.cgi/FAQ_Compiling_on_Linux but get nothing for sdl-config).
Looking forward to 1.2.14 being in karmic.

Hi,
I have the same problem. If clicking play the audio is awful and the video is having a hard time, and 50% of the times Kdenlive simply crash. I have tried for a week now making changes to pulseaudio/ALSA and so on, but it doesn't work. I use ubuntu 9.10 (GNOME) and Kdenlive 0.7.6

Hello, thank you for the description of the problem and your trials. On my system I had almost exactly the same difficulties with the sound as you described it. I'm not good at Linux, and as a learner I appreciate people who can help out. I like kdenlive, it is a really fine tool. In the end, after exactly doing what you described in your last posting it worked again with 9.10 - after some frustrating trials of my own. Of course I also want to thank all the developers of the software and those who gave you the hint how to do it.

Fresh 9.10: I've been trying to get this to work and, following your advise (removing pulseaudio and kdenlive), I got rid of the crashing and sound problems. This is the first time I do any kind of Linux -debugging in my entire life, so it felt pretty rewarding. Thank you. Annoying though: removing pulseaudio removes the volume -switch on the desktop interface and I don't know how to get it back. Thankfully there's sound in kdenlive and vlc, but if anyone can help with this please tell!

As a followup to the problem with the squeezed and green video, I confirmed that this is a bug in the 1.2.13 version of SDL provided in Ubuntu 9.10 and some X server drivers. I also confirmed that the newer 1.2.14 version of SDL fixes this problem on the X server where I was able to reproduce this problem and there is no workaround or fix I can make in MLT to make it work with 1.2.13.

Could you guys open a bug on Ubuntu and various distros trancking systems.

Hi,

Thanks ddennedy for researching my problem and finding the cause - much appreciated.

jmpoure: I have followed your example and posted a bug report on Ubuntu's system: https://bugs.launchpad.net/ubuntu/+source/libsdl1.2/+bug/491335

Watch this space...

Hi!

My first posting here on the forum, so let me begin by saying a huge Thank You to all the developers of kdenlive! It is truly a wonderful thing.

I also got problems after upgrading to Ubuntu 9.10.

Kdenlive crashes immediately when i try to playback anything. (with some green screen and/or squeezed picture for a little while)

I upgraded my libsdl to 1.2.14:
- removed kdenlive, melt, ffmpeg libsdl ...
- installed libsdl1.2debian-all_1.2.14-1_i386.deb

When i reinstall kdenlive using apt-get, it replaces sdl 1.2.14 with 1.2.13, so I am back where i started from. I am obviously doing it wrong. How should I do it?

thank you for your help

greetings,
Antti

Hi,

A helpful posting by bojo42 on the bug I reported (follow link above) led me to add the PPA http://ppa.launchpad.net/dnjl/games/ubuntu to my software sources as this has the SDL version 1.2.14 package.

I then installed this SDL version using Synaptic and then re-installed Kdenlive (which did not replace the new SDL version).

When I then used Kdenlive I experienced some of the problems already posted concerning crackling sound and jerky video. So I then installed libsdl1.2debian-pulseaudio using Synaptic as advised by some of the posts (e.g. mseewald http://kdenlive.org/forum/remember-remove-pulseaudio-if-using-kubuntu-ka...) and everything now seems to work fine.

Thanks very much everyone for your help.