How to get a CBR Mpeg2 output

Hello, i'm italian and my enghlish is not good...However, I try to post

 

I'm very fun with kdenlive, imho is the best video editing software under GNU/Linux...

 

My problem was that, with the default rendering profile, i can't get a CBR Mpeg2. The output seems to be a VBR Mpeg. I resolved the problem adding some parameter to the parameter line as in the example below:

Original parameter line:

f=mpeg acodec=mp2 ab=384k ar=48000 vcodec=mpeg2video minrate=0 b=4000k bf=2 b_strategy=1 trellis=1 aspect=%dar

 

Modified parameter line:

 

f=mpeg acodec=mp2 ab=384k ar=48000 vcodec=mpeg2video minrate=4000k maxrate=4000k bufsize=1835k b=4000k bf=2 b_strategy=1 trellis=1 aspect=%dar

 

In the second case a CBR output is guaranteed.

 

I believe that it may be useful to include the CBR's rendering profile in the future software rlease.

Forums: