How to proceed after ffmpeg patch?

Hi all together,

In this thread we discuss about a problem with Interlaced Video.

http://kdenlive.org/forum/problem-interlaced-files

The "solution" is to patch ffmpeg and build it from sources.
I'm not a linux professional and I did my first ffmpeg compilation on a test machine. There was only ffmepg installed, which I've removed before building it from sources.

On my productive system there's a lot installed which depends on ffmpeg or on it's libs.

So the question is: Have I from now on to build all other software from sources which depends on ffmpeg or ffmpeg's libavcodec?
Affected is MLT, Kdenlive, VLC and so on and this means that I should follow the instructions from this guide.

http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/inst...

Is it correct or is an faster and easier way available?

Thanks
Christian

i use gentoo, but i think on debian you can download also the sources of the same version that ist installed as binary ?
this would solve your problem with missing libs from ffmpeg.

else you could install mlt/kdenlive also in a new dir and compile it there.
but i think you need a bit more linux knowlegde for this.

there was a build script for kdenlive (kdenlivebuilder ?? ) , which will download, compile and set the needed stuff for you.

i don't seem to have any issues with interlaced files, I use the force progressive setting when rendering to x264/aac 10k 2 pass mp4 file. I am using the following combo of software and not sure what distro you're using. im using ubuntu 10.04 (lucid lynx)
ffmpeg = medibuntu repo (SVN-r0.5.1-4:0.5.1-1ubuntu1)
libavcodec-extra-52 and all other ffmpeg libraries (4:0.5.1-1ubuntu1+medibuntu1)
mlt = sanub2 PPA (0.5.7+git20100907.c8b11129-0ubuntu0~sunab~lucid1)
kdenlive = sanub2 PPA (0.7.7.1+svn20100907.r4857-0ubuntu0~sunab~lucid1 )

my videos are only SD but they turn out damn good IMO. here's an example.

http://www.youtube.com/watch?v=bYcOzNUiLgg

@g.marco
Thanks for this Info. I use OpenSuse 11.3.
Kdenlive, MLT, ffmpeg are from the external "Packman" repository.
I've seen there are also source rpm's available! I'll try to patch these.

Parallel I'm learning, learning, learning! I've startet to build MLT. The problem is the available free time. Such things wherefore a pro only needs 5 Minutes costs me 5 Hours at the moment :(

@ubuntuaddicted
That what you want to get as result isn't the same!
There's an issue with the x264 encoding implementation into ffmpeg. You'll get trouble if you render to interlaced x264 output. Please read the other thread and you will be well informed :)

@ubuntuaddicted

how can you have no issues with interlaced files, when you render to progressive mp4 ? this problem appears only if you render to interlaced mp4.
if you are ok with lower quality video, this is ok.
for encode to interlaced mp4, this patch is needed.

@lxvidcut
i hope that you will get it then.

i apologize for my misunderstanding of the thread and not reading the original issue.

I did it successfully on my virtual machine!

I've patched ffmpeg without breaking dependencies.

Here is a short description. Feel free to comment.

download ffmpeg source rpm from packman (same version like the binaries)
rpm -i .src.rpm
extract complete source tree from the /usr/src/packages.....tar.bz2 > ~/src_patch/ffmpeg....
modify sources (I've included a printf Hello World to ffmpeg.c under usage instructions for testing)
create new .tar.bz2 image with identical name
replace original image with the new one
rpmbuild /usr/src... ffmpeg spec file
Here I got an error. It isn't easy possible to build with libspeex under OpenSuse 11.3 because of different versions and providers, so I have modified the spec file.
* Remove dependencies to libspeex
* Remove libspeex from ffmpeg's ./configure options
rpmbuild again, now it works.
rpm -i lib*
rpm -i ffmpeg

Now I can see the installed ffmpeg in my packet manager and if I call ffmpeg from shell there is my Hello World present.
After that I added Kdenlive without any trouble.