How to set project duration?

I have a project with some clips in it which only occupy the first 30 seconds of the project. The rest of the project (like 15 minutes) is empty, but it still results in thousands of black frames when I try to render the project. Thus I'm forced to select the first 30 seconds and set the "render just the selection" option. How can I set the duration of my project to 30 seconds?

The project duration is defined by the clips in timeline. Can you check if you don't have a very short clip at the end of the project (Press Ctrl+End in timeline to go to the last frame and zoom to make sure there is no small clip).

Otherwise, which Kdenlive version?

Oops, reread first post. Edited reply.

There is a workaround in case the timeline should turn out to be okay: when rendering, don't render the whole timeline but instead choose to render only a part of it. You will find this option in the render dialog.

But first make sure that your timeline is fine, as yellow suggested.

I will remember and do this one too.:)