I don't have Rotoscoping filter - 0.8.1

I've compiled myself KDENLive from sources, but I don't have rotoscoping, which I need. Also config wizard says that following modules are missing:

-QImage
-pixbuf
-title module

But I am 100% sure that I have first two installed (I am on openSuSE 11.3)

QImage:
libqimageblitz-devel
libqimageblitz4

Both 0.0.4

Pixbuf:

gdk-pixbuf
gdk-pixbuf-devel
Both 0.22.0

Please help me since I need this effect (for rest I don't care).

BTW.: Version from repo didn't work (non-snapping clips issue - you should fire openSuSE packager, same thing was with 0.7.7.1 and had to instal rpm from fedora)

Well Kdenlive is only the GUI. All video processing is done by MLT ( http://mltframework.org ) and the effects are provided by various packages.

The missing modules message means that MLT was compiled without Qt and Gtk support.

The rotoscoping filter is part of MLT, was added in version 0.7.4 if I remember correctly.

So you should remove all your MLT packages and compile latest MLT from git, see infos on our download from source for more infos (dependencies,etc).

If you are not comfortable with all that compiling stuff, you can also try the builder script that downloads and compiles everything, see our install from source page.

regards

Yeah, but I've compiled MLT myself.
Here's ./configure log:

Configuring framework:
Configuring modules:
Configuring modules/avformat:
Configuring modules/core:
Configuring modules/decklink:
Configuring modules/dv:
Configuring modules/feeds:
Configuring modules/frei0r:
Configuring modules/gtk2:
Libexif found, enabling auto rotate
Configuring modules/kdenlive:
Configuring modules/lumas:
Configuring modules/melt:
Configuring modules/oldfilm:
Configuring modules/plus:
Configuring modules/sdl:
Configuring modules/sox:
Configuring modules/swfdec:
- swfdec not found: disabling
Configuring modules/vmfx:
Configuring modules/vorbis:
Configuring modules/xml:
Configuring melt:
Configuring mlt++:
Configuring swig:
GPL Components are disabled

//edit: Tried to compile with --enable-gpl and rotoscoping didn't show up in kdenlive too.

MLT must be configured with --enable-gpl or you will miss important components. If I remember correctly, the rotoscoping filter requires some extra packages, like libqjson-dev. Try installing it and reconfigure...

I have libqjson and libqjson-devel, both in 0.7.1 version and as I said in edit --enablegpl didn't change nothing. I even recompiled & reinstalled kdenlive after recompiling and reinstaling mlt, because I thought it is needed, but it also didn't help.

Then what is the output of your MLT's configure? Mine looks like that:

Configuring framework:
Configuring modules:
Configuring modules/avformat:
Configuring modules/core:
Configuring modules/decklink:
Configuring modules/dgraft:
Configuring modules/dv:
- libdv not found: disabling
Configuring modules/effectv:
Configuring modules/feeds:
Configuring modules/frei0r:
Configuring modules/gtk2:
Libexif found, enabling auto rotate
Configuring modules/jackrack:
Configuring modules/kdenlive:
Configuring modules/kino:
- libquicktime not found: only enabling dv avi support
Configuring modules/linsys:
Configuring modules/lumas:
Configuring modules/melt:
Configuring modules/motion_est:
Configuring modules/normalize:
Configuring modules/oldfilm:
Configuring modules/plus:
Configuring modules/qimage:
Libexif found, enabling auto rotate
Qt version 4.x detected, will compile Qt4 qimage producer
Configuring modules/resample:
Configuring modules/rotoscoping: Configuring modules/sdl:
Configuring modules/sox:
Configuring modules/swfdec:
- swfdec not found: disabling
Configuring modules/videostab:
Configuring modules/vmfx:
Configuring modules/vorbis:
Configuring modules/xine:
Configuring modules/xml:
Configuring melt:
Configuring mlt++:
Configuring swig:
GPL License Used

Configuring framework:
Configuring modules:
Configuring modules/avformat:
Configuring modules/core:
Configuring modules/decklink:
Configuring modules/dgraft:
Configuring modules/dv:
Configuring modules/effectv:
Configuring modules/feeds:
Configuring modules/frei0r:
Configuring modules/gtk2:
Libexif found, enabling auto rotate
Configuring modules/jackrack:
Configuring modules/kdenlive:
Configuring modules/kino:
Configuring modules/linsys:
Configuring modules/lumas:
Configuring modules/melt:
Configuring modules/motion_est:
Configuring modules/normalize:
Configuring modules/oldfilm:
Configuring modules/plus:
Configuring modules/qimage:
Libexif found, enabling auto rotate
Qt version 4.x detected, will compile Qt4 qimage producer
Configuring modules/resample:
Configuring modules/rotoscoping:
Configuring modules/sdl:
Configuring modules/sox:
Configuring modules/swfdec:
- swfdec not found: disabling
Configuring modules/vmfx:
Configuring modules/vorbis:
Configuring modules/xine:
Configuring modules/xml:
Configuring melt:
Configuring mlt++:
Configuring swig:
GPL License Used

Now check if the rotoscoping filter is in MLT, in a terminal:

melt -query filters | grep roto

Where did you install MLT? by default it is installed in /usr/local.

You must make sure that you don't have an older MLT install in /usr.

to check:

ls -la /usr/local/lib/mlt
ls -la /usr/lib/mlt

To make sure where is melt:

which melt

Hm... Fixed itself, not sure how.