Importing a video file kdelive crash

This is the error that appears when I am importing a video file in kdenlive 0.7.8.
If I open a a previous project "*.kdenlive" kdennlive no crash.
Importing an audio file kdenlive no crash.

Now I verify that same error appears installing version 0.7.7

I supose that it has happened after update some dependency.

I am video user and I cannot solve it by myself

Thanks
+++++++

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb784b930 (LWP 3810))]

Thread 4 (Thread 0xb33e4b70 (LWP 3812)):
#0 0x01b3866a in g_main_context_check () from /lib/libglib-2.0.so.0
#1 0x01b390ce in ?? () from /lib/libglib-2.0.so.0
#2 0x01b394b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3 0x0504c82f in QEventDispatcherGlib::processEvents (this=0x8f330f8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#4 0x0501ca99 in QEventLoop::processEvents (this=0xb33e4290, flags=) at kernel/qeventloop.cpp:149
#5 0x0501cf1a in QEventLoop::exec (this=0xb33e4290, flags=...) at kernel/qeventloop.cpp:201
#6 0x04f19c5e in QThread::exec (this=0x8d61988) at thread/qthread.cpp:490
#7 0x04ffb9ab in QInotifyFileSystemWatcherEngine::run (this=0x8d61988) at io/qfilesystemwatcher_inotify.cpp:248
#8 0x04f1cf39 in QThreadPrivate::start (arg=0x8d61988) at thread/qthread_unix.cpp:266
#9 0x0024b96e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#10 0x01354a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xb2a33b70 (LWP 3825)):
#0 0x006aa422 in __kernel_vsyscall ()
#1 0x00250342 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x004962e9 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
#3 0x09058570 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xb2232b70 (LWP 3826)):
#0 0x006aa422 in __kernel_vsyscall ()
#1 0x00250015 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x01af449f in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb784b930 (LWP 3810)):
[KCrash Handler]
#7 0x047c5819 in sws_scale () from /usr/lib/i686/cmov/libswscale.so.0
#8 0x00000828 in ?? ()
#9 0x013b9af3 in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Forums:

Following previous post:

The error in comando line is:

@xxxxx:~$ kdenlive
File given: true
Color mode changed to 0
File given: true
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No existe el archivo o directorio
QFileSystemWatcher: failed to add paths: /home/carlos/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
[mp3 @ 0x8cf1fa0]max_analyze_duration reached
[mp3 @ 0x8cf1fa0]Estimating duration from bitrate, this may be inaccurate
[mp3 @ 0x8d2cb00]max_analyze_duration reached
[mp3 @ 0x8d2cb00]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8d59e10]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8d5bc10]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8d5fd20]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8da0990]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8dd9130]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8da3cf0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8dd8640]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8e36f90]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8e220b0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8e8bcb0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8e8dab0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8e91c80]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8ec4a90]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8ec6890]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8ecaac0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8f20a30]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8f22830]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8f26a10]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8f59780]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8fbe680]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8fbc6f0]Estimating duration from bitrate, this may be inaccurate
[mp3 @ 0x8c48c10]max_analyze_duration reached
[mp3 @ 0x8c48c10]Estimating duration from bitrate, this may be inaccurate
[mp3 @ 0x8c3a570]max_analyze_duration reached
[mp3 @ 0x8c3a570]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8bbcdc0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8bbea30]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8cf0400]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8ce17d0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8ce6760]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x90f7630]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x8ce2c70]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x90d2200]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x9180ed0]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 9 times
[dv @ 0x918df30]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 21 times
[dv @ 0x9182b40]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 21 times
[dv @ 0x91884e0]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 88 times
[dv @ 0x91ef180]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 33 times
[dv @ 0x92009c0]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 34 times
[dv @ 0x9212740]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 177 times
[dv @ 0x92b6f90]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 18 times
[dv @ 0x92c8d80]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 22 times
[dv @ 0x92fc430]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 95 times
[dv @ 0x8ce7840]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x90b3880]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x90c9200]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x93679a0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x936f9b0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x93b4750]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x93da7a0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x93ec8c0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x93efc20]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x93d9370]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x9389160]Estimating duration from bitrate, this may be inaccurate
[dv @ 0x9384dc0]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 21 times
[dv @ 0x94ecd60]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 19 times
[dv @ 0x950e9d0]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 21 times
[dv @ 0x95120d0]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 36 times
swScaler: pal8 is not supported as output pixel format
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/carlos/.kde/socket-maquina/kdeinit4__0

[1]+ Detenido kdenlive

What distribution do you use?
Which other (video related) packages did you update besides Kdenlive?

I am using Kubuntu 10.04.

I don't know if the error begins with this:

++++:~$ apt-show-versions -a ffmpeg
ffmpeg 4:0.6-2ubuntu2~ppa0 install ok installed
ffmpeg 4:0.5+svn20090706-2ubuntu2 karmic archive.ubuntu.com
ffmpeg 4:0.5+svn20090706-2ubuntu2.2 karmic-security archive.ubuntu.com
ffmpeg 4:0.5+svn20090706-2ubuntu2.2 karmic-updates archive.ubuntu.com
ffmpeg 4:0.5.1-1ubuntu1 lucid archive.ubuntu.com
ffmpeg 4:0.6-2u3~ppa1 lucid ppa.launchpad.net
ffmpeg 4:0.6-2ubuntu1.2 lucid ppa.launchpad.net
ffmpeg 4:0.6-2ubuntu2~ppa0 lucid ppa.launchpad.net
No stable version
ffmpeg/lucid uptodate 4:0.6-2ubuntu2~ppa0

I had problems with mplayer because it don't works after update ffmpeg, an reading other post I had to update mplayer and mencoder.

Now I have got begin a new project but just in the moment of import the .dv files Kdenlive crash:

xxxxxx:~$ kdenlive
File given: true
Color mode changed to 0
File given: true
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No existe el archivo o directorio
QFileSystemWatcher: failed to add paths: /home/carlos/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::end: Painter not active, aborted

kdenlive(8088)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
kdenlive(8088)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/home/carlos/.local/share/mime/magic"
[dv @ 0xabc76c0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8fc950]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8f4010]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xabc76c0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8fc950]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8f4010]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 1 times
swScaler: pal8 is not supported as output pixel format
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/carlos/.kde/socket-maquina/kdeinit4__0

[1]+ Detenido kdenlive

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

I think the key of the problem is here:

Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 1 times
swScaler: pal8 is not supported as output pixel format

but i don't know to evaluate it

I am using Kubuntu 10.04.

I don't know if the error begins with this:

++++:~$ apt-show-versions -a ffmpeg
ffmpeg 4:0.6-2ubuntu2~ppa0 install ok installed
ffmpeg 4:0.5+svn20090706-2ubuntu2 karmic archive.ubuntu.com
ffmpeg 4:0.5+svn20090706-2ubuntu2.2 karmic-security archive.ubuntu.com
ffmpeg 4:0.5+svn20090706-2ubuntu2.2 karmic-updates archive.ubuntu.com
ffmpeg 4:0.5.1-1ubuntu1 lucid archive.ubuntu.com
ffmpeg 4:0.6-2u3~ppa1 lucid ppa.launchpad.net
ffmpeg 4:0.6-2ubuntu1.2 lucid ppa.launchpad.net
ffmpeg 4:0.6-2ubuntu2~ppa0 lucid ppa.launchpad.net
No stable version
ffmpeg/lucid uptodate 4:0.6-2ubuntu2~ppa0

I had problems with mplayer because it don't works after update ffmpeg, an reading other post I had to update mplayer and mencoder.

Now I have got begin a new project but just in the moment of import the .dv files Kdenlive crash:

xxxxxx:~$ kdenlive
File given: true
Color mode changed to 0
File given: true
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No existe el archivo o directorio
QFileSystemWatcher: failed to add paths: /home/carlos/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::end: Painter not active, aborted

kdenlive(8088)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/usr/share/mime/magic"
kdenlive(8088)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing "/home/carlos/.local/share/mime/magic"
[dv @ 0xabc76c0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8fc950]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8f4010]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xabc76c0]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8fc950]Estimating duration from bitrate, this may be inaccurate
[dv @ 0xa8f4010]Estimating duration from bitrate, this may be inaccurate
Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 1 times
swScaler: pal8 is not supported as output pixel format
QSocketNotifier: Invalid socket 13 and type 'Read', disabling...
KCrash: Application 'kdenlive' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/carlos/.kde/socket-maquina/kdeinit4__0

[1]+ Detenido kdenlive

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

I think the key of the problem is here:

Diverting av_*_packet function calls to libavcodec. Recompile to improve performance
Last message repeated 1 times
swScaler: pal8 is not supported as output pixel format

but i don't know to evaluate it

hi,

there is an enormous problem in your ffmpeg install! Using ppas can be dangerous. Be very careful, you've done some updates and you broke totally the "multimedia chain" broking FFmpeg. (0.5+svn; 0.5.1, 0.6.2 ...)

Your are probably using my kdenlive packages ? yes/no?

In both cases if you are running Lucid (10.04) the only FFmpeg that is expected to be seen, and the only one that will not break everything is ffmpeg 4:0.5.1-1ubuntu1

You have to clean that. You have to delete all the ffmpeg packages, and restore the original ones, and do not use any ppa providing ffmpeg 0.6 for Lucid or other ffmpeg than 4:0.5.1-1ubuntu1. The only way to get it work with ffmpeg 0.6 would be recompiling every application relying on ffmpeg (insane work).

If you don't know how to clean your system : use ppa-purge to revert packages offending packages and use your package manager and check the package version of
ffmpeg, it has to match that : 4:0.5.1-1ubuntu1 ; if it doesn't match
delete all ffmpeg packages :

ffmpeg, libavutil, libavdevice, libavcodec, libavformat, libavfilter,
libswscale, libpostproc or their -extra versions

Then check versions of the x264 and libx264-85, they have to match
that : 2:0.85.1448+git1a6d32-4

If other libx264-XX packages are installed deleted them (where XX
different from 85)

All that done your system will be cleaner.

Is this all still true ^^^?

I'm assuming so as I'm using kdenlive 0.7.8 on 10.04 on my work computer and things were ok until I just checked (there must've been an update).

FFmpeg version 0.6-4:0.6-2ubuntu6.2, Copyright (c) 2000-2010 the FFmpeg developers
built on Nov 5 2010 10:51:45 with gcc 4.4.3

I know that kdenlive .8 on 10.04 on my home computer definitely has issues as well. (Crashes upon opening any project w/video and/or importing a vid clip.)

Is there any way to purge the offending ffmpeg and then checkout and/or clone the correct one? (4:0.5.1?)

Thanks.

For anyone using kxstudio:

Make sure you're using the following PPAs:

http://ppa.launchpad.net/falk-t-j/lucid/ubuntu
http://ppa.launchpad.net/kxstudio-team/ppa/ubuntu

.....and do a apt-get update, and a apt-get dist-upgrade

Falktx has just updated ffmpeg, mlt, mplayer, dvgrab and kdenlive

I just did it. Seems to work.

NOTE: I'm not totally sure where kxstudio stands in regards to Natty, etc. I'm still on Lucid.