Individual timeline for clips / export layer

Dear all,

I am thinking of all situations when you need to correct a clip:
* audio synchronisation,
* audio level,
* color correction,
* brightness, contrast, etc ...
* effects,
* add subtitles (very interesting when editing and trying to find a story, not only for translation),

The number is large. To solve these issues, it may be interesting to have an individual timeline for each clip. Because MLT is able to play Whestley files into Whestley files, this seems to be technically possible.

As for the interface, I propose:
* User should be able to hide/show individual timeline.
* Right-click on the clip in project would show the option "show individual timeline" and "hide individual timeline".
* A global option (toggle) would hide/show all individual timelines (when not empty).
* When a project has 100 source files and as many individual timelines (I am thinking of colour correction in a professionnal project), it may be interesting to stack timelines in a hirarchy. If a file is named "foo", all timelines should be stacked (hidden) under "Individual timeline for "foo". A click on the timeline would unstack it and show individual timelines for the media. The presentation in global timeline should be hierarchal.

Also, it may be interesting to add export profiles using timeline. In these precise situations:
* Your project needs a Mpeg4 640x480 quick export for fast viewing.
* But it also needs rendering to HDTV and DVD (for selling).
* When you sell to a TV, you may add a layer with the logo of the company. This can be done in a layer where you add logo AND export options.
* Ultimately, you only need to "render" to create one or several export options, attached to your project.

Bye,
Jean-Michel

This would be very nice. Especially for it also eliminates the problem of transitions covering effects. (Example: Clip A on track 0 is above clip B on track 1, with transition Composite. If you add a fade in effect to B now, you cannot move the start/end point with the mouse because it is below the Composite effect. You need to remove the composite effect or enter start/end manually.)