Installed 9.04 package on Mint 7

Well it seemed to go OK on Linux Mint 7 (Ubuntu variant) with the package designed for 9.04 (this running off a USB Key).

It was different trying to find "software sources", but I found it eventually in Package Manager.. Settings.. Repositories - and I added a new one Ok :
http://ppa.launchpad.net/sunab/ppa/ubuntu/
jaunty
main

The install command went OK except for ending :
Hit http://packages.linuxmint.com gloria/upstream Packages
Hit http://packages.linuxmint.com gloria/import Packages
Fetched 9691B in 0s (13.7kB/s)
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

But never mind, I pressed on, ticked the boxes and let it suck down the installation. And there it is, in the menu.

It runs.

I loaded up an AVCHD Lite 720p clip and it played in the clip monitor, with only a few stutters and sound breakups. I put it on the timeline and it won't play.
Then I tried adding an AVI file (containing mp4 720p), the whole app went grey and took a while to come back, without the clip loaded. Aah, no... the app changed to the effect stack for some reason. The clip is there in the project window after all, but clicking on it makes things go grey again. But then it finally does play in the preview. Into the timeline it goes... then won't play. It's having a think to itself.

Oh dear. It's seized up solid. I'll have to kill it.

Later... I then tried a 640x480 MJPEG MOV clip, and it works smoothly and reliably. Quite impressively, in fact. Nice!