Jaunty, crash after installation wizard

hi,

 

i have a mixed ubuntu system, quite minimal (not (much) kde, gnome etc - fluxbox), which i fully upgraded from hardy to intrepid, added jaunty repositories and installed the latest kdenlive (0.7.2.1-0ubuntu2) with all dependencies + medibuntu stuff.

when i run kdenlive, at the end of installation wizard it crashes without an exception.

-----------------

A Fatal Error Occurred
The application Kdenlive (kdenlive) crashed and caused the signal 11
(SIGSEGV). Please help us improve the software you use by filing a
report at http://bugs.kde.org. Useful details include how to reproduce
the error, documents that were loaded, etc.

Please attach the following information to your bug report:

Application: Kdenlive (kdenlive), signal SIGSEGV
[Current thread is 0 (LWP 4811)]

Thread 2 (Thread 0xb2d4ab90 (LWP 4812)):
#0  0xb7f0c430 in __kernel_vsyscall ()
#1  0xb65e67b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0xb72aa380 in ?? () from /usr/lib/libQtCore.so.4
#3  0xb71d896e in ?? () from /usr/lib/libQtCore.so.4
#4  0xb64f24ff in start_thread ()
#from /lib/tls/i686/cmov/libpthread.so.0 5  0xb65ee49e in clone ()
#from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb5ccb6d0 (LWP 4811)):
[KCrash Handler]
#5  0xb691e0c2 in QWidget::insertAction () from /usr/lib/libQtGui.so.4
#6  0xb691e32c in QWidget::addAction () from /usr/lib/libQtGui.so.4
#7  0x080de444 in MainWindow::addToMenu ()
#8  0x080ded1c in MainWindow::populateMenus ()
#9  0x080df33e in MainWindow::loadPlugins ()
#10 0x080e21ef in MainWindow::MainWindow ()
#11 0x080c4e8d in main ()
 

-----------------------------

and in the terminal, from which i run kdenlive:

 

$ kdenlive
kdenlive(5033) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
kdenlive(5033) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(5033) Wizard::checkMltComponents: // FOUND MLT version: 36
kdenlive(5033) Wizard::installExtraMimes: EXTS: ("*.vob", "*.mod", "*.mpe", "*.mpg", "*.mpeg", "*.mp2", "*.mts", "*.m2t", "*.ts")
kdenlive(5033) Wizard::installExtraMimes: INSTALLING NEW MIME TO: "/home/random/.local/share/mime/packages/video-mpeg.xml"
kdenlive(5033) Wizard::installExtraMimes: EXTS: ("*.dv")
kdenlive(5033) Wizard::installExtraMimes: INSTALLING NEW MIME TO: "/home/random/.local/share/mime/packages/video-dv.xml"
kdenlive(5033) Render::Render: ////////// USING PROFILE: hdv_1080_50i
kdenlive(5033) Monitor::Monitor: /////// BUILDING MONITOR, ID: 16780595
kdenlive(5033) Render::Render: ////////// USING PROFILE: hdv_1080_50i
kdenlive(5033) Monitor::Monitor: /////// BUILDING MONITOR, ID: 16780783
QPainter::fontMetrics: Painter not active
kdenlive(5033) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 16780828
QStatusBar::insertPermanentWidget: Index out of range (5), appending widget
QStatusBar::insertPermanentWidget: Index out of range (7), appending widget
kdenlive(5033): Shortcut for KAction "monitor_play_zone" "Play Zone" set with QShortcut::setShortcut()! See KAction documentation.
kdenlive(5033): Shortcut for KAction "monitor_loop_zone" "Loop Zone" set with QShortcut::setShortcut()! See KAction documentation.
kdenlive(5033) MainWindow::loadPlugins: // PARSING FIOLER: "/usr/lib/kde4/"
kdenlive(5033) MainWindow::loadPlugins: // FOUND PLUGIN: "libkdenlive_sampleplugin.so" = "/usr/lib/kde4/libkdenlive_sampleplugin.so"
kdenlive(5033) MainWindow::addToMenu: // ADD to MENU ("Countdown", "Noise")
KCrash: Application 'kdenlive' crashing...
sock_file=/home/random/.kde/socket-fenchurch/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.

 

anyone has ideas, which packages/libs are causing me trouble here?

nova.

(i can post some dpkg -l stuff too, if it's needed)

what's the version of the qt libs?
could you try compiling kdenlive (mlt packages should be ok) with the builder wizard?

libqt version is 4.5.0-0ubuntu3

and

kdelibs are 4:4.2.1a-0ubuntu4

and

libmlt1 and libmlt++1 are now  at 0.3.6-0baudm1 (from https://launchpad.net/~baudm/)

the crash reports the same.

could you try the builder wizard? kdenlive 0.7.2.1 has some issues with qt 4.5 i think...

ok, using the builder wizard solved this problem.

 

thanks.

then it should be qt 4.5. there's a 0.7.3 coming out in few days, that will probably work. but you can always use the builder wizard the get the newest features!