Kdenlive 0.6

Hi,

I have seen people talking about Kdenlive 0.6. I am wondering whether this is available in SVN.

I would like to know.

Thanx.

No, I haven't even released Kdenlive 0.5 (though I hope to be able to do it today). What you probably saw was a reference to a Kdenlive project file with the 0.6 version number. Kdenlive's project file format has changed several times and it is now at 0.6, but that's just the file format, not Kdenlive itself, but I must admit this is rather confusing.

But on the good side, I have several new features / improvements ready to commit, so as soon as Kdenlive 0.5 is out, the svn development version will get a nice set of new features (printing, creation of export scripts, management of playlist clips, improved titler, ...).

regards

woot!!

just what i was hoping to hear, jb's new features ready to commit. I've been using 0.5svn for sometime so the new features for 0.6 will be great.

jb well done for releasing 0.5. many thanks

it's nuts to ask this but how soon for the commit of the new stuff?

New features have been committed, happy testing!

regards

jb

yippee!

0.6svn successfully built on Fiesty.

many thanks again jb.

Also got it compiling ok. Nice work ..

But as last version I'm not able to save my movie project.

When I sudo kdenlive It did save but I got a chrash screen also. How can I be able to save my project as normal user.

Regards Rohnny

diffid wrote:
jb

yippee!

0.6svn successfully built on Fiesty.

many thanks again jb.

Hi! I have Feisty to, so please show me how to make the installation! :)
Thanks a lot!

Hi Amonsul

Quote:
Hi! I have Feisty to, so please show me how to make the installation! :)
Thanks a lot!

I do it the easy way using espinosa_cz's great builder script from here:

http://www.kdenlive.org/bbforum/viewtopic.php?f=8&t=100&sid=5a959fec3072fd55adb76ac8e6358556#p300&sid=0d46ee989b4b291ae9ffd4bbf030e4cc

Sorry, how to get work the script?

When i run the script i get the following error:

amonsul@amonsul-desktop:~/Desktop$ sudo ./kdenlive_builder.sh clean
./kdenlive_builder.sh: line 57: cd: ffmpeg: No such file or directory
make: *** Keine Regel, um »clean« zu erstellen. Schluss.
./kdenlive_builder.sh: line 59: cd: ../mlt: No such file or directory
make: *** Keine Regel, um »clean« zu erstellen. Schluss.
./kdenlive_builder.sh: line 61: cd: ../mlt++: No such file or directory
make: *** Keine Regel, um »clean« zu erstellen. Schluss.
./kdenlive_builder.sh: line 63: cd: ../kdenlive: No such file or directory
make: *** Keine Regel, um »clean« zu erstellen. Schluss.

Bye

hi,

the "clean" parameter works only after you've successfully build the sources!
You don't need it at first time.

But i get this error :(

amonsul@amonsul-desktop:~/Desktop$ sudo ./kdenlive_builder.sh build
./kdenlive_builder.sh: line 72: cd: ffmpeg: No such file or directory

your checkout seems to be not complete ...
what are the things you've done so far?
was "./kdenlive_builder.sh getsources" successfully?

No!

amonsul@amonsul-desktop:~/Desktop$ sudo ./kdenlive_builder.sh getsources
Password:
./kdenlive_builder.sh: line 37: svn: command not found
amonsul@amonsul-desktop:~/Desktop$

amonsul wrote:
No!

amonsul@amonsul-desktop:~/Desktop$ sudo ./kdenlive_builder.sh getsources
Password:
./kdenlive_builder.sh: line 37: svn: command not found
amonsul@amonsul-desktop:~/Desktop$

hhmmmm .... what could this mean???? .... hhmmmm ....
ok, seriously!
You have to install svn package to be able to checkout via svn ;)

btw - normally you don't need root privileges to launch the script!!

Im so stupid! sorry :)

ok getsources works but then i got this error:

amonsul@amonsul-desktop:~/Desktop$ sudo ./kdenlive_builder.sh clean
Makefile:5: config.mak: No such file or directory
/version.sh 
make: /version.sh: Kommando nicht gefunden
make: *** Keine Regel, um »config.mak« zu erstellen.  Schluss.
Makefile:27: config.mak: No such file or directory
make: *** Keine Regel, um »config.mak« zu erstellen.  Schluss.
Makefile:1: config.mak: No such file or directory
make: *** Keine Regel, um »config.mak« zu erstellen.  Schluss.
make: *** Keine Regel, um »clean« zu erstellen.  Schluss.
amonsul@amonsul-desktop:~/Desktop$ sudo ./kdenlive_builder.sh build
ERROR: liba52 not found
If you think configure made a mistake, make sure you are using the latest
version from SVN.  If the latest version fails, report the problem to the
ffmpeg-devel@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.
amonsul@amonsul-desktop:~/Desktop$ 

as I said - NO "CLEAN" AT THIS POINT!!!!
just "buildsources"

OK, aber nun wenn ich mit "... build" alles ausführe passiert irgendwann das:

make[1]: Verlasse Verzeichnis '/home/amonsul/Desktop/mlt++/test'
Bootstrap is now trying to create a ./configure script suitable for Kdenlive
WARNING: running bootstrap is only usefull when checking out Kdenlive from CVS.

./admin/cvs.sh: 651: --version: not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer
make: *** [cvs] Fehler 1
amonsul@amonsul-desktop:~/Desktop$ 

Ich habe autoconf schon installiert...

what version do you have installed?
try "autoconf --version"

amonsul@amonsul-desktop:~$ autoconf --version
autoconf (GNU Autoconf) 2.61
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software.  You may redistribute copies of it under the terms of
the GNU General Public License .
There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille.
amonsul@amonsul-desktop:~$ 

hi,

I would recommend you to do a "unsermake clean" in the kdenlive directory
or
checkout the sources again, but in a new directory - maybe the initial "./kdenlive_builder.sh clean" did some strange things? Just a guess...

If this did not help, than post your error in the kdenlivebuilder topic:

viewtopic.php?f=8&t=100

I've reinstalled all. No chance, I got the same error.
I have no idea what to do.

Bye

Try
./bootstrap
./configure
make
make install

It worked for me. Did not work without the bootstrap.

Regards Rohnny

It gives me the same error message when i try ./bootstrap!

:(

Hi

I believe the AUTOCONF not found error is because you do not have automake installed.

Hope this helps.

Right!

But now i get this error:

make[2]: Betrete Verzeichnis '/home/amonsul/kdenlive_svn/mlt/src/modules/qimage'
cc -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../   -c -o factory.o factory.c
cc -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../   -c -o producer_qimage.o producer_qimage.c
g++ -Wall -fPIC -DPIC   -O4 -pipe -fomit-frame-pointer -ffast-math -DUSE_MMX -g -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -pthread -I../../ -I/usr/include/qt3 -I/usr/include/kde -Wno-deprecated   -c -o qimage_wrapper.o qimage_wrapper.cpp
qimage_wrapper.cpp:31:23: error: kinstance.h: No such file or directory
qimage_wrapper.cpp:32:22: error: kimageio.h: No such file or directory
qimage_wrapper.cpp:42: Fehler: expected initializer before »*« token
qimage_wrapper.cpp: In function »void qimage_delete(void*)«:
qimage_wrapper.cpp:50: Fehler: »instance« wurde in diesem Gültigkeitsbereich nicht definiert
qimage_wrapper.cpp:50: Fehler: Argument vom Typ »« wurde an »delete« übergeben, Zeiger erwartet
qimage_wrapper.cpp:51: Fehler: »instance« wurde in diesem Gültigkeitsbereich nicht definiert
qimage_wrapper.cpp: In function »void init_qimage()«:
qimage_wrapper.cpp:80: Fehler: »instance« wurde in diesem Gültigkeitsbereich nicht definiert
qimage_wrapper.cpp:81: Fehler: expected type-specifier before »KInstance«
qimage_wrapper.cpp:81: Fehler: expected `;' before »KInstance«
qimage_wrapper.cpp:82: Fehler: »KImageIO« wurde nicht deklariert
make[2]: *** [qimage_wrapper.o] Fehler 1
make[2]: Verlasse Verzeichnis '/home/amonsul/kdenlive_svn/mlt/src/modules/qimage'
make[1]: *** [all] Fehler 1
make[1]: Verlasse Verzeichnis '/home/amonsul/kdenlive_svn/mlt/src/modules'
make: *** [all] Fehler 1
amonsul@amonsul-desktop:~/kdenlive_svn$ 

Hi,

really all dependencies solved, especially the qt and kde stuff?

http://en.wikibooks.org/wiki/Kdenlive/G ... _libraries

I miss only the "SDL" package. I cannot find this package in synaptic (ubuntu). Is this a problem?

You should be able to find the SDL package with a name like libsdl1.2...
On my ubuntu feisty, it is called libsdl1.2debian-all

Remember to also install the development package libsdl1.2-dev

regards