Kdenlive 0.7.5 for ubuntu Jaunty (ppa)

hi everyone,

The latest stable packages are available on my ppa : deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main

- Kdenlive 0.7.5
- MLT 0.4.4

i will test this package , thank you for your efforts .

EDIT:
it works fine here. ty

Thanks. Could you please upgrade and maintain this page:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

If your packages work well, we may ask you to become our official package maintainer for Ubuntu.

Thanks a lot for this, works fine for me too.

I am in the process of uploading kdenlive and mlt to my ppa, for Karmic:

https://edge.launchpad.net/~thefirstm/+archive/karmic-testing

to jmpoure,

I can maintain this page http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...
but I think I don't have sufficient rights as a simple user to do that, can you please enable it ?

ps: I can build 0.7.5 packages for other versions of Ubuntu, just tell me which ones... I will be honored to help the kdenlive team.

EDIT : I am not aware if it is interesting to build 0.7.5 under Hardy (8.04), the latest kdelibs are 4.1.2 (via Kubuntu-members ppa) and ffmpeg cvs20070307 (more recent versions will brake compatibility)

To compare with intrepid (8.10) we have kdelibs 4.2.2 (with backports) and ffmpeg svn20081115 (with darwin bautista ppa).

@sunab: the upgrade worked perfect for me. Thanks a lot !!!

Hi sunab!

I updated your permissions, so you should now be able to edit the page. It's great if you can keep the page up do date.

regards

Well for me,after adding ppa repo and key, kpackagekit propose to upgrade to mlt 0.4.4 but blocks kdenlive to 7.3
(Kubuntu 9.04)

Hmmm after removing 7.3, it allows me to install 7.5 but wants to remove vlc ....
Trying in the konsole using apt-get seems to let vlc installed, ok I go this way ...
After this Kapckagekit found another update to inigo ...

Well if didn't go very smoothly, at last it seems to work ...

@PhilippeP

This seem to be a Kapckagekit problem resolving dependencies.

Hi sunab

I'm getting very frequent crashes, mainly when working with effects and transitions. Clean build of 9.04 updated to KDE 4.2.4 from ppa. Only other third-party repository is yours, and only other software installs are adept and nvidia 180 driver. Desktop effects are disabled. I had the same crash with a previous 9.04 install that was an upgrade of 8.10. I was hoping that the clean install would fix.

I'd really appreciate it if you could have a quick scan of the attached crash report and point me in the right direction. Kdenlive is a great piece of software and it's awesome that people like you take the time to package it for the community.

thank you
Steve.

@stevecnz

I have some troubles when applying effects, at this moment I have no explanation.

I will work on it after building a patched version of ffmpeg to resolve an issue that affects AVCHD users in Jaunty : http://www.kdenlive.org/forum/no-audio-importing-sanyo-fh1-files-vlc-pla...

Thanks for the interest on my packages.

Hi
I success to install kdenlive 0.7.5 and mlt 0.4.4, but I have a problem with the freiOr-plugin package :

E: /var/cache/apt/archives/frei0r-plugins_1.1.22git20090409+repack-0ubuntu1_i386.deb: tentative de remplacement de « /usr/lib/frei0r-1/3dflippo.so », qui appartient aussi au paquet frei0r

FreiOr-plugins is usable with this last version of kdenlive ? Kdenlive works well..so it's a bit strange

@magisterpecoris,

I have tested upgrades of kdenlive in two situations in a virtual machine (Ubuntu 9.04 i386) :
- kdenlive official ubuntu package (0.7.3)+frei0r-plugins >>> my 0.7.5 package : no errors
- Kdenlive unofficial package from dominik stadler (0.7.4) >>> my 0.7.5 package : no errors

Could you tell me what was your kdenlive install before updating with my repository. Then I will try to reproduce the problem, and fix my package if needed.

Thanks for your interest.

Sure
I've updating from kdenlive 0.7.4 . Before that , it was kdenlive 0.7.3, 0.7.2 ... I think there's a lot of package installed on my distro (ubuntu jaunty i386 update from an hardy).
I remembered too i've installed some packages to have a lot of renderer profile in kdenlive.

Now , I try to remove completely kdenlive and associate, but when i reinstall , there's also this problem with freiOr.. and kdenlive works very well. FreiOr is now a brocken package in my package management

Maybe also i try to install kdenlive 0.7.5 first time with your package and older activated.. (http://ppa.launchpad.net/dominik-stadler/ppa/ubuntu) . I've testing reinstall without it, but the problem still.

here the message when i try to fix my broken package :

--------------------------------------------------------------------------------------------------
(Lecture de la base de données... 184905 fichiers et répertoires déjà installés.)
Dépaquetage de frei0r-plugins (à partir de .../frei0r-plugins_1.1.22git20090409+repack-0ubuntu1_i386.deb) ...
dpkg : erreur de traitement de /var/cache/apt/archives/frei0r-plugins_1.1.22git20090409+repack-0ubuntu1_i386.deb (--unpack) :
tentative de remplacement de « /usr/lib/frei0r-1/3dflippo.so », qui appartient aussi au paquet frei0r
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/frei0r-plugins_1.1.22git20090409+repack-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
--------------------------------------------------------------------------------------------------

Thanks for your help

For some reason there are old frei0r files remaining on your system.
I could suggest you the following :

1. disable all ppas related to kdenlive or frei0r-plugins
2. in your package manager search for any package related to old versions. Warning : some of them had different names in their history : so delete all the following if they are installed : kdenlive, kdenlive-data, libmlt1, libmlt-data, libmlt++1, libmlt++2, inigo, melt, frei0r, frei0r-plugins.
3. When you are sure to have cleaned everything, browse your file system to /usr/lib and verify if there is a frei0r-1 folder. If there is, you have to delete it at all costs.

This solution resolve my problem !

Thanks ! Amazing became Kdenlive !

Hi.

When I try to install kdenlive on jaunty i get the following errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive: Depends: libmlt++2 (>= 0.4.4) but it is not going to be installed
Depends: libmlt1 (>= 0.4.4) but it is not going to be installed
Depends: melt (>= 0.4.4) but it is not going to be installed
Depends: libavdevice-unstripped-52 but it is not going to be installed
Depends: libavfilter-unstripped-0 but it is not going to be installed
Depends: libswscale-unstripped-0 but it is not going to be installed
Depends: libpostproc-unstripped-51 but it is not going to be installed
E: Broken packages

Anyone know what's going on with this?

Cheers.

Hi

I also keep getting frequent crashes. I am unable to work with kdenlive for more than 5 minutes before the application crashes. I have never used kdenlive before, but it seems really nice. I would love to be able to give it a shot.

When the application crashes I get The KDE Crash Handler telling me that the it crashed and caused the signal 11 (SIGSEGV), and a bunch of "(no debugging symbols found)". Then another Crash Handler dialog pops up telling that it was unable to create a valid backtrace, probably because my packages are built in a way which prevents creation of proper backtraces.

Btw, I am using Gnome, but that shouldn't be a problem, should it?

Using Kdenlive under Gnome is not a problem: this is my case and it works fine.

@sunab : I think we should modify the installation page to present it in a way that people learn 1) How to upgrade to Ubuntu latest release 2) Verify that older versions of MLT are not installed 3) Install FFmpeg and MLT / Kdenlive latest packages. You may have a look at my Debian page.

I'm running Jaunty in a VirtualBox, I was a bit confused at first with the 'third party' selection in apps...add/remove and hastily selected kdenlive from the list when I spotted it... and then realised I shouldn't have - so I cancelled it. I then read the instructions more closely!
I then found the 'third party' info in the other place (admin.. software sources), I then added the info as per instructions but it's not working well. I'm getting this with the sudo command:

Err http://ppa.launchpad.net jaunty/main; Packages
404 Not Found
Hit http://gb.archive.ubuntu.com jaunty-updates/multiverse Packages
Hit http://gb.archive.ubuntu.com jaunty-updates/multiverse Sources
Fetched 308B in 0s (648B/s)
W: GPG error: http://ppa.launchpad.net jaunty Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B5115B98AA836CA8
W: Failed to fetch http://ppa.launchpad.net/sunab/ppa/ubuntu/dists/jaunty/main;/binary-i386... 404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.

Help!

Your instructions say :
2. click add and paste this line in:
deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main;

but it seems to work a lot better without the ; at the end!!!

The sudo command has now done a LOT more, but I'm still seeing the public key error.

sorry for the ";" thing, some other contributor modified the page. I will correct it now.

I googled for B5115B98AA836CA8 and found the advice to run :
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B5115B98AA836CA8

- which has stopped it moaning about that key.

However, I am still not seeing anything available from third parties apart from these 2 :
Adobe Flash Plugin 10
Adobe Reader 9

Should something else appear in the add/remove third parties list if there's an entry in the software sources third parties list?

EDIT : aha, I ran this again
sudo apt-get update && sudo apt-get install kdenlive

- and I'm now running kdenlive.... at long last!! Yay!

Welcome on board MJ Peg :)

Thanks... LOL... I can't believe how much I've had to research to get going!

VirtualBox was simple download and install... fair enough.
Installing Ubuntu on VirtualBox was simple enough - for these steps I was following the handy screenshots guide at :
http://www.psychocats.net/ubuntu/virtualbox

From there on it got more tricky with a rogue ; that had crept in on the instructions at http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...
- but that finally worked out OK after a lot of headscratching (see my posts earlier in this thread).

I then had trouble accessing my host Windows C: drive from within the guest Ubuntu, but after half a day scrabbling about I have found that you need to do the following :
1) On the VirtualBox menu bar select Devices..Install Guest Additions - follow the instructions and reboot when done.
2) Setup a share to act as a bridge between the host machine and the virtual one :
go to the VirtualBox Devices..Shared Folders.. machine folders.. and set one up pointing at c:\ and call it cdrive
3) Start the Ubuntu virtual machine, and in there you will find a CD image on the desktop called something starting with "VBOXADDITIONS.." - double click it and then also the autorun file, and let it install.
4) Finally, run a terminal and mount the "cdrive" share set up earlier as "/mnt/shared" - with these 2 commands:
sudo mkdir /mnt/shared
sudo mount -t vboxsf cdrive /mnt/shared

(That last command won't work unless you've got the name right and you've installed the additions in step 3) because it won't know what vboxsf is otherwise)

A happy side effect of installing the Additions pack, is that you can get the full 1024x768 screen rez (or more) instead of being limited to the tiny 800x600 default earlier.

I can now browse my full Windows C: drive, and .MOV files from my MJPEG camera play fine. The .MOV file from a h.264 based Canon SX1 wouldn't play, but it told me it needed to install a new codec, and once again it was childsplay to let it do it for me, accepting the defaults and entering that all important password.

So here I am with a fully up to date patched version of Ubuntu running full screen on my Vista PC, with Kdenlive working and I can simply drag MOV files in and they work - a big improvement over Windows Movie Maker, LOL
The only problem is that it's a bit slow, being a virtual machine emulation.... but my home PC has two drives so I think I may repartition the D: drive, install Ubuntu on it, and choose between XP or Ununtu when booting by selecting either drive 1 or 2.

I tell you what, I feel like I've come a long way in a couple of days and broadened my horizons considerably! It's been quite a journey of discovery. For instance, I was a bit irritated that the numeric keypad didn't work as I'm used to for selecting text in conjunction with the shift key - but with a quick bit of googling I found :
"go to System | Keyboard | Layouts | Layout Options, and under "Miscellaneous compatibility options" select "Default numeric keypad keys" and "Shift with numeric keypad keys works as in MS Windows" (http://www.newsgab.com/forum/tech-news/74087-inside-ubuntu-9-04-a.html). It's all there if you look!

So I'm very impressed with Linux, Ubuntu, and I will recommend this to anyone looking for a free way to edit video.

.. and then I discovered Wubi ( http://wubi-installer.org/ ) and I wish I'd known about it before! It says it takes only a slight performance hit to run Ubuntu this way, so is it quick enough for Kdenlive I wonder?

Has no-one really got any idea about my broken packages broken above??

hi rofko,

sorry for being so late, I didn't see your post before.

Try to manually delete all the broken packages. Then reload with your package manager or type sudo apt-get update. And then install kdenlive.

ps: your first post was on 07-11, this day I have uploaded many updates on this ppa. You probably have tried to install kdenlive but all the dependencies wasn't all uploaded yet. This maybe the explanation for your broken install.

Hi everybody!

I have installed kdenlive on Ubuntu 9.04 as it is discribed on the help pages. After that, the problem was that kdenlive goes frozen every now and then, in the middle of showing a clip, for example. So I have deinstalled kdenlive as sunab has discribed it here in the threat, rebooted the computer and installed by synaptic kdenlive again. The installation was ok, but the result the same => kdenlive goes frozen.

May be you would like to know what kind of computer my one is: It has Intel Core 2 Quad Q8300 - 2.50 GHz and a Memory of 4.0 MB and, as it said before, the os is Ubuntu 9.04.

Has someone a idea was is wrong with the installation?

Rorohiko

@sunab and MJ peg

Hello i'm a new contributor of this website.

I will update this page http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/..." with this information :

After adding the repository, you also need to add the key for the repository to your system's list of trusted keys, type the following command line in the terminal :
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B5115B98AA836CA8

Thanks for your help

Thank you so much for 7.5. I have been able to open a DV 16:9 project that had the phantom sound problem (sound playing when it is not on the time line). Every thing plays well and I have even been able to replace the voice over, it has all gone well, looking forward to editing when I come home and hope to give you more feed back soon.

sunab

thanks for your reply!
unfortunately i am unable to solve this problem. it has had me pulling my hair out for a few days. i really don't want to give up on this as i really like this software.

Sorry I can't help Rofko, I'm a total newbie... but what happens if you try to install it again? Same error messages?

Hi everybody!

Have seen now the 'Kdenlive Builder Wizard'. Is there a chance that I get rid of the problem that Kdenlive goes frozen? Or is it a general problem in the version: '0.7.5'?
If I try it, do I have to deinstall more than only Kdenlive (I mean libraries for example)?

Thanks for help!

Rorohiko

HElllo
KDEnlive 0.7.5. is on my notebook!!
I have uninstelled vlc and libswscale0 ,after installed it again))

Hello,
I installed Kdenlive 0.7.5 on Xubuntu 9.04.
It seems it works well, but the launch icon did not appears in the application menu.
This is maybe because the menu of Xubuntu were reworked in this version of Xubuntu (and there is also no menu editor).

Hello,

On Ubuntu (Gnome) 9.04, Kdenlive 0.7.3 was working reasonably well. After following these instructions to update to the latest, I now get this:

kdenlive(5275) MainWindow::parseProfiles: RESULTING MLT PATH: "/usr/share/mlt/profiles/"
kdenlive(5275) initEffects::parseEffectFiles: // INIT EFFECT SEARCH
kdenlive(5275) Wizard::installExtraMimes: EXTS: ("*.vob", "*.mod", "*.mpe", "*.mpg", "*.mpeg", "*.mp2", "*.mts", "*.m2t", "*.ts", "*.m2ts")
kdenlive(5275) Wizard::installExtraMimes: INSTALLING NEW MIME TO: "/home/bob/.local/share/mime/packages/video-mpeg.xml"
kdenlive(5275) Wizard::installExtraMimes: EXTS: ("*.dv")
kdenlive(5275) Wizard::installExtraMimes: INSTALLING NEW MIME TO: "/home/bob/.local/share/mime/packages/video-dv.xml"
kdenlive(5275) Render::Render: ////////// USING PROFILE: hdv_1080_50i
kdenlive(5275) Monitor::Monitor: /////// BUILDING MONITOR, ID: 67111756
kdenlive(5275) Render::Render: ////////// USING PROFILE: hdv_1080_50i
kdenlive(5275) Monitor::Monitor: /////// BUILDING MONITOR, ID: 67111938
kdenlive(5275) RecMonitor::RecMonitor: /////// BUILDING MONITOR, ID: 67111981
kdenlive(5275) MainWindow::loadPlugins: // PARSING FIOLER: "/usr/lib/kde4/"
kdenlive(5275) MainWindow::loadPlugins: // FOUND PLUGIN: "libkdenlive_sampleplugin.so" = "/usr/lib/kde4/libkdenlive_sampleplugin.so"
kdenlive(5275) MainWindow::addToMenu: // ADD to MENU ("Countdown", "Noise")
kdenlive(5275) KdenliveDoc::setProfilePath: Kdenlive document, init timecode from path: "hdv_1080_50i" , 25
kdenlive(5275) KdenliveDoc::setProfilePath: Kdenlive document, init timecode from path: "hdv_1080_50i" , 25
kdenlive(5275) KdenliveDoc::KdenliveDoc: Kdenlive document, init timecode: 25
kdenlive(5275) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 4 , DURATION: 0
kdenlive(5275) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 3 , DURATION: 0
kdenlive(5275) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 2 , DURATION: 0
kdenlive(5275) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 1 , DURATION: 0
kdenlive(5275) TrackView::slotAddProjectTrack: ************* ADD DOC TRACK 0 , DURATION: 0
kdenlive(5275) TrackView::parseDocument: /////////// TOTAL PROJECT DURATION: 300
kdenlive(5275) Render::setSceneList: // NEW SCENE LIST DURATION SET TO: 0
KCrash: Application 'kdenlive' crashing...
sock_file=/home/bob/.kde/socket-bob-laptop/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly

I realize that this is Gnome not KDE, but .7.3 was working fine, now even after uninstalling the latest version and trying to reinstall from the Jaunty repos the original .7.3, it crashes with the same signal 11. As it is now, I can no longer use any version with Ubuntu.

Any help to resolve this is appreciated.

Bob

EDIT: SOLVED. It seems a number of other video related libraries must be upgraded as well.

Thanks a lot,
Works perfectly for me !

I'm running under Ubuntu 9.04 and kdenlive 0.75 as sunab has kindly suggested.

kdenlive has been freezing repepetively while I'm working in a project. I can work 5, 10, 15 minuts, but always end up freezing. No matter what I'm doing, watching a clip, watching the project, moving any object. Always freeze. I can work but it's very upset start the program once and again, and again.

Melt run well. I manually installed FFmpeg version SVN-r19576 (latest I think). I installed libsdl1.2debian-all (and automaticaly uninstalled libsdl1.2debian-alsa). Nothing seems to fix it.

Any suggestion?

I am getting much the same thing. The application is not freezing, but when reviewing a clip it stops during playback and cannot be restarted without restarting the application.

Rofko

I had the same problem. First of all make sure all the check marks are checked.
System->Admin->Software sources-third party.
(all sources should be checked, this is why mine failed)

Then go to
System->admin->Synapatic Package Manager
Make sure "ALL" is highlighted on left.
In quicksearch type "kdenlive" and mark all packages for installation.

If that doesn't work let me know I will let you know what packages I had in my third party list.

Thank you for this! This works perfectly to me!

I followed the howto at http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/... but upgrading to 0.7.5 doesn't work for me. Some packages (melt libavutil-unstripped-49 inigo libmlt-data) were downloaded but ffmpeg kdenlive kdenlive-data{a} libmlt1{a} are held back. What could be the reason?

hi tubgnome, there is something preventing a smooth upgrade. To solve it I suggest you manually uninstall all the kdenlive related packages if present on your machine. kdenlive, kdenlive-data, libmlt1, libmlt-data, libmlt1++, libmlt2++, melt, inigo. Then install the kdenlive package from my PPA and all the dependencies will follow.

From what kdenlive version are you upgrading? (to understand your issue).

hi everyone,

for users wanting new features and bug fixes before kdenlive official releases, I have set up a new ppa to package Kdenlive and mlt trunk. This will improve testing and bug report ability to many new users.

deb http://ppa.launchpad.net/sunab/sunab2/ubuntu jaunty main

Many fixes have been resolved since 0.7.5 release, see changelog : http://www.kdenlive.org/mantis/changelog_page.php
A major improvement (not listed in changelog), at least for me, is no more crash using many effects like technicolor and others.

Another contributor created a similar project but with a different point of view : he packages the latest ffmpeg, kdenlive and mlt to apply custom patches to improve AVCHD support of his Canon camcorder. See here for more information : http://www.kdenlive.org/forum/development-snapshot-ubuntu-packages

Hi All,

I am new to kdenlive. My first impressions are that it looks great!

I'd like to use the auto mask feature:
http://www.kdenlive.org/about-kdenlive/creative-effects

I am using ubuntu jaunty with kde 3.5. I tried using kdenlive (and associated packages) from:
- the official repository
- http://ppa.launchpad.net/sunab/ppa/ubuntu
- http://ppa.launchpad.net/sunab/sunab2/ubuntu

However, none of these options provide the auto mask feature. Looking at this old thread:
http://www.kdenlive.org/forum/automask-kdenlive-0721-and-ubuntu-intrepid
it seems that this is related to how mlt is compiled. Is there a repository where I can find a package that provides this option or do I need to recompile it?

Thanks,
Tom

hi tvercaut,

I will look at my compilations options, and update my package if needed.

sunab, thanks. It works. I think it was 0.7.3 from which I tried to update.

Hi, everybody!

I run Ubuntu 8.10 (interpid), after getting the pub.keys as recommended above, I've got:

The following packages have unmet dependencies:
kdenlive: Depends: dvgrab but it is not going to be installed
Depends: frei0r-plugins but it is not going to be installed
E: Broken packages

Any ideas what to do?