kdenlive 0.7.6 Ubuntu Karmic-Jaunty-Intrepid

Kdenlive 0.7.6 and MLT 0.4.6 are currently building on my testing ppa. When finished they will be copied to my kdenlive stable ppa. Also working on Intrepid and Karmic packages.
I will update the Ubuntu packages install page when finished.

Edit : packages for Karmic Jaunty and Intrepid are ready. http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Thanks for those! (And thanks for keeping us posted)

Thanks for this !

I have a problem of dependencies, i have no idea if this problem can be changed by modifing the ppa, but if yes, here is some info about it :

kdenlive:
Dépend : kdebase-runtime (>=4:4.2.4) mais (but) 4:4.2.2-0ubuntu1 doit être installé (has to be installed)

pepe

I used to run kdenlive 0.7.5 on plain Ubuntu 9.04 using the sunab repository.
Unfortunately, the new 0.7.6 release refuses to install.

All dependencies of kdenlive seem to be met, except the kde-libs:

The following packages have unmet dependencies:
kdenlive: Depends: kdebase-runtime (>= 4:4.2.4) but 4:4.2.2-0ubuntu1 is to be installed
Depends: kdelibs5 (>= 4:4.2.4) but 4:4.2.2-0ubuntu5.2 is to be installed
E: Broken packages

Is this a known limitation?

-> The issue has been resolved at the repository. Thanks for the quick help!

Installed tonight, Karmic, Toshiba AMD 64, running 32bit.

Using command 'melt -debug filename.mp4' correctly displays the video, but when the last frame is reached melt continued with the following output:
...
[filter gtkrescale] 1920x1080 -> 720x432 (yuv422)
[filter deinterlace] xine.deinterlace 1 prog 0 format yuv422
[filter gtkrescale] 1920x1080 -> 720x432 (yuv422)
[filter deinterlace] xine.deinterlace 1 prog 0 format yuv422
[filter gtkrescale] 1920x1080 -> 720x432 (yuv422)
[filter deinterlace] xine.deinterlace 1 prog 0 format yuv422
[filter gtkrescale] 1920x1080 -> 720x432 (yuv422)
[filter deinterlace] xine.deinterlace 1 prog 0 format yuv422
...
continues forever until 'q' or kill,
and processor remains at 100%

repeatable on all my mp4's.

Just noticed I'd been updated. Very smooth. Thank you so much :)

I have jaunty and I updated to 0.7.6 today with sunab-repository.

Kdenlive starts but is complaining I need MLT 0.4.5 but I have 0.4.6 i.e. the right one?

hello everyone,

First of all thank you for reporting about the quality of those packages.

Second, please be kind to tell which ubuntu version you are currently using, it will help me to debug (this topic is open for Intrepid, Jaunty and Karmic, and the packages are slightly different).

Third, if tou are trying to update, tell from what version you are upgrading (to optimize smooth old versions replacement)

About the kdebase-runtime dependency problem : i made a mistake, your system is requesting the backports version at some point (only jaunty i386 and lpia arch are affected). I will rebuild those packages to avoid that.

Edit : packages queued on soyuz, 2 hours to wait.
Edit 2 : packages rebuilt, all should be ok now.

@ xamiga : don't known about that, in my opinion it is not package related. File a bug report or try to reach Dan Denedy (mlt maintainer) on another topic.

ps : same problem here on jaunty amd64 arch.

@ Finnish : the correct version is the latest mlt 0.4.6 kdenlive 0.7.6.

- launch kdenlive
- menu configure>configuration wizard
- and follow the detection steps

any remaining problems?

@ sunab: thanks for the packages. A quick test shows they work great for me.

FYI I'm running karmic beta

I did have one problem. During the first run the first start screen showed I was missing mlt. This was fixed by removing the "kdenliverc" file in my home directory and then restarting. It is here: /home/[username]/.kde/share/config/kdenliverc

One other issue is I cannot render to x264 anymore, it is all red in render options box, but I think that is due to ffmpeg version being used may not include x264 support. I was thinking about building a version from source to fix this. Any thoughts?

I also noticed the recommended ffmpeg version for mlt is now r19873, but Karmic provides an older version. Any thoughts on if this will cause problems or not? I'm really trying to stay with packages instead of building everything from source.

Thanks, Geoff

Hi there,
I'm using Ubuntu Jaunty.

I had a pop up box on Ubuntu this morning saying something about a "partial upgrade", which also said that kdenlive would have to be removed, some libraries updated and did I want to keep or remove some obselete packages (I opted for keep). I normally pay more attention but I was tired and in a hurry, so I just clicked through everything and let it do its thing.

Now though, Kdenlive was indeed removed, and when I try to reinstall it (and I do have sunab's PPA in my software sources), I just get the following:

user@ubuntu:~$ sudo apt-get install kdenlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
kdenlive: Depends: kdebase-runtime (>= 4:4.2.4) but it is not going to be installed
Depends: kdelibs5 (>= 4:4.2.4) but it is not going to be installed
E: Broken packages

@digitalranger : I made a mistake when building for jaunty, now the packages are rebuilt and only claim about the regular kdebase-runtime. [solved]

@geoffrey : the ffmpeg gap between the recommended version by Dan (MLT maintainer) and the karmic version shouldn't cause many problems. But using r19873 improves seeking in H.264 and MPEG2 transport streams, as MLT had been patched to support that on 2009-09-15.

I plan to build the recommended r19873 ffmpeg (in a a few hours) in another ppa to test it. I will look at x264 enabling at this time.

Thanks a lot Sunab,

This problem :

kdenlive:
Dépend : kdebase-runtime (>=4:4.2.4) mais (but) 4:4.2.2-0ubuntu1 doit être installé (has to be installed)

is now solved for me, with ubuntu jaunty 32 bits, upgradding kdenlive 0.7.5 to 0.7.6.

However I still have the problem of MLT 0.4.5 (Kdenlive starts but is complaining I need MLT 0.4.5 but I have 0.4.6 i.e.) and doing that :

- launch kdenlive
- menu configure>configuration wizard
- and follow the detection steps

doesn't solve the problem.

I've tried Geoffrey's solution for Karmic (but I have Jaunty) : "during the first run the first start screen showed I was missing mlt. This was fixed by removing the "kdenliverc" file in my home directory and then restarting. It is here: /home/[username]/.kde/share/config/kdenliverc", but it doesn't solve the problem.

Any ideas ?

Regards

hi pepe,

your problem with MLT 0.4.5 message is curious. I tested the many upgrades in a virtual machine Jaunty 32 bits, from kdenlive 0.7.3, 0.7.4 and 0.7.5 and I can't reproduce the problem. In my upgrade cases, when I launch kdenlive after an upgrade to 0.7.6, the kdenlive config wizard is launched first automatically and MLT 0.4.6 is detected without any problems.

Have you ever installed kdenlive in another way than packages (build-wizard or compiling from source by hand)?

An explanation about requesting MLT 0.4.5 can be you are executing kdenlive 0.7.5 and not O.7.6.

The message about MLT 0.4.5 could come if have a previous install of MLT. To check the MLT version, Kdenlive first uses pkgconfig.

The MLT pkgconfig file is called mlt-framework.pc and installed in:
/usr/local/lib/pkgconfig (may depend on where you installed).

If you are using packages, that file is part of the mlt-devel package. So if you have not installed the new mlt-devel package, you might have an old mlt-framework.pc lying around.

To make sure, you can type:
melt --version

in a terminal, that will show you the correct MLT version. If it shows 0.4.6, you can ignore the Kdenlive warning, that is caused by a previous pkgconfig file...

@pepe: I misread your message. If Kdenlive asks for MLT 0.4.5, then you are not running Kdenlive 0.7.6

Kdenlive doesn't start after updating it... what should I do?

Hi,

im using Jaunty, i had same problem with mlt 0.4.6. But I installed mlt-devel and deleted mlt-framework.pc and mlt++.pc and this solved proplem in wizzard. But I have another problem there. I have not Qimage and I can not render MPEG-4, Xvid4, H.264, Flash and Theora. And another problem is, when I click OK in subtitles editor, Kdenlive crash. I had sunab 2 test Kdenlive before. Today I use Kdenlive 0.7.6. KDE 4.2.4 - jaunty backports.

P.

@puzzlenoise : can you explain a little more things :

- ubuntu version and architecture
- from what version are you upgrading? previous version was sunab's package?
- does the upgrade is smooth, any error message?
- "kdenlive doesn't start" : any error message, if not try to launch in a terminal and paste the errors.

hi funk,

one thing after another, what ffmpeg packages are you using? version and origin. FFmpeg in my kdenlive repository is able to encode to mpeg4, H.264 ...

second : qimage not present? it's in Qt libs so if you have KDE 4 on your system it's there ... Another package-config mess from previous test installs?

Hi Sunab,

yes, I had 4:0.5+svn20090926-0ubuntu1~tj~ppa1j from Openshot videoeditor. But I downgrade to yours 3.0.... so this didnt solve problem. I had to remove libavcodecs/libavformats/-unstripped as well. So, now i have big mess in my PC :0). I thing, that subtitles are my mistake as well. When Kdenlive crash, there is written: The application Kdenlive (kdenlive) crashed and caused the signal 11 (SIGSEGV).

@funk : sometimes mixing many ppas can be a problem for package consistency. I test my packages with clean and fresh virtual machines.

I cannot reproduce your problem, I played with the title editor, and no crahes for now.

ps: I know Tj's ffmpeg packages and his video-editors repository. His ffmpeg is like mine but more recent, in both packages mpeg4 and H.264 encoding are available. So your problem with those codecs disabled may come from other things. I encourage to carefully clean your system.

If your are looking for a recent FFmpeg for Jaunty or Karmic, I have set a new ppa (named ffmpeg-trunk) to test packages of the ffmpeg recommended version (r19873 aka 20090916) by the MLT maintainer Dan Dennedy. I will test it extensively and if there is no problem I will copy it in my kdenlive-stable ppa.

Thanks Sunab. Now I know that is my mess. I mixed many repos and that's it. Codecs aren't so big problem like title editor, but I can make it in Gimp on static picture. P.

Xamiga, this is expected behaviour from melt. It keeps playing the last frame. If you ran with -consumer sdl terminate_on_pause=1 you will maybe get different, expected behaviour.

Hello,

I've installed KDEnlive on my Ubuntu 9.04 using the PPA of sunab. It starts and I see the startup screen, but about 2 seconds after this, KDEnlive crashes, giving the following error backtrace.

Program: Kdenlive (kdenlive), signaal SIGSEGV
[Current thread is 0 (LWP 3560)]

Thread 3 (Thread 0xae52bb90 (LWP 3565)):
#0 0xb803e430 in __kernel_vsyscall ()
#1 0xb65ff412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb6706344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3 0xb801d289 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
#4 0xb65fc9ce in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#5 0xe8758bff in ?? ()

Thread 2 (Thread 0xaed2cb90 (LWP 3566)):
#0 0xb803e430 in __kernel_vsyscall ()
#1 0xb65ff0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb67062ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3 0xb3880fdc in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb5c6e920 (LWP 3560)):
[KCrash Handler]
#5 0x080dd307 in _start ()

hi Jenske,

I have tested installs in a clean distro and upgrade from 0.7.5 and I am unable to reproduce your crash.
Something may be wrong on your system.
Have you tried to delete the kdenlive configuration file in your home? in /home/[username]/.kde/share/config/kdenliverc

To all users,

new version of kdenlive packaging (version3), it includes a patch from svn trunk to avoid crash when using the dvd wizard (revision 4032).

I installed Kdenlive on my other laptop, it is Karmic koala-based. Everything works.

But still, on my 32-bit jaunty laptop, I'm getting error about my MLT-version. Synaptic tells me it's 0.4.6, but when I run in terminal

mlt --version

it tells me MLT melt 0.4.5

So whats going on here..?

Hi sunab and thank you.

With kdenlive 0.7.6 I loose some artworks: transition bar between two clips (see the image below), initial and final arrows in clip etc.
Is this a package bug?

Hi sunab,

I tried to install your ffmpeg-trunk testing ppa. However, I find the following error in synaptic when trying to install your kdenlive ppa version..

kdenlive:
Depends: ffmpeg but it is not going to be installed

It appears that ffmpeg/ffplay cannot be installed due to some dependency issues. All the libraries install okay such as libavformat-extra-52 and so on..

Hope this helps, Geoff

Using Ubuntu Studio 8.10, 64-bit.

Having problems installing. First uninstalled previous wizard install (removed /usr/local/bin/kdenlive/ & ~/.kde/share/config/kdenliverc).

Followed the guide, added repo, enabled backports etc. but get the following when trying to install (freely translated from swedish);
Following packages has dependencies which cannot be met:
kdenlive: Dependant on: libmlt++2 (>= 0.4.6) but will not be installed
Dependant on: libmlt1 (>= 0.4.6) but will not be installed
Dependant on: melt (>= 0.4.6) but will not be installed
Dependant on: libavdevice52 but will not be installed
Dependant on: libavfilter0 but will not be installed
Dependant on: libswscale0 but will not be installed
Dependant on: libpostproc51 but will not be installed
E: Broken packages

Some of these dependencies probably is because I've got the unstripped Ffmpeg install (and I need that). Other packages I can't find in Synaptic:
libmlt++2 (>= 0.4.6) - got libmlt++0.2.5 installed, can't find libmlt++2
libmlt1 (>= 0.4.6) - can't find
melt (>= 0.4.6) - can't find
libavdevice52 - stripped ffmpeg, got unstripped installed
libavfilter0 - can't find
libswscale0 - stripped ffmpeg, got unstripped installed
libpostproc51 - stripped ffmpeg, got unstripped installed

Kdenlive version in synaptic is said to be 0.7.6 so repo seems to be installed and working.
So, what's missing in the equation?

hi rylleman,

sorry for this, I have done some stupid things in ffmpeg and kdenlive packages for intrepid and I didn't had time to test those. Currently those packages are being rebuilt on my ppa.

sorry again, next time I will double check before uploading :)

edit : the new ffmpeg package for intrepid is built (version4), but the kdenlive package with updated dependencies (version4 too) is queued but there are a couple of hours to wait.

edit2 : packages built, tested and no more problems to install with intrepid (with backports enabled for sure, to have KDE4)

@guiodic : I don't have this kind of problem (using Jaunty and and regular kde/Qt)

I don't think that it's package related, it could be kde/Qt related ... what versions are you using?

hi geoffrey,
I saw where was the problem, an issue in ffmpeg package name : "ffmpeg-extra" instead of "ffmpeg". I'am rebuilding it. I will also modify the karmic kdenlive package to avoid the install of dummy packages (the unstripped ffmpeg libs are called extra now in karmic).

I use:

libqt 4.5.0-0ubuntu4.2 (

kde: 4:4.2.4-0ubuntu1~jaunty2 (from jaunty backports)

PPA now works and I installed Kdenlive 0.7.6 on Ubuntu Studio 8.10, 64-bit. Everything seems to be working as it should.

Hi. I just installed kdenlive 0.7.6 on my Ubuntu Jaunty following http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Unfortunately at beginning it crashed after a few operations so I installed kdenlive debugging symbols in order to generate useful reports just in case. At the moment the "Configuration Wizard" tells I'm missing QImage module and also to upgrade my MLT version. Actually as for MLT I have libmlt++2 installed (0.4.6-0ubuntu0~jaunty2).

In the other hand, I'm not able to install libmt++2-dbg from Synaptic and it gives:

libmlt++2-dbg:
Depends: libmlt++2 (=0.4.4+git20090927-0ubuntu2~tj~ppa1j) but 0.4.6-0ubuntu0~jaunty2 is to be installed

Any suggestion, please?
Thanks.

...also, is there any option in order to get a mailing digest from this forum?
Thanks

hi Munaciello,

your problem is very clear, there is a mess on your system. You have mixed 2 different mlt versions, mine (sunab's) and tj's from his video editors one. You musn't do that, use one or other.

If you still want to use my ppa, you must clean all your MLT related packages.

And for information there is no libmlt++2-dbg package in the ubuntu database, if such package exists in tj's ppa it doesn't follow ubuntu naming rules.

Ok, thanks for your reply.

So, I suppose I should remove all MLT and related packages, then all MLT lines from repos except the ones related to your sunab repos, just in case. Right?
Also, how to discover which of those lines to keep or remove from /etc/apt/sources.list ?

As far as I can see, that should mean choosing to have installed exclusively just one between OpenShot and KDEnlive... right?

Thank you.

PS: is there any option to get a mail digest from this forum?

Ubuntu Karmic 9.10 32 bit - Kernel

2.6.31-14-generic #46-Ubuntu SMP Tue Oct 13 16:47:59 UTC 2009 i686 GNU/Linux

Cannot get past the install step.

Try to install kdenlive and get

kdenlive:
Depends: libmlt1 (>=0.4.6) but 0.4.4-2build1 is to be installed

Try to Upgrade libmlt1 and get:

libmlt1:
Depends: libavcodec-unstripped-52 but it is not going to be installed
Depends: libavformat-unstripped-52 but it is not going to be installed
Depends: libavutil-unstripped-49 but it is not going to be installed
Depends: libswscale-unstripped-0 but it is not going to be installed

sunab,
Thank you very much for you work. I was able to install your ffmpeg PPA with the new changes and it works nicely, except I have found I now need a newer SVN version as this version and others cause problems with my HV30 .m2t files. I did some testing and a newer version of ffmpeg such as SVNr19976 doesn't crash on my files. Other slightly earlier versions may also work, but I chose this because it is the last before I would also have to upgrade ubuntus x264 packages. I don't know which specific patch fixes it though.

Can you share your secrets on how to create your debs from latest SVN source so I can create my own debs like you have done? Currently I'm using the checkinstall method (http://ubuntuforums.org/showthread.php?t=786095) but would like to create "proper" packages using the debuild method to ease the tracking of dependencies in Ubuntu. The checkinstall method puts all the libraries and everything into one package called ffmpeg. I've also tried using debuild, but it only gets half way through with some issue about dependencies that I don't know how to correct. My guess is that I'm missing some tweak to the debian/control or such file to fix this.

Any pointers would be appreciated or a copy of your /debian/ files so I can compare what you have done and help build these things.

I really just want kdenlive (version that works with my files) and amarok to co-exist using packages not a patchwork of source installs.

Thank you again for all your work and hope you have some thoughts or can help out.
Geoff

Hi - latest Karmic Update (32bit) - Kdenlive has installed and works fine. I set Audio to Pulse BTW

I deleted the file you said and then KDEnlive did work.
I made a small sample movie and all worked well.

BUT ... when I loaded an older movie, which was made in an earlier version of KDEnlive ... the crash reappeared.

The crash report is at the end of this mail.

Fortunately, when I then restarted KDEnlive, it worked again. But as soon as I tried opening a previous project ... boom.

I must add that, after having erased the file you mentioned, restarting KDEnlive and opening my former project, KDEnlive tells me the directory of this file is not correct. I assume it has something to do with that, but as I'm not a computer programmer, this is just an educated guess.

Error report (partly in Dutch)

Programma: Kdenlive (kdenlive), signaal SIGSEGV
[Current thread is 0 (LWP 4764)]

Thread 3 (Thread 0xb1edfb90 (LWP 4773)):
#0 0xb80a5430 in __kernel_vsyscall ()
#1 0xb6666412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb676d344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
#3 0xb8084289 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
#4 0x00000004 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xb16deb90 (LWP 4774)):
#0 0xb80a5430 in __kernel_vsyscall ()
#1 0xb66660e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb676d2ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3 0xb38e7fdc in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb5cd5920 (LWP 4764)):
[KCrash Handler]
#6 0x080dd307 in _start ()

So I had problems with MLT, Kdenlive complaining about wrong MLT-version.

I had previously installed Openshot Video Editor. Removing it (especially its special MLT-version) solved the problem.

Yeah!

Hi

I don't know how to get to contact the creators or heavily involved person with the development of Kdenlive

could you please help me?

I would really like to donate a google wave invitation to some person heavily involved with the development so they could experiment with this tool I have heard is great for discussions or brainstorms for developers of open source etc

many thanks

my email is:
Enzo.Gianvittorio@Gmail.com

cheers --

I tried compiling kdenive, but the artwork issue is still here. So this is a kdenlive bug or I need some package, but I have nearly everithing about kde4

The latest nvidia drivers 190.42 are now deemed stable, so it seems a good idea to move to this. I had been using the 185 series. But it uninstalls Kdenlive 0.7.6 from sunab ppa. When I try to reinstall, it wants to reinstall the 185 drivers. Obviously less than ideal. Is there any fix for this?

About missing artwork, it is a bug of Intel driver. I upgraded to v. 2.9.1 and artworks are there :)

But I have an issue with vob and mpeg2 export: I use ffmpeg-trunk sunab repo and export process crashes.

And:

I ise kdenlive 0.7.7 from sunab2 and ffmpeg-trunk by sunab

Exporting in xvid or mp4 or other make audio/video non syncronized...

Pages