kdenlive 0.7.6 Ubuntu Karmic-Jaunty-Intrepid

Kdenlive 0.7.6 and MLT 0.4.6 are currently building on my testing ppa. When finished they will be copied to my kdenlive stable ppa. Also working on Intrepid and Karmic packages.
I will update the Ubuntu packages install page when finished.

Edit : packages for Karmic Jaunty and Intrepid are ready. http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

hi all,

the problems with my ffmpeg trunk repo are 'expected', and I never advertised this repo for that reason. PLEASE DO NOT USE IT.

It was just an personnal experiment to test new seeking features of recent ffmpeg. The major problem are major changes in ffmpeg API, this results in 'bad exprerience' in decoding or encoding with some codecs/muxers (mpeg2, svq3 ...) with all programs that are not built against this recent ffmpeg.

To use it in a production machine you will need to recompile every packages that depends on ffmpeg (too much...).

So if you tried it, please downgrade to the regular karmic ffmpeg version.

PS: I will delete ffmpeg-trunk packages, as they are not useful for regular use.

PS edit : @guiodic, your problem with mpeg2 dvd crash is caused the problem described above.

ok, I'll try with "standard" ffmpeg form Ubuntu repos

ok, vob export seems work well. Thank you.
Have you idea where I can find a good ffmpeg repo so I can use x264 in kdenelive? the ubuntu version is not compatible :(

Hello,

I am trying to follow the instructions given here to install kdenlive on Kubuntu 9.10:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

However, I have a problem with the very first step:
1- go to System Menu > Software Sources > Third-Party Software;
Where do I find that? I looked inside synaptic and it was not in there.
Are you speaking about the KDE3 traditional menu or the new KDE4 menu or something else?

What is a ppa?

Can the documentation be updated a bit so that it's foolproof for nitwits like me?

Thanks for your work.

Blessings,

Augustin.

those instructions are for ubuntu not kubuntu.

But if you manage to find synaptics then look into it's setting menu and select repositories, then you'll find the third-party software tab in the window that will pop.

you can also do it in the terminal by typing:
sudo add-apt-repository ppa:sunab/ppa

then type:
sudo apt-get update

and finally:
sudo apt-get install kdenlive

PPA: personal package archives, some nice users (thank you sunab) have their own repositories with packages they create themselves like kdenlive. Those packages are stored in their Personal Package Archive, which you can access to install them.

Thank you Rico. I could install kdenlive without any problem.

I didn't know about ppa's (thank you sunab, indeed). It seems it is a *buntu specificity.
I just found this article, which is a nice introduction to ppa's:
http://www.desktoplinux.com/news/NS5056230026.html
Maybe this link could be added in an appropriate place in the documentation here:
http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-...

It's strange that the installation in kubuntu is not documented, especially since kdenlive is itself a KDE application.

I do not have the edit rights to the page above. It'd be nice for future users if it could be updated to add the link to the article about ppa's, and to include installation instructions valid for any flavor of *buntu, as provided by Rico, above.

Blessings,

Augustin.

Hi,

Installed kdenlive from Sunab PPA on Karmic running gnome, running excellently. Thank you very much for your efforts.

geordie

Hi guys.

I'm still with the same problem.

First of all, it's very difficult to me to follow the thread since I get NO mail notifications about the new thread updates. So, as I've been asking for a couple of time some posts ago, IS THERE ANY WAY TO RECEIVE AN EMAIL NOTIFICATION ABOUT THE UPDATES OF THIS THREAD? Hope someone will consider my help request, please.

So, getting to the point, that's the bug report I've been creating since I red no satisfying answer on this thread:
http://www.kdenlive.org/mantis/view.php?id=1270

Thanks for your attention.
Regards.

Hi to all.

My actual problem is reported here:
http://kdenlive.org/mantis/view.php?id=1270

Also, KDEnlive still in conflict with OpenShot?

Thank you.

Problem installing on 9.10 on a persistent USB key :

I went to System.. Admin.. Software Sources... "Other software" tab.. and added the PPA - it is now listed as :
http://ppa.launchpad.net/sunab/ppa/ubuntu
karmic
main

It took an age to reload, but eventually the greyed out dialog vanished.

Then I went to Applications.. Ubuntu Software Center.. typed in kdenlive, it found it, I pressed the install button. It failed.

I tried a terminal : sudo apt-get update && sudo apt-get install kdenlive
but got an error amongst the output :
W: GPG error: http://ppa.launchpad.net karmic Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B5115B98AA836CA8

I presumed I still needed to do this as in previous attempts :
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com B5115B98AA836CA8

That seemd to fix the key error, but I'm still getting this:
...
Fetched 308B in 0s (1,114B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive: Depends: libmlt++2 (>= 0.4.6) but it is not going to be installed
Depends: libmlt1 (>= 0.4.6) but it is not going to be installed
Depends: melt (>= 0.4.6) but it is not going to be installed
Depends: libavdevice-extra-52 but it is not installable
Depends: libavfilter-extra-0 but it is not installable
Depends: libswscale-extra-0 but it is not installable
Depends: libpostproc-extra-51 but it is not installable
Depends: swh-plugins but it is not installable
Depends: dvgrab but it is not installable
Depends: frei0r-plugins but it is not installable
Depends: recordmydesktop but it is not installable
Depends: dvdauthor but it is not installable
E: Broken packages

What's wrong? :)

Hello, I'm trying to install on Ubuntu 9.10 64bits with gnome.
I can't install kdenlive.
If I type sudo apt-get -f install kdenlive, i get this message:

sudo apt-get -f install kdenlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive: Depends: libmlt++2 (>= 0.4.6) but it is not going to be installed
Depends: libmlt1 (>= 0.4.6) but it is not going to be installed
Depends: melt (>= 0.4.6) but it is not going to be installed
Depends: libavdevice-extra-52 but it is not going to be installed
Depends: libavfilter-extra-0 but it is not going to be installed
Depends: libswscale-extra-0 but it is not going to be installed
Depends: libpostproc-extra-51 but it is not going to be installed

To the last two posts:
You need to install other programs that kdenlive uses. Try using synaptic and adding the extra repositories. Make sure all the repositories are selected (main, universe, restricted, multiverse). Then reload and try to install kdenlive again with synaptic.

I confirm I have the four repositories checked. updated, upgraded but still not able to install :o(

What does a
sudo apt-get install libavcodec-unstripped-52 libavdevice-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0

do? Which error messages?

@vpxavier - Why are using the "-f" flag with apt-get. This is probably not needed and can cause other problems if not used carefully. Maybe try it without.

If you are still having troubles installing, you should try using synaptic. Pick the "extra" packages and install them. some dependencies will likely need to be removed and others added, but it shouldn't be too many.

Install these:
libavformat-extra-52
libavcodec-extra-52
libavdevice-extra-52
libavfilter-extra-0
libavutil-extra-49

It will want to remove the base versions such as: libavformat52 which is okay

sudo apt-get install libavcodec-unstripped-52 libavdevice-unstripped-52 libavformat-unstripped-52 libavutil-unstripped-49 libpostproc-unstripped-51 libswscale-unstripped-0

went fine...

After that, sudo apt-get install kdenlive gives this result:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive: Depends: ffmpeg but it is not going to be installed
E: Broken packages

After that, if I want to sudo apt-get install ffmpeg, it gives this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ffmpeg: Depends: libavcodec52 ( libavcodec-extra-52 ( Depends: libavdevice52 ( libavdevice-extra-52 ( Depends: libavfilter0 ( libavfilter-extra-0 ( Depends: libavformat52 ( libavformat-extra-52 ( Depends: libpostproc51 ( libpostproc-extra-51 ( Depends: libswscale0 ( libswscale-extra-0 ( E: Broken packages

I'm on #!CrunchBang 9.04 (Ubuntuy Jaunty 9.04 respin) x86.

Installed 0.7.4 last night from the Ubuntu repo's.

Started project, continued to crash out with this error about 2:00 minutes into project monitor playback (w/ heavy scene changes):

"
The application Kdenlive (kdenlive) crashed and caused the signal 11 (SIGSEGV).
Please help us improve the software you use by filing a report at http://bugs.kde.org. Useful details include how to reproduce the error, documents that were loaded, etc.
"

Removed 0.7.4, added this ppa, reinstalled, fired up 0.7.6 just fine. Looked noticeably cleaner/better! Opened up saved project, and crashed at the same spot as before with same error.

Is this a system resources error? This machine only has 512mb of RAM.

Update:

The reason I didn't include a crash log with my previous post is because it didn't generate one.

Installed a fresh copy of #!9.04 on a machine with all around better specs and 1GB of RAM. Added the sunab ppa before doing anything else, then updated/upgraded everything and grabbed 0.7.6. Project file will open and play, but crashes at the same spot with the same SIGSEGV # 11. Crashes every now and then with same error when working on projects. I can recover from manual backups, but not gracefully from autorecovery.

Is is possible to tell kdenlive to simply ignore SIGSEGV's rather than terminating?

Is it also possible that the SIGSEGV is a result of not enough memory resources?

Other than this SIGSEGV # 11, kdenlive is amazing! Everything I'm looking for. Hopefully I can get this resolved soon? :)

Sunab, if this bug is not related to your packages, or if I should be discussing this elsewhere, please let me know!

Using Karmic currently with a Sony Vaio when I change the repository i still get the old kdenlive 07.5 version with KDE 4.3.2 and the old mlt...how do i get the new 7.6? or 7.7

I'm running both Ubuntu Intrepid 8.10 and Kubuntu Karmic 9.10.

I can't remember which versions I upgraded from. Both systems were able to upgrade to 0.7.6. Previously on Kubuntu 9.04, Kdenlive worked, saved files, had sound etc., but was crashy. I'd rather have that than what I have now. Now the Kubuntu version reads an SDL sound error when playing video. The system sound is set to standard settings, the sound on Kubuntu works fine otherwise in other programs.

0.7.6 on Ubuntu Intrepid still doesn't have sound like the earlier version did not, except now it is able to produce the SDL error at the bottom. The install wasn't as smooth and gave me an error for frei0r plugins update. Sound on this system is tricky. It seems that I've uninstalled pulseAudio at some point, as the sound chooser daemon will not start and various programs cannot share audio. This means that I cannot use the solution given here:
http://ubuntuforums.org/showthread.php?t=1071066

I wish I could get one of the Kdenlives on one of the systems to have sound so I can do a project at some point. My youtube fans are getting antsy.

kdenlive update error report

E: /var/cache/apt/archives/frei0r-plugins_1.1.22git20090409+repack-0ubuntu1~intrepid1_i386.deb: trying to overwrite `/usr/lib/frei0r-1/threshold0r.so', which is also in package frei0r

Also see this post: http://www.kdenlive.org/forum/kdenlive-075-ubuntu-jaunty-ppa#comment-5197

Update:

Spent the last ~4 hours editing and finishing a project. Did not suffer from a single crash. I made no changes to my software or hardware. Playback lagged occasionally due to the low system resources of the machine. Kdenlive is awesome!!!

So in summary:

Kdenlive 0.7.6 from sunab repo running great in #!CrunchBang 9.04 Lite on an HP DV5000 laptop w/ 1GB of RAM.

Hi

Any help getting this working would be very welcome. I have been fighting with this all day but can not resolve the dependencies.

ubuntu 9.10

$sudo apt-get install kdenlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
kdenlive: Depends: melt (>= 0.4.6) but it is not going to be installed
Depends: ffmpeg but it is not going to be installed
E: Broken packages

I had some other repositories enabled (trying to get cinelerra installed)
I disabled these and reinstalled some stuff and now it installs ok.

However I still (as with 0.7.5) sometimes experience kdenlive consuming 100% CPU when monitoring playback.

Hi,

I'm a bit inexperienced with Linux and I can't figure out from this website how to install kdenlive in Kubuntu 9.10.

I tried downloading synaptic but still couldn't find anywhere to "paste the line ppa:sunab/ppa" and when I ran "sudo apt-get update && sudo apt-get install kdenlive" everything is successful except at the end it says "E: Couldn't find package kdenlive".

Thanks for any help,
Aston

@efAston

Try:

sudo add-apt-repository ppa:sunab/ppa
sudo apt-get update && sudo apt-get install kdenlive

---------

I'm trying out the new kdenlive 0.7.6+svn4309-0ubuntu0~karmic1 and mlt 0.5-0ubuntu0~karmic1 in sunab unstable. I haven't been able to get vdpau working. I managed to build mlt with vdpau support on another machine, but I'd like to use the sunab repository on this one since it's also a myth box. I'm trying:

melt -debug 00008.MTS 2>&1 | grep -i vdpau

There's nothing in the output.

I can play the same file with mplayer:

Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))

Other than that it's working well. Thanks!

Pages