kdenlive 0.7.7 Ubuntu Karmic-Jaunty-Intrepid

Kdenlive 0.7.7 and MLT 0.5 are ready in my stable series PPA.
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Edit : If you are working with intrepid or jaunty you had a problem because I didn't upload at the same time kdenlive and mlt (this is stupid, I know, but I had more urgent tasks to do with by baby boy and then I forgot to finish the job). During the time lapse any upgrade failed with a missed dependency. Now it's ok and if you reload your package manager the upgrade will be smooth.

Edit 2 : If you are using ubuntu karmic with KDE 4.4, you must use my unstable ppa (ppa:sunab/sunab2)

Edit3 : both ppas have been updated to kdenlive 0.7.7.1

Sunab,

Thanks a ton for taking the time to keep us updated in Ubuntu. You have no idea how much I appreciate it.

I don't see vdpau under the video driver (where I would assume it would be listed).

Additionally, the timeline QT 4.6 bug is still present with the backported KDE 4.4 packages.

If I can be any help in helping you track this down, let me know. Another bug may have been fixed in this version that may make kdenlive finally viable for a project I am working on, but which currently has a peaking/crackling audio issue, so I am anxious to try it out.

Yeah, thanks for all your work. I'm using the latest Nvidia 195 beta drivers and I can't get VDPAU playback working. Mplayer is using VDPAU with the configuration so I can confirm that it's available. Playing back an AVCHD file with "melt -debug file.mts 2>&1 | grep -i vdpau" does not show any VDPAU output. I also have the unstable PPA enabled - is that a problem?

Thank you very much for maintenance kdenlive packages!

I would like to ask about my problem: kdenlive didn't updated from 0.7.6. to 0.7.7 with messages:

kdenlive: depends: libmlt++2 (>= 0.5) but 0.4.10-0ubuntu0~jaunty1 will be installed
depends: libmlt1 (>= 0.5) but 0.4.10-0ubuntu0~jaunty1 will be installed
depends: melt (>= 0.5) but 0.4.10-0ubuntu0~jaunty1 will be installed
depends: libmlt-data (>= 0.5) but 0.4.10-0ubuntu0~jaunty1 will be installed
E: broken packages.

Distr.: Ubuntu 9.04, the string
"deb http://ppa.launchpad.net/sunab/ppa/ubuntu jaunty main" was added to sources.list, apt-get update was finished succesfully.

Could you please advise something about fix the issue?

THank you in advance,

I'm trying to go from 0.7.3 to 0.7.7 in Ubuntu 9.04

The following packages have unmet dependencies:
kdenlive: Depends: libmlt++2 (>= 0.5) but it is not going to be installed
Depends: libmlt1 (>= 0.5) but 0.3.8-0ubuntu2 is to be installed
Depends: melt (>= 0.5) but it is not going to be installed
Depends: libmlt-data (>= 0.5) but 0.3.8-0ubuntu2 is to be installed
E: Broken packages

From synaptics melt is not installed but only offers 0.4.10
Where do I get melt >= 0.5
I tried both the command line and in Synaptics, update not possible either place due to melt.

Hello! I'm trying to install the new Kdenlive 0.7.7, but I get errors:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive: Depends: libmlt++2 (>= 0.5) but it is not going to be installed
Depends: libmlt1 (>= 0.5) but it is not going to be installed
Depends: melt (>= 0.5) but it is not going to be installed
Depends: libavdevice-extra-52 but it is not going to be installed
Depends: libavfilter-extra-0 but it is not going to be installed
Depends: libswscale-extra-0 but it is not going to be installed
Depends: libpostproc-extra-51 but it is not going to be installed
E: Broken packages

I'm using Ubuntu 9.10 and I get that message (in the bottom), when I type
sudo apt-get update && sudo apt-get install kdenlive

What's wrong? I used Kdenlive 0.7.6 earlier, it was automatically deleted when I upgraded Gimp to 2.7. (earlier I used packages for installation)

Now we have to create a video clip presenting our school. The schoolmaster said to us today, that the first version of that clip have to be done by Monday. I would like to use Kdenlive for video editing, so please help me how to install it!

P.S. Sorry for my English ;)

@Tadas

You may not have the extra codecs etc for ffmpeg installed. Try:

apt-get install libavcodec-extra-52 libavdevice-extra-52 libavfilter-extra-0 libavutil-extra-49 libpostproc-extra-51 libswscale-extra-0

Then install kdenlive.

You could also try "apt-get -f install" to fix the broken package.

As for the others not finding packages, make sure you either click Reload in Synaptic or apt-get update after adding the repository. I'm using 9.10 and the packages installed without a hitch for me.

Sunab,
I can confirm cryophallion words. The only annoying thing is the QT 4.6 bug with the backported kde 4.4 packages (https://launchpad.net/~kubuntu-ppa/+archive/backports). That bug makes kdenlive totally unusable.
As cryophallion says, if I can be any help in helping you track this down, let me know.
Thanks a lot for your work.

I've been following the Sunab daily for quite a while and now have the 0.7.7. I'm on Karmic 64 bit with Nvidia 9600GT graphics. Installation and packages seem to be fine, and overall stability and features have been quite good. BUT Melt playback both within Kdenlive and from a console melt command both have for several months had big problems with jerkiness and sound stuttering.

This may be related to PulseAudio and or my Nvidia driver. I think it would be quite helpful to have a general guide for the recommender setup for Kdenlive.

1. Which Nvidia driver is recommended or required?
2. What sound setup to use? Get rid of PulseAudio? Temporarily suspend it? What to use instead?

I actually locked my driver to 185.18.36 as many attempts to use later drivers like the 190 and 195 series introduced many problems - at one point installing a 190 driver required the removal of Kdenlive! The 185 driver seemed to have fewest issues. That's why I locked it. I'm willing to start experimenting again because I really need Kdenlive working better!

I have vdpau working fine with mplayer. MTS from Canon AVCHD playback is quite good now with mplayer. But I don't see that Kdenlive or Melt is using vdpau. Shouldn't it be visible as a video driver choice in Settings | Configure Kdenlive | Playback | Video Driver dropdown? It isn't there.

Pulse seems to be pretty half baked still, but also seems to present big problems in removing it, since it has become so pervasive throughout some key Ubuntu multimedia packages and settings. I hate to remove it and have sound be screwed up on other apps. Is there a method to temporarily suspend Pulse while using Kdenlive that works well? Lately it seems that when I kill Pulse it seems to just restart itself! Or some other strategy? Or is Pulse suppose to be okay with Kdenlive now and there is some other problem?

I've installed 0.7.7 from this repository, but now the timeline doesn't work at all. A clip does not snap on horizontally and even vertically (tried the snap-on on on and off button). If I put in the second video track, I can't even move the clip again. Very weird.

Same problem ... the timeline doesn't work at all and it's impossible to do something.

config : Ubuntu 9.10 nvidia driver, and pulse audio

ps: what is VDPAU ??

VDPAU is GPU assisted video decoding - takes the burden away from the CPU, but the linux support is still not the best

Jaunty with KDE 4.4 and 0.7.7 - same issues with no vertical or horizontal snapping, unable to delete from timeline and playback does not match clip position. Unusable.

I am working on the issue in this thread. AMD64 already uploaded, working on 32 bit currently.

Hi all,

For people having dependencies problems during the upgrade see the edit in the top post.

For the Qt 4.6 problem :

my packages are built against the officially supported version of Kde in each ubuntu version since intrepid. I see some people here mixing my packages with KDE 4.4 from another PPA. But my karmic packages are built against KDE 4.3 : this may result in bugs because my packages are not aware of new procedures of a more recent Qt/KDE.

I could set up a separate ppa for kdenlive 0.7.7 built against Kubuntu-backports-ppa for karmic users or simply rebuild my karmic packages against that ppa but this will force every karmic user to upgrade to KDE 4.6.

edit : for karmic users wanting to work with KDE 4.4 use my unstable ppa, I will rebuild the karmic packages there in a few hours.

Sunab,
As someone with a 2.5 year old and a 4 month old, I certainly understand little boys taking up a lot of time.

I really appreciate you taking the time to keep the repos updated, and I don't envy you the time it takes to do the job. (I personally did it on two different comps to create the two architectures).

Let me know if there is anything I can do to help. Hopefully my unofficial packages can act as a holdover until you can get the time to do them the proper way.

Using my unstable ppa with karmic you can enjoy kdenlive and mlt built against KDE 4.4. This avoids many problems reported here with this recent KDE version (officially supported in lucid).

Note : My ppa does not contain KDE 4.4, my packages are just built against it. So if you don't have KDE 4.4 previously installed on your system, your package manager will shout for missed dependency...

Note 2 : My unstable ppa is updated every weekend with an svn snapshot, so be careful with your updates.

I typed in that command and it then wants to try and remove ffmpeg kdenlive libavcodec52 libavdevice52 libavfilter0 libavformat52
libpostproc51 libswscale0

hi hellocatfood,

can you explain a bit more : What command did you type in? What ubuntu version are you using? Other ppas installed on your system (potential source of conflicts)?

Thanks a lot Sunab for the new packages on Karmic KDE 4.4. Excellent work!

sunab2 ppa solves my timeline problems. thanks!

Thanks to Freecates and KoRnholio8 for the feedback, I will update the documentation.
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Thanks sunab
melt is there now and I have 0.7.7.
I vote for the baby boy being the first priority. :)

I can wait for Kdenlive 0.7.7.1, but all I need to know is, when it will hit your repo, because at the moment, I cannot work with this timeline/composite-bug so 0.7.7 is pretty useless to me.

I don't need Kdenlive at the moment, so take your time. And thanks for the repo. :-)

EDIT: Okay, 0.7.7.1 is here.

I may be doing something very very stupid and I begin by begging your pardon for that, but since I may not be the only one with the same problem I'll go ahead.

I used to use version 0.7.6 at Ubuntu Karmic without any problem. After upgrading to 0.7.7 I was not able to add any clip any more because the software crashes (I tested with .AVI and MPEG files). Version 0.7.7.1 shows the same behavior. When I run the software from the command line it shows the following lines:

kdenlinfgf@nfgf-desktop:~/Cap$ kdenlive
Fontconfig warning: "~/.fonts.conf", line 6: invalid constant used : legacy
KCrash: Application 'kdenlive' crashing...
sock_file=/home/nfgf/.kde/socket-nfgf-desktop/kdeinit4__0

[1]+ Stopped kdenlive
nfgf@nfgf-desktop:~/Cap$

Any help?

Thank you

re: PulseAudio on Ubuntu:

http://idyllictux.wordpress.com/2009/04/21/ubuntu-904-jaunty-keeping-the...

It's the method I use to completely remove PulseAudio from my systems.

HOWEVER: Be aware that removing PulseAudio may cause problems with programs that depend on it. OTOH, my systems run Mplayer, Kdenlive, Xine, and many other media players with no problem using the ALSA drivers (or JACK if supported). If you follow the steps in the linked article you should end up with a system free from PulseAudio-related complications.

Btw, I have nothing against PulseAudio per se. I think it's a fine system, one that addresses a long-standing problem, but it's not so useful (at this point) for a system oriented towards audio/video production. I understand that JACK has been vetted for inclusion with Ubuntu's Lucid Lynx release, along with full support in PulseAudio. Perhaps this development can be of utility to Linux video editors (?).

Best,

dp

Hi, to modify /etc/pulse/daemon.conf works well.

If not, try to launch kdenlive with:

PULSE_SERVER=127.0.0.1 kdenlive

Pulseaudio will be excluded.

The sunab2 repos fixed the timeline problem - temporarily. Kdenlive updated yesterday and it's broken again :(

Hi Everyone!

I need to edit interviews related to a research work I'm involved. My camera is a canon hf20 (generating avhcd files). For the last 2 to 3 years I have only used ubuntu, so I thought kdenlive would be my best bet. My old laptop couldn't handle the job, so I bought a new one (HP dv6 2120tx - with intel i-series 5 and Nvidia graphics card).

I installed Karmic and was hoping to use only one machine to work with. I don't like dual boot, and don't want to learn how to deal with Windows 7... Unfortunately for me, because I don't know much about linux (I'm just an ordinary user who got sick of windows), I realized that Karmic was full of bugs (internet wireless, mobile key, sound,etc), and that the latest version of kdenlive I downloaded from the website would not work properly in it either.

Could any of you advise me on which ubuntu version, other than karmic, should I install kdenlive? Is there a step by step for ubuntu users that a lay person like me could use (and really succeed)? I would also be glad if I could avoid a dual boot just for the sake of editing interviews... I already decided to 'downgrade' my system to intrepid or jaunty as I don't have time do be fixing all these bugs at the moment due to family, studies, and work. Anyway, I would appreciate your inputs here in forum or in an email (eurico.vpc@gmail.com).

Another issue I'll have to be dealing with in the near future is how to subtitle these interviews. Can you point me to a tutorial or something similar? I have never done editing before, and time is an issue as I said. Still, I would like to stick with the open-source approach in my machine.

Thanks a lot!
Eurico

I can confirm this- same problem as briguy.

@ Eurico: please start a new topic for anything else other than installing kdenlive from sunabs ppas, otherwise this thread will become very hard to read.

Confirmed! same problem here, not snapping to timeline - karmic kde4.4, kdenlive 7.7.1

Confirmed too! Same problem: not snapping to timeline - karmic kde4.4, kdenlive 7.7.1

EDIT 1 (01-04-2010): Today I've downloaded again, now works perfectly. Thanks a lot for the great job done!

I'm using Kubuntu karmic with experimental repository 4.6 Qt libraries, and as for many other users Kdenlive doesn't work properly (for the timeline problem). Seen that sunab2 repository doesn't work, I made a deb file from the original sources and you can find it here: zorbaproject.uuuq.com/upload/kdenlive_0.7.7.1-1_i386.deb

To install it simply install Kdenlive from sunab2, then remove only kdenlive and kdenlive-data packages, and then install the deb file with Gdebi.
It's not a prefect solution, but you don't have to compile the program from yourself.

It worked well for me and other friends, so I hope it could help other users.

Luca Tringali

Hi,

as Freecates said, I updated my packages. Sorry for the mess, I forgot to activate KD4 ppa before building. I was too busy these last weeks to see it.

I am back on business, a new build every sunday on sunab2 ppa.(Beware svn trunk!)

For stable series see here.

hi

I have a problem to play video and sound under kdenlive. It play 2-3 seconds and it stop(i can do nothing). All works well until i play. I have KDE 4.4.2 and Kdenlive 0.7.8 under Ubuntu Karmic classic.

I think its maybe a sound problem, but i choose many drivers (pulse, alsa...) and it stop..

Maybe others persons have the same bug ?

Thanks for help

@magisterpecoris: please open a new topic for your issue as it does not sound like a packaging issue.

Hi, I just installed kdenlive in karmic with kde 4.4 (so I used the unstable ppa). My architecture is amd64.
The problem is that when I run kdenlive, the avformat module gives an error, making me think ffmpeg isn't detected. But when I run it from the command line, it works:
----------------------------------------------
$ ffmpeg
FFmpeg version SVN-r19352-4:0.5+svn20090706-2ubuntu2, Copyright (c) 2000-2009 Fabrice Bellard, et al.
configuration: --extra-version=4:0.5+svn20090706-2ubuntu2 --prefix=/usr --enable-avfilter --enable-avfilter-lavf --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --disable-stripping --disable-vhook --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --extra-cflags=-I/build/buildd/ffmpeg-0.5+svn20090706/debian/include --enable-shared --disable-static
libavutil 49.15. 0 / 49.15. 0
libavcodec 52.20. 0 / 52.20. 0
libavformat 52.31. 0 / 52.31. 0
libavdevice 52. 1. 0 / 52. 1. 0
libavfilter 0. 4. 0 / 0. 4. 0
libswscale 0. 7. 1 / 0. 7. 1
libpostproc 51. 2. 0 / 51. 2. 0
built on Oct 13 2009 22:35:00, gcc: 4.4.1
At least one output file must be specified
--------------------------

Do I need to install a specific ffmpeg from a specific ppa? Or build from source? As it is now, kdenlive won't recognize mkv or avi files.
Thanks!

No, I just followed instructions, and had no errors.

I've also tried doing a strace, and found nothing suspect. /usr/bin/ffmpeg gets loaded, as is /usr/lib/mlt/libmltavformat.so and /usr/lib/libavformat.so.52

Any idea on what to check now? I also did ldd on all these and kdenlive, and there is no missing lib.

Could you please post you backtrace?

I think there might be a problem with the dependencies on latest kdenlive
stable repository:

Im running Ubuntu 9.10 karmic koala

I have added the kdenlive ppa for KDE 4.3 as described on
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

when I do
apt-get install kdenlive
I get the errors:

kdenlive: Depends: libmlt1 (>= 0.5) but it is not going to be installed
Depends: libmlt++2 (>= 0.5) but it is not going to be
installed

Something wrong in the PPA?

Cheers.

Hi,

first thank you for your work, but the current version seem to destroy my GSTREAMER framework and is unable to render anything:
http://www.kdenlive.org/forum/rendering-crashes

I noticed that it might be an issue with the freu0r plugins, GSTREAMER works fine if you deinstall them

Any ideas?