Kdenlive 0.7.8 install error on Ubuntu 10.10 [fixed]

Hi,

Today after upgrading Ubuntu to the latest version I wanted to reinstall Kdenlive and got these messages:

kdenlive:
Depends: libmlt++3 but it is not going to be installed
Depends: melt but it is not going to be installed

Installing these by hand resulted in an error about libmlt2

Seems to be a libmlt2 vs libmlt++3 conflict...

What to try next?

Thanks.

kdenlive 0.7.8 does not exist in Ubuntu 10.10 so I suppose you are using my repository. Upgrade procedure is tested and functional.
Your problem seem to be caused by some old install junk.

to correct that clean up your system. Delete old packages remaining on your machine related to kdenlive or mlt :

libmlt1 libmlt2 libmlt-dev libmlt-data melt libmlt++2 libmlt++3 libmlt++-dev kdenlive kdenlive-data

sunab.

Hi Sunab,

After upgrading to 64 bits Ubuntu everything works fine with the default Kdenlive install (Ubuntu 10.10 64 bit now - the earlier post was on 32 bits).

But after installinmg from the: ppa ppa:sunab/kdenlive-release I get the same error message which started this issue (see atatchment for details)

Thanks,

Bert

I am very sorry this is caused by a glitch in my packaging. I have reproduced it in a virtual machine, and it is caused by the way my packages force the install of ffmpeg unstripped libraries. The problem doesn't show up if they are already installed

I will correct it soon. Stay tuned.

sunab.

edit: packaging fixed, extra codecs (mp3, h264) aren't forced anymore, so any user should manually install the libavcodec-extra-52 package to use such codecs.

Hi, sunab

I am having the same problem as OP (Ubuntu10.10 32 bit) and the problem is still not fixed. Upgrading to libmlt3 removed libmlt2 and kdenlive. Tried to reinstall libmlt2 (which removed libmlt3 and libmlt++3 and melt) and tried to reinstall kdenlive but it said now kdenlive depends on libmlt++3 and melt?? Can't install either way.

Please advise. Thanks.

hi monkeybrain,

you say : "Upgrading to libmlt3 removed libmlt2 and kdenlive"

Where libmlt3 comes from? version 0.6.2? This package is only present in Natty (11.04).

Are you trying to upgrade to Natty? Playing with repositories can be a dangerous game...

To fix your problems you have to clean up your system.

On Ubuntu Maverick (10.10) a typical MLT install consists in these 4 packages :

melt
libmlt-data
libmlt2
libmlt3++

If a libmlt3 instead of libmlt2 exists on your machine, delete the 4 MLT packages (it will delete kdenlive) and disable the repository which brought them. Then reinstall kdenlive in a sane environment. By the way, which version of kdenlive are you installing? from PPA?

sunab.

Hi all,

I've successfully installed the latest release on Ubuntu 10.10 64 bits.

The error messages monkeybrain is getting are exactly the same as I got.

Sunab: thanks for the fix and keep up the good work!

Bert

Hi Sunab,

The package libmlt3 comes from the Maverick-bleed ppa (as is libmlt2)

I use the version of kdenlive from your ppa.

I will try your advice and see how it goes.

Thanks

At this moment the Maverick-bleed ppa and mine are not compatible.

sunab.

Hi, Sunab,

Just did the following and it worked.

I removed everything related to libmlt and melt, disabled the Maverick-bleed ppa and reinstalled kdenlive, I then reactivated Maverick-bleed (I need to keep it as I have installed quite a lot of stuffs from it) and checked for updates, there were 5 related packages that had updates: libmlt++3, libmlt2, libmlt-data, melt, python-mlt2. Of the 5 updating libmlt++3, melt and python-mlt2 would install libmelt3 and remove libmlt2 and kdenlive, the other two were ok (remove nothing). So I updated libmlt2 and libmlt-data and locked the version for the other three. Now everything appears to be working (on second thought I probably should have locked the version for the other two as well, but oh well, I will force their versions if something goes wrong)

Thanks a lot and keep up the good work!

@monkeybrain,

as you want to live on the bleeding edge, instead of locking packages risking incompatibilities and problems, you should use my kdenlive-svn ppa (ppa:sunab/kdnelive-svn).
It ships mlt 0.6.2 as Maverick-bleed ppa, so it won't uninstall kdenlive.

Hi, sunab,

Just tried out your svn ppa and here is the first bug report. :) There are some problems with maximizing, minimizing and closing the window of kdenlive. It is also extremely big (it overflows to the next virtual desktop) and I couldn't resize it the normal way. I use Compiz.

Thanks again.

Use the View menu to turn off the AudioSpectrum and Spectrogram.

Hi Sunab,

There seems to be a similar issue on the latest kdenlive release. I'm running Ubuntu 10.10 64 bits.

This is not an error but a warning... limbmlt version is moving from 3 to 4 so libmlt3 will be replaced by libmlt4. If all is ok, running "partial upgrade" (very bad named) all will be updated (just libmlt3 will be removed).

This warning is only because by default the update manager is very conservative, if you do the same update with Synaptic (package manager) it will update without warning.

please report success or failure with this update.

sunab.

ps : update the package list before ...