kdenlive 0.8.2 - Decklink card not found

I've been using kdenlive since 0.8 for my Decklink Blackmagic Intensity card. Once I upgraded to kdenlive 0.8.2 (and mlt 0.7.6 to match), though, I was no longer able to use the Decklink card. When I hit the play button in kdenlive with the Blackmagic card selected, it simply returns the error "Decklink card not found" in the little notification area.

I went back to the proprietary software (MediaExpress) that's provided for Decklink cards, and the card still worked there, so the drivers should be fine. I also upgraded the drivers just in case, but still no change. I then upgraded kdenlive to 0.8.2.1 to see if it would fix anything, but it did not. I feel almost as if I'm just not configuring something properly. I tried purging the configure files for kdenlive and reconfiguring it, and though it detects the device in the Capture settings, it still returns the "Decklink card not found" error when I try to use the card.

For now, I've downgraded my kdenlive and mlt to the versions I originally used (0.8 and 0.7.2 respectively). This also forced me to downgrade my ffmpeg from 0.9.1 to 0.7.8, but the rest of my libraries remained the same as they were. In this configuration, kdenlive finds and uses my Blackmagic card perfectly fine.

Does anyone know what could have changed between these versions? I feel like it must be something really simple that I'm missing, but so few people use Decklink cards on Linux that I haven't been able to find someone with the same problem.

Forums:

Perhaps there are multiple threads trying to access the card. If a thread locks access to the card, it makes it inaccessable to other cards and give the error of no card found.

I use a decklink card and haven't had issues, but then again I haven't used it with kdenlive for several weeks.