kdenlive 0.9 hangs on LinuxMint 12

I followed the Ubuntu instructions to install kdenlive 0.9:

sudo add-apt-repository ppa:sunab/kdenlive-release && sudo apt-get update && sudo apt-get install kdenlive

I then tried to run kdenlive and it complained about needing mlt 0.7.6, so I upgraded mlt and libmlt to 0.7.8. After that, kdenlive 0.9.0 starts up fine, but when I try to do anything, like add a clip or click the New... button, kdenlive hangs.

I found this thread http://kdenlive.org/forum/linuxmint-12-newbie-installation-mlt-errors and tried uninstalling kdenlive, mlt, and libmlt, followed by reinstalling everything from the svn repository: ppa:sunab/kdenlive-svn.

Again, the install completed with no errors, but when I run kdenlive, I get the same problem -- it hangs when I try to do anything with it.

Thanks in advance for any help. For now, I am unable to run kdenlive, and wouldn't you know it, I am in vital need of it at this particular moment.

Can you please post the result of the following commands in a terminal:

sudo dpkg --get-selections | grep mlt

ls -la /usr/lib/libmlt*

ls -la /usr/local/lib/libmlt*

Then, try to run MLT's command line player in a terminal:

melt color:red

It should bring a red screen.

thinkmate bin # sudo dpkg --get-selections | grep mlt
libmlt++3 install
libmlt-data install
libmlt4 deinstall
libmlt5 install

thinkmate bin # ls -la /usr/lib/libmlt*
-rw-r--r-- 1 root root 154120 2012-04-20 04:36 /usr/lib/libmlt.so.0.7.9
-rw-r--r-- 1 root root 118784 2012-04-20 04:36 /usr/lib/libmlt++.so.0.7.9
lrwxrwxrwx 1 root root 17 2012-04-20 04:36 /usr/lib/libmlt++.so.3 -> libmlt++.so.0.7.9
lrwxrwxrwx 1 root root 15 2012-04-20 04:36 /usr/lib/libmlt.so.5 -> libmlt.so.0.7.9

thinkmate bin # ls -la /usr/local/lib/libmlt*
ls: cannot access /usr/local/lib/libmlt*: No such file or directory

thinkmate bin # melt color:red
pops up a red window

Thanks for offering help.

Rick

when I put videos in the "bin" and move the mouse kdenlive disappears suddenly

here's what I get in console:

~$ kdenlive
QWidget::insertAction: Attempt to insert null action
QWidget::insertAction: Attempt to insert null action
kdenlive: symbol lookup error: kdenlive: undefined symbol: _ZN3Mlt5Frame12get_positionEv
~$

It turns out that kdenlive is not hanging, exactly. When I first run it and try to do something, such as Add a Clip, it appears to hang. There's no response from kdenlive until I repeatedly click the window close button. Most of the time, it eventually (after 5 or 10 clicks) responds by finally popping up the select clip dialog. I can then add a clip. After that, I can use the program normally. I have gotten some kdenlive crashes, but it does basically appear to work after the initial problem. Any clue what's going on and how to fix this?

Thanks.

Essaye de faire la même opération en décochant au bas de la "TimeLine" : "Afficher les miniatures audio" et "Afficher les miniatures vidéo".

might be related to the file dialog preview feature. Try disabling preview in the add clip dialog

Sorry, I'm not seeing where to disable preview. Where is that?

I was talking about the "Show Aside Preview" option available in the "configure menu" (top right icon) in the file dialog.

However I just installed a virtual machine with Linux Mint 12 and Kdenlive 0.9 seems to work fine, no freeze. Can you check which FFmpeg version you have? From a terminal, type:

ffmpeg

and post the result here.

well I moved to kdenlive svn (sunab) and it works fine ( almost ).

Now when I just started kdenlive and opened the Add Clip dialog, it did not hang as I described earlier. I've been having some other problems with Linux Mint 12 since I installed it -- many youtube videos result in their Aw Snap response in Chrome (but not in Firefox) and I am getting a system hang once or twice a day that requires a reboot. I have rebooted since last reporting on the kdenlive problems I've been seeing. Perhaps they're not due to kdenlive.

In any case, following is the output from the ffmpeg command:

$ ffmpeg
ffmpeg version 0.7.3-4:0.7.3-0ubuntu0.11.10.1, Copyright (c) 2000-2011 the Libav developers
built on Jan 4 2012 16:08:51 with gcc 4.6.1
configuration: --extra-version='4:0.7.3-0ubuntu0.11.10.1' --arch=amd64 --prefix=/usr --enable-vdpau --enable-bzlib --enable-libgsm --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvorbis --enable-pthreads --enable-zlib --enable-libvpx --enable-runtime-cpudetect --enable-vaapi --enable-gpl --enable-postproc --enable-swscale --enable-x11grab --enable-libdc1394 --enable-shared --disable-static
libavutil 51. 7. 0 / 51. 7. 0
libavcodec 53. 6. 0 / 53. 6. 0
libavformat 53. 3. 0 / 53. 3. 0
libavdevice 53. 0. 0 / 53. 0. 0
libavfilter 2. 4. 0 / 2. 4. 0
libswscale 2. 0. 0 / 2. 0. 0
libpostproc 52. 0. 0 / 52. 0. 0
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...