kdenlive compiled on kubuntu 9.04 beta

1 add medibuntu repository. #you can skip this

#userfull package #gnome
#sudo apt-get install  mencoder mplayer mozilla-mplayer xine-ui ubuntu-restricted-extras sox libsox-fmt-all  w32codecs libdvdcss2

#userfull package #kde
#sudo apt-get install  mencoder mplayer mozilla-mplayer xine-ui  kubuntu-restricted-extras kdemultimedia digikam  kmplayer kmplayer-konq-plugins  libsox-fmt-all  w32codecs libxine1 libxine1-ffmpeg 

# #
sudo apt-get install gettext  gawk x11proto-core-dev libxau-dev libxdmcp-dev x11proto-xext-dev libxext-dev libxi-dev x11proto-input-dev x11proto-kb-dev xtrans-dev libpthread-stubs0 libpthread-stubs0-dev libxcb1-dev  libx11-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libice-dev libsm-dev x11proto-render-dev libxfixes-dev libxcursor-dev libexpat1-dev zlib1g-dev libfreetype6-dev pkg-config libfontconfig1-dev libxft-dev x11proto-xinerama-dev libxinerama-dev libxmu-headers x11proto-randr-dev libxrandr-dev libxt-dev x11proto-record-dev libxtst-dev cmake cvs libstdc++6-4.3-dev g++-4.3 g++ libxmu-dev liblcms1-dev libjpeg62-dev libmng-dev libpng12-dev xlibmesa-gl-dev libglu1-xorg-dev libaudio-dev libssl-dev libkadm55 comerr-dev libkrb5-dev libpq-dev libglib2.0-dev libsqlite0 libsqlite0-dev libqt4-dev libsoprano-dev automoc libphonon-dev libasound2-dev libgpg-error-dev libgcrypt11-dev libtasn1-3-dev libgnutls-dev libcups2-dev libdbus-1-dev libkeyutils-dev libstreams-dev libstreamanalyzer-dev libxml2-dev libxml2-utils libxslt1-dev libgif-dev libavahi-common-dev libbz2-dev libenchant-dev libattr1-dev libacl1-dev libjasper-dev libilmbase-dev libopenexr-dev libpcrecpp0 libpcre3-dev libtiffxx0c2 libtiff4-dev hspell xsltproc kdesdk-scripts kdelibs5-dev libslang2-dev libncurses5-dev libaa1-dev libapr1 libaprutil1 libaudiofile-dev libcucul-dev libcaca-dev libdirectfb-extra libsysfs-dev libdirectfb-dev libesd0-dev libneon27-gnutls libqt4-opengl-dev libsdl1.2-dev libsvn1 subversion libglib1.2ldbl libgtk1.2-common libgtk1.2 libavc1394-0 libiec61883-0 libfreebob0 libjack0 libsndfile1 jackd ladspa-sdk libavutil49 libgsm1  libdv4 libfaad0 libjack-dev libmad0 libmad0-dev libogg-dev libpopt-dev libqt4-gui libswscale0 libquicktime1 libsamplerate0-dev libvorbis-dev qjackctl dvgrab libdv-bin libdv4-dev libfaac0 libfaac-dev libfaad-dev libmp3lame0 libmp3lame-dev libtheora-dev libgtk2.0-dev libavcodec52 autoconf automake cdbs fdupes ffmpeg intltool libavcodec-dev libavdevice-dev libavdevice52 libavfilter0   libavformat-dev libavformat52 libavutil-dev libquicktime-dev libquicktime-doc libsox-dev libsox-fmt-all libswscale-dev libxine-dev m4 recordmydesktop dvdauthor  libx264-dev  libxvidcore4-dev libopenjpeg-dev libamrwb-dev libamrnb-dev libdirac-dev

 

sudo apt-get build-dep ffmpeg libmlt++1 libmlt1 inigo  mjpegtools mpeg2dec openjpeg-tools libmad0 m4 liba52-0.7.4 lame faad2 libdvdread4 libcdio7 faac libdca0 libmpcdec3 libquicktime1 x264
 

mkdir kdenlivesvn; cd kdenlivesvn
svn checkout svn://svn.ffmpeg.org/ffmpeg/trunk ffmpeg
cd ffmpeg
./configure --prefix=/usr --enable-shared --enable-libmp3lame --enable-gpl --enable-libfaad --enable-libvorbis --enable-pthreads --enable-libfaac --enable-libxvid --enable-postproc --enable-x11grab --enable-libgsm --enable-libx264  --enable-libtheora --enable-libdc1394 --enable-nonfree --disable-stripping --enable-avfilter --enable-libdirac --disable-decoder=libdirac --enable-libschroedinger --disable-encoder=libschroedinger --enable-avfilter-lavf --enable-libamr-nb --enable-libamr-wb
make
sudo make install
cd ..
Checkout MLT from git:
git clone git://mltframework.org/mlt.git

./configure --prefix=/usr --enable-gpl --qimage-libdir=/usr/lib/ --qimage-includedir=/usr/include/qt4 --avformat-swscale
make clean;make
sudo make install
cd ..

svn co https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive
cd kdenlive
mkdir build; cd build; cmake .. -DCMAKE_INSTALL_PREFIX=/usr; make
sudo make install

I followed these instructions after having crashes when saving under Jaunty. Worked great - unfortunately I now have crashes every time I watch a clip that uses the composite transition. :(

Thanks for the instructions anyway, they will probably be useful again later.

mm bad new

hi well i have tried just now , and "here" it works pretty good but i have no compiz no kde effects and nothing that can be interfere with kdenlive.

 

 

 

maybe try to set up something on the settins--->configure kdenlive--->playback

 

if you get crash when you try to set somethuing on playback  try to delete config file 

$HOME/.kde/share/config/kdenliverc
 

here i have compiled even without these  libxcb-xlib0-dev libartsc0-dev (needed on intrepid...)
that i can't find on jaunty maybe it that the issue

good luck....

 

this was reccomended for 8.10 §(see here http://www.kde-apps.org/content/show.php/Kdenlive+Builder+Wizard?content...)

a copy of that :

sudo apt-get install gettext kommander gawk
 x11proto-core-dev libxau-dev libxdmcp-dev x11proto-xext-dev
 libxext-dev libxi-dev x11proto-input-dev x11proto-kb-dev xtrans-dev
 libpthread-stubs0 libpthread-stubs0-dev libxcb1-dev libxcb-xlib0-dev
 libx11-dev mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev libice-dev
 libsm-dev x11proto-render-dev libxfixes-dev libxcursor-dev
 libexpat1-dev zlib1g-dev libfreetype6-dev pkg-config
 libfontconfig1-dev libxft-dev x11proto-xinerama-dev libxinerama-dev
 libxmu-headers x11proto-randr-dev libxrandr-dev libxt-dev
 x11proto-record-dev libxtst-dev cmake cvs libstdc++6-4.3-dev g++-4.3
 g++ libxmu-dev liblcms1-dev libjpeg62-dev libmng-dev libpng12-dev
 xlibmesa-gl-dev libglu1-xorg-dev libaudio-dev libssl-dev libkadm55
 comerr-dev libkrb5-dev libpq-dev libglib2.0-dev libsqlite0
 libsqlite0-dev libqt4-dev libsoprano-dev automoc libphonon-dev
 libasound2-dev libgpg-error-dev libgcrypt11-dev libtasn1-3-dev
 libgnutls-dev libcups2-dev libdbus-1-dev libkeyutils-dev
 libstreams-dev libstreamanalyzer-dev libxml2-dev libxml2-utils
 libxslt1-dev libgif-dev libavahi-common-dev libbz2-dev libenchant-dev
 libattr1-dev libacl1-dev libjasper-dev libilmbase-dev libopenexr-dev
 libpcrecpp0 libpcre3-dev libtiffxx0c2 libtiff4-dev hspell xsltproc
 kdesdk-scripts kdelibs5-dev libslang2-dev libncurses5-dev libaa1-dev
 libapr1 libaprutil1 libartsc0-dev libaudiofile-dev libcucul-dev
 libcaca-dev libdirectfb-extra libsysfs-dev libdirectfb-dev libesd0-dev
 libneon27-gnutls libqt4-opengl-dev libsdl1.2-dev libsvn1 subversion
 libglib1.2ldbl libgtk1.2-common libgtk1.2 libavc1394-0 libiec61883-0
 libfreebob0 libjack0 libsndfile1 jackd ladspa-sdk libavutil49 libgsm1
 libavcodec51 libdv4 libfaad0 libjack-dev libmad0 libmad0-dev
 libogg-dev libpopt-dev libqt4-gui libswscale0 libquicktime1
 libsamplerate0-dev libvorbis-dev qjackctl dvgrab libdv-bin libdv4-dev
 libfaac0 libfaac-dev libfaad-dev libmp3lame0 libmp3lame-dev
 libtheora-dev
 

 

edit ok i have problems with my website

It crashes for me also when I try to save the project...

I deleted $HOME/.kde/share/config/kdenliverc , but it still crashes (segmentation fault).

compile then... compiling the latest svn the bug is solved