Kdenlive config wizard ignores libfaac

I am 100% certain libfaac is installed. I downloaded and compiled the newest version of FFMPEG (with libfaac enabled) and could render in libfaac or AAC with it. But it is a different story with Kdenlive. The config wizard simply doesn't see libfaac and kdenlive would not allow me to render in x264 + libfaac (or aac). I am forced to make do with libmp3lame but most if not all flash-based web video players would not with it (the result being no sound).

Please help. Would compiling Kdenlive from source help?

I run Ubuntu 10.04 on my machine. Kdenlive worked fine on my last 9.10 system.

Forums:

I followed the instructions on this page:

http://ubuntuforums.org/showthread.php?t=786095

No luck. Still couldn't render in libfaac.

How did you "downloaded and compiled the newest version of FFMPEG?" You can not just compile and install a dependency in a package-based system without updating or compiling/installing everything it depends upon.

Dear sgfhk321 and ddennedy,

this post is quiet old but I think not solved. I followed the offical ffmpeg update (with libfaac) instruction on https://ffmpeg.org/trac/ffmpeg/wiki/UbuntuCompilationGuide . ffmpeg works now perfect with libfaac and h264 in the console. But if I run kdenlive config wizard I can't find libfaac in the audio codecs. That seems also the reason why I get this error message while creating a new profile with parameter acodec=libfaac. Is this parameter in the kdenlive profile not just passed through to ffmpeg? How can I add this codec to the list of audio codecs in kdenlive to allow me to click on "render to file"-button?

Many thanks in advance for your help
Best regards
Christian

kdenlive-version:0.9.2
ubuntu: 11.10
ffmpeg-configuration: --enable-libfaac

Dear all,

I found two hints:
1.
The audio codecs you see if you click "Settings > 'Run Config Wizard'" seems to be the the output of

melt -query "audio_codecs"

So melt is the problem and not ffmepg?

2.
If you execute

ffmpeg -codecs

You can see that in ffmpeg aac is able to de- and encode while libfaac is only able to encode.

Perhaps the easiest way is to create a script with kdenlive and change it. But I'm not so familar with kdenlive_render which parameters go to melt and which to ffmpeg. Perhaps somebody can help?

The following script (changed aac to libfaac) gives no sound:
SOURCE="file:///path2File/script002.sh.mlt"
TARGET="file:///path2File/test.mp4"
RENDERER="/usr/bin/kdenlive_render"
MELT="/usr/bin/melt"
PARAMETERS="-pid:12906 in=12297 out=12350 $MELT atsc_1080p_25 avformat - $SOURCE $TARGET f=mp4 hq=1 acodec=libfaac ab=128k ar=48000 pix_fmt=yuv420p vcodec=libx264 minrate=0 vb=4000k g=250 bf=3 b_strategy=1 subcmp=2 cmp=2 coder=1 flags=+loop flags2=dct8x8 qmax=51 subq=7 qmin=10 qcomp=0.6 qdiff=4 trellis=1 aspect=@16/9 pass=1 threads=1 real_time=-1"
$RENDERER $PARAMETERS

Any other ideas?

Best regards
ebel

Wow, this is a great coincidence: 10 min ago a new Ubuntu 11.10 update for melt was available. Now it works with acc. No libfacc is necessary for ACC! Sorry for spaming!

Best regards
ebel