Kdenlive doesn't render to any format

Hi everyone.

I have the following issue: When i try to render a file to any format, kdenlive will say "Rendering of [filename] aborted, resulting video will probably be corrupted."
EDIT: I would like to add that the issue is present even if the project uses only a 5 second long image clip. It has nothing to do with effects. Also, no format works, even AVI or DV.

I have tried renaming the facedetect.so file as suggested on http://www.kdenlive.org/forum/resulting-video-will-probably-be-corrupted without luck.

I'm using two boxes, both openSUSE 12.1, kdenlive 0.8.2 running under KDE 4.7.2. One 32 bit, the other one 64 bit. It doesn't work on either one.
Also, i have:
libmlt++3 0.7.6-1.3
libmlt4 0.7.6-1.3
mlt 0.7.6-1.3
python-mlt 0.7.6-1.3
frei0r-plugins 1.3-3.1.2

Forums:

Will it render 'selected' tracks rather than full project.

So if you set a temporary in & out point via the 'Project' monitor for a certain amount of your projects timeline and then in the render dialogue, render 'Selected' rather than whole project.

Also not sure if your kdenlive version against MLT version is correct. But can't be sure on that, there may be a incompatibility there.

Hi yellow,

Rendering the selected zone only as per suggested will also fail.

Did you check the bug fix release 0.8.2.1 yet?

Hi, after rebuilding frei0r, mlt and kdenlive from source, i still have the same issue. Tried with FLV and MP4, still no go. I removed all the packages using YaST first, then built them from source code using sources downloaded from GIT. I also changed "git checkout v0.8.2" to "git checkout v0.8.2.1". http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/...

Have you ran kdenlives configure to see if all required packages are present / detected?

What version of ffmpeg are you using? Are you compiling that from source. When you removed all packages did you remove all ffmpeg / libav related too, like libavformat etc and then compile or reinstall them?

Hi, yellow. Answering your questions:

When i updated the first thing it did was to run the configuration dialog, and no dependencies were missing. In fact, i have everything on the lists.

My ffmpeg is installed from YaST, version 0.8.7-1.1.

hi, although I was using ffmpeg from git which was 0.8.x and kdenlive would render although there were other problems I believe kdenlive / MLT are tested against stable ffmpeg which is 0.7.x. Not that I think that the version difference is stopping rendering working only that you may find other incompatibilities anyway.

I guess you could try deleting the kdenliverc file in your home/.kde/share/config folder, best do a search for the file I can never remember its location. :-) Then let kdenlive do a new config at start up.

Hi there yellow. Unfortunately, i have deleted the rc (configuration file in ~/.kde4/share/config/kdenliverc) to no avail. I'd also like to point that i always create the simple project from scratch, putting an image file in the project then try to render, so the project file isn't the issue.

Also, it seems it's something distro related (opensuse 12.1), since http://www.kdenlive.org/forum/error-message-rendering-crashed-99-or-100-... is the same issue. However, the video isn't OK since i can't upload it to youtube or play it with xine (it will crash, but play the audio fine), or convert it to another format.

EDIT: Here is the complete error log. Size: 129 KiB. http://pastebin.com/8x0SrvYz

not sure but I have no issues at all using sunab's svn-kdenlive PPA for Ubuntu 10.04. I see you're using a non-debian based linux, sorry I wish I couldn't be of more help

I've got the same problem here.

OpenSuse 12.1 and KDEnlive 0.8.2.1, every Render crashes, no matter what I try.

Any help would be highly apreciated.

Peter

@PHabermehl: It isn't KDEnlive, that name could be misleading since this project isn't part of KDE.

@ibelcomputing, although this is of no help to your rendering issue kdenlive does in fact stand for KDE 'n' on 'li' near 'v' ideo 'e'ditor and probably soon will be a bigger part of the whole KDE thing via the Devs. ;-)

http://www.kdenlive.org/users/j-b-m/getting-ready-kdenlive-082

And a quote from that page by j-b-m:

"After that release, we will be moving to KDE's infrastructure to be part of KDE multimedia..."

Yellow: Thanks for the aclarations and for the link.

As for the rendering issue, i found this:
http://kdenlive.org/mantis/view.php?id=2422

It says to use mencoder to fix the video so youtube will accept it. I haven't tried it yet, but i will report back if this method generates a valid video.

From the link:
AVI file can be "fixed" using mencoder and repackaging the A/V streams:

mencoder -ovc copy -oac copy -o fixed.avi broken.avi

Well, it's useless. Trying to render to avi using the profile AVI DV will generate a 0 byte file.

How can i get a clue on what's going on?

You could try the build scripts here:

http://www.mltframework.org/twiki/bin/view/MLT/BuildScripts#Kdenlive

It may work for you on your distro. I've used it with great success on Ubuntu, the script will build (hopefully) a localised build of all required in a dated folder in your home directory and may get you further.

Well, lookie what we have here.

The script gave me:
LOG: Number of steps completed : 36
~/kdenlive/src
LOG: Process has finished. Reason: SUCCESS Everything succeeded

But the rendering process is giving me:
Rendering of /home/alberto/kdenlive/untitled.avi crashed
[swscaler @ 0x7f0b09480360] Warning: data is not aligned! This can lead to a speedloss

*** glibc detected *** /home/alberto/kdenlive/20111217/bin/melt: free(): invalid pointer: 0x000000000080a550 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x74c06)[0x7f0b3fcc5c06]
/usr/lib64/ladspa/sine.so(_ZN22StartupShutdownHandlerD1Ev+0x26)[0x7f0b34db53e6]
/lib64/libc.so.6(+0x379a1)[0x7f0b3fc889a1]
/lib64/libc.so.6(+0x37a25)[0x7f0b3fc88a25]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x7f0b3fc72244]
/home/alberto/kdenlive/20111217/bin/melt[0x402369]

So it seems something is not quite right. I'm using the build from the script with the same result.

EDIT: I have tried playing the resulting video and it seems to work! Xine played it without crashing. Now, if i can (finally) upload the original project to YouTube, all right...

I need to use GIT version of 'mlt' future 0.7.7 version.

Starting from original src.rpm package I redo the RPM package for my OpenSUSE 12.1. I only need to change a little 'mlt.spec' file. Here is the diff I maked:

10c10
---
> Version: 0.7.7
272a273
> %{_libdir}/mlt/libmltrtaudio.so

Original package:
-------------------
http://packman.links2linux.org/downloadsource/278968/mlt-0.7.6-1.10.src.rpm

After install all generated packages I install Kdenlive and all render well.