Kdenlive doesn't start after Installation

Hi everyone.

I switched to Ubuntu 9.04 yesterday, hoping that video editing software will work here...
But now I still have problems.

I installed kdenlive through the package for 9.04, and if I want to boot the program, it wont. Nothing happens if I'll open Kdenlive.

What may the problem be? :(

Regards, Puzzlenoise

Switch, as in a clean install? How did you install the package? What version of kdenlive (there are major changes in the support lib mlt from 0.7.3 to 0.7.4) What happens if you run it from the commandline?

Have you tried deleting the kdenlive.rc file from your .kde folder?

Jup, a clean install. It's Kdenlive 0.7.3, I installed it with tiping "sudo apt-get install kdenlive dvgrab frei0r-plugins swh-plugins libfaad0" in the terminal.

If I write "kdenlive" in the terminal (I think that's how I start it per terminal, if I'm not wrong) I get this message:

daryl@daryl-desktop:~$ kdenlive
kdenlive: error while loading shared libraries: libmlt.so.1: cannot open shared object file: No such file or directory

I didn't delete anything, should I delete this "kdenlive.rc"-file?

Did you upgrade from Ubuntu 8.10? Or did you do a fresh install of kdenlive on a fresh install of Ubuntu 9.04?

Did you have kdenlive installed from the builder wizard before?

The tip to remove kdenliverc is for the case when you used an older version of kdenlive on the same system before.

Also see a number other posts about not installing/removing frei0r packages before installing and running the setup wizard for the first time. This is a know problem with 0.7.3.

Also try the PPA repo that lure posted for 0.7.4. Haven't got it to work yet, but you might have better luck. See http://www.kdenlive.org/forum/074-ubuntu-intrepid-810#comment-3478

The frei0r-packages are installed - that happened, as I installed all those things per Terminal ("sudo apt-get install kdenlive dvgrab frei0r-plugins swh-plugins libfaad0")

I cannot install all of those packages that Lure posted in this thread, only the "kdenlive data"-package.
I can't install the "Kdenlive"-Package, because "libmlt++2" is missing, I think. But I don't know how I can get libmlt++2, since it isn't in the Synaptic package list.
Because I can't install the Kdenlive-package, the "Kdenlive-dbg"-Package also doesn't want to install.
Again - those are the packages from Lure... shouldn't they be for Ubuntu 8.10? I use 9.04, as stated before.

I watched in the .kde-folder of mine, and couldn't find any file containing the name "kdenlive".

Don't just install single packages from lure's repository! Add the whole repository to your package management!
There's a submenu in Synaptic where you can add third party package sources. That's where you have to add

deb http://ppa.launchpad.net/lure/video/ubuntu jaunty main

For more details, check out https://help.ubuntu.com/9.04/add-applications/C/adding-repos.html

If this still doesn't fix the issue, get back to us over here.

I did this method, but i had this problem (with jaunty) :

when i launch kdenlive 0.7.4 when it starts it asks me that :

"cannot find the melt program required for rendering (part of Mlt)"

I have updated libmlt1 to 0.4.2-1 version but it still asks me that.

I've tried to put the following path in this window, but without success...

/usr/lib/mlt/libmltmelt.so (after that, it says in french : "error, couldn't find SDL module from MLT, Kdenlive will not start untill you fix this")

(cf. http://www.kdenlive.org/forum/074-ubuntu-intrepid-810 )

Someone has the same problem ?

Okay, I added this package source and installed kdenlive and kdenlive dbg, with these other files which were automatically added to install.

Still, Kdenlive won't start. I get the same error message as before...

daryl@daryl-desktop:~$ kdenlive
kdenlive: error while loading shared libraries: libmlt.so.1: cannot open shared object file: No such file or directory

I have the same problem. I did an install from the ubuntu repository and when I run the config wizard I get "FatalError, couldn't find SDL module from MLT, Kdenlive will not start untill you fix this.
I am running Ubuntu Studio 9.04 on an AMD machine.
I also have an old pentium 3 machine running Ubuntu 9.04 which loads OK.
I am new to Linux and still finding my way round, but when I look in the directories of the two machines with respect to MLT they appear to be the same.
Is it to do with how the different processor's handle the program?

This issue with the default kdenlive packages in 0.7.3 is created by a faulty plugin in the frei0r library. You can solve it is by unistalling frei0r, though that's not really helpful because you will loose support for some effects. There is a work around though, you can manually remove the plugin by going to this directory /usr/lib/frei0r-1 (or something like that) and remove the facedetect.so plugin in that directory.

At least that is the case with my 9.04 ubuntu install (32 bit).

Well, that didn't fix my problem...

It still says that "libmlt.so.1" is missing. If I watch in Synaptic, I see that every libmlt-file is installed...

@Puzzlenoise
Did you really try to delete the kdenliverc? It's at .kde/share/config/kdenliverc in your $HOME

EDIT: if you upgraded from an earlier Ubuntu release, it might be at .kde4/share/config/kdenliverc

Delete it, then try again. If Kdenlive starts, but you get the "missing SDL" warning, see the workaround above.

It wasn't at the location you mentioned. I deleted the file in usr/lib/frei0r-1.

I never got a message telling something about SDL. It only mentions that this libmlt thing can't be found...

Well, the reference to the "missing SDL" error message was for the case that my last hint would make it work, sort of. But it didn't, obviously ;)

Could you send the output of 'ls /usr/lib/libmlt* ; ls /usr/local/lib/libmlt*' please? Synaptic won't tell you if the files it *thinks* are there really *are* there. And could you look up which version of kdenlive is installed? Not just the main version (0.7.3, 0.7.4), but the whole package version string (e.g. 0.7.3-0ubuntu2). That info would be of great help.

My guess is that the libmlt (it's files, not the package) either isn't there, or the wrong version is installed. But I might be wrong.

And just to make sure: you're using the 32bit version of Ubuntu, right?

Here is the output from that commandline:
daryl@daryl-desktop:~$ ls /usr/lib/libmlt* ; ls /usr/local/lib/libmlt*
/usr/lib/libmlt.so /usr/lib/libmlt++.so.0.4.2
/usr/lib/libmlt++.so /usr/lib/libmlt++.so.2
ls: cannot access /usr/local/lib/libmlt*: No such file or directory

The version installed is "0.7.4-0ubuntu3~lure~jaunty3".

That's right, I'm using the 32-Bit version.

Well, the mlt stuff seems to be alright. I'm running out of ideas here. Time to start from scratch, I guess:

1) remove the PPA repository for kdenlive; then update the package archive
2) purge everything libmlt, this will also remove packages that depend on it, but that's exactly what we want
3) remove any leftover kdenliverc and kdenlive directories under .kde
4) purge frei0r-plugins, swh-plugins
5) do a sudo apt-get autoremove --purge
6) install kdenlive (this will be the 0.7.3 package), try it out, if it works
6a) add swh-plugins, frei0r-plugins back in one by one to see if it works

If this still doesn't work, you could try the kdenliveBuilderWizard. And if this still doesn't work, I don't know what will.

Could you tell me what "Purge" means? :o

--purge means that any configuration files of a package are removed as well, not just binaries and other data. (See man dpkg)

EDIT: It's recommended to check the list of packages that are selected for removal when using autoremove!

Wow, thanks! It works now. ^__^
I purged everything you told me to, and then installed kdenlive again (0.7.3). Now it's working =)